Buried Piping

Tutorial for Buried Piping Modeling and Analysis using CAEPIPE
The following are the Steps to perform Buried Piping Modeling and Analysis using CAEPIPE.

General

In CAEPIPE, Soil in Buried piping analysis is modeled using bilinear restraints with an initial stiffness and an
ultimate load. After the ultimate load is reached, the displacement continues without any further increase in load,
i.e., the yield stiffness is zero. The initial stiffness is calculated by dividing the ultimate load by the yield
displacement which is initially assumed to be D/25 where D is outside diameter of the pipe.

Soil modeling is based on Winkler's soil model of infinite number of closely spaced elastic springs. Soil stiffness is
calculated for all three directions at each node. Pressure value in the load is suitably modified to consider the
effect of static overburden soil pressure. Model is analyzed for operating (W+P1+T1) condition and the
displacements in the three global directions are noted. A check is made for whether skin friction is mobilized and
the soil has attained the yield state. If true, then the spring is released in that direction indicating that soil no
longer offers resistance in that direction. This modified model is again analyzed and checked for yield stage. The
iterative process is continued till the percentage difference between displacements at each node for two
successive iterations is less than 1%. The final stiffness in each direction is the true resistance offered by the soil
to the pipe in that direction.

From the above, you may note that elastic springs representing the soil stiffnesses in the Global X, Y and Z
directions are to be added at as many nodes in the buried portion of the Stress model as required to simulate
Winkler’'s soil model. So, it is important that even long buried straight pipes are discretized so that such elastic
springs are added at all intermediate nodes generated along those long straight pipes. In addition, it is at the
bends, elbows, and branch connections that the highest stresses are found in buried piping subjected to thermal
expansion of the pipe. These stresses are due to the soil forces that bear against the transverse run. The
stresses are proportional to the amount of soil deformation at the elbow or branch connection. Hence, before
performing the analysis, discretize the stress layout as given below.

1. Piping elements at the junction of bends, elbows, and branch connections can be refined through Layout
window > Edit > Refine Nodal Mesh > Buried Piping, and

2. Long pipe sections can be discretized manually through Layout Window > Edit > Multiple Split.

When the refinement length for adding intermediate nodes on long buried straight pipes is not known, then the
influence length used to refine pipes near bends, elbows and branch connections can be used to split long
straight pipes. Details on computing Influence length is given below.

Modulus of Subgrade Reaction (k)

This factor k defines the resistance of the soil or backfill to pipe movement due to the bearing pressure at the
pipe/soil interface. Several methods for calculating modulus of subgrade reaction (k) have been developed in
recent years. As per Trautmann, C.H., and O’Rourke, T.D., “Lateral Force-Displacement Response of Buried
Pipes,” Journal of Geotechnical Engineering, ASCE, Vol. 111, No. 9 Sep 1985, pp. 1077-1092, the modulus of
subgrade reaction, k, can be calculated as per Eq. (2) in Appendix VIl of ASME B31.1-2014 code.

k = C,N,wD
where,

Ck = a dimensionless factor for estimating horizontal stiffness of compacted backfill. C, may be estimated at 20 for
loose soil, 30 for medium soil, and 80 for dense or compacted soil. In the current version of CAEPIPE, the value
of Cy is internally set as 80 for both cohesive and cohesionless soil.

D = pipe outside diameter, in
w = soil density, Ib/in3

N;, = a dimensionless horizontal force factor from Fig. 8 of above stated technical paper. For a typical value where
the solil internal friction angle is 30 deg. the curve from Fig. 8 may be approximated by a straight line defined by
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Np, = (0.285H)/D) + 4.3

H = the depth of pipe below grade at the pipe centerline, in

Influence Length (L)

The influence length is defined as the portion of a transverse pipe run which is deflected or “influenced” by pipe
thermal expansion along the axis of the longitudinal run.

From Hetenyi’'s theory, (Beams on Elastic Foundation, The University of Michigan Press, Ann Arbor, Michigan
1967) (also, see Section VII-3.3.2 of Appendix VIl of ASME B31.1-2014 code)

Lo
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where,
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Pipe / Soil System Characteristics =

E = modulus of elasticity of pipe at reference temperature
| = moment of inertia of pipe cross section

k = modulus of subgrade reaction of soil as detailed above.

Tutorial

Snap shot shown below is a sample model for Buried Piping Modeling and Analysis.
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Step 1:

First define soils using the command Layout window > Misc > Soils.

Soil #1

Soil # 2

. {» Cohesive
Soil hame ’52'7 (" Cohesionless
Density [150 (b3
Stiength W [psi]

Ground level |3'3" [ft'in")

Walue entered is Depth of Soil above pipe
centerline

Include Insulation thickness for computing
maximum sail loads

oK I Cancel

, " Cohesive
Soil name |53 (* Cohesiorless
Density [150 (b3
Deka [30  [deg)
Ks |0.80
Ground level |6'6" [ft'in"']

Walue entered is Depth of Soil above pipe
centerline

Include Insulation thickness for computing
maximum soil loads

oK I Cancel

Two types of soils can be defined - Cohesive and Cohesionless.

Cohesive soil is hard to break up when dry, and exhibits significant cohesion when submerged. Cohesive soils
include clayey silt, sandy clay, silty clay, clay and organic clay.

Cohesionless soil is any free-running type of soil, such as sand or gravel, whose strength depends on friction
between particles.

Soil density and Ground level are input for both cohesive and cohesionless soils. The Ground level is used to
calculate depth of the buried section. For cohesive soil, Strength is the un-drained cohesive strength (Cs). For
cohesionless soil, Delta is angle of friction between soil and pipe, and Ks is Coefficient of horizontal soil stress.

Ground Level

Ground level for a soil is the height of the soil surface from the global origin (height could be positive or negative).
Itis NOT a measure of the depth of the pipe’s centerline.

In the figure, the height of the soil surface for Soil 1 is 3 feet from the global origin. Pipe node 10 [model origin] is
defined at (0,-5, 0). So, at Node 10, the pipe is buried 8 [= (3’ — (-5")] deep into the soil. Define similarly for the
other soil.

The pipe centerline is calculated by CAEPIPE from the given data.

4 ft. depth

Node 10
begins at begins at
(0,-50) | (0,-5,0)
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Depth of Soil above Pipe’s Centerline

When the option “Value entered is Depth of Soil above pipe centerline” is turned ON in Soil input then CAEPIPE
will compute maximum soil loads for the sections buried using the Depth entered. This option will be helpful for
modeling pipes that are running up or down a hill with same depth of soil filled above pipe’s centerline as shown
in the figure given below.

Hillcrest .y

Warning:

Assign Soil only to those elements that are really buried in soil when the option “Value entered is Depth of Soil
above pipe centerline” is turned ON.

Step 2:

Tie the soils defined above with pipe sections through Layout window > Misc > Sections or Ctrl+Shft+S (to list
Sections). Double click on the required section property. You will see the field Soil in the bottom right corner. Pick
the soil name from the drop-down combo box.

*I* Caepipe: Pipe Sections (10) - [BuriedPiping.mod (C:h\Tutorials\BuriedPipi...
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Section # 1 >

Section name (€] ¢ ANSI O DIN Q15 €150

Marninal diameter |Mon Std - Scheduls
Outzide diameter |30 [inch) Thickness |0.87402 [inch)

Corrogion allowance [inch) kill tolerance (5.0 [%]
Inzulation : Denzity [lbAft3] Thickness [inch)
Lining : Denzity [lbAt3] Thickness [inch)

ok | Cancel | Insulatiu:un| Soail |52 -

If a part of a piping system uses a certain pipe section with some portion of it buried and the balance not buried,
then two separate sections have to be defined, with one of them without soil and the other with soil.

Step 3:
Use the appropriate section for each element on the Layout window that is buried with this soil around it.
Step 4:

Review the stress layout by highlighting the buried sections of the model in graphics. If your model contains
sections that are above ground and buried, then you can selectively see only the buried sections of piping in
CAEPIPE graphics by highlighting the section that is tied to the soil. Use the Highlight feature under the Section
List window and place highlight on the buried piping section (see Highlight under List window>View menu, or
press Ctrl+H). The Graphics window should highlight only that portion of the model that is using that specific
section/soil. See the portion shown in green in the figure below.

=i Caepipe: Graphics - [BuriedPiping.mod (C:\Tuterials\BuriedPiping]]
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Step 5:

It is at the bends, elbows, and branch connections that the highest stresses are found in buried piping subjected
to thermal expansion of the pipe. These stresses are due to the soil forces that bear against the transverse run.
The stresses are proportional to the amount of soil deformation at the elbow or branch connection. Hence, piping
elements at the junction of bends, elbows and branch connections are to be refined in the stress layout.

This can be performed through Layout window > Edit > Refine Nodal Mesh > Buried Piping. Please see the
section titled “Buried Piping” in CAEPIPE User’s Manual for details on “Nodal mesh generation”.
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Step 6:

Now, to best simulate Winkler's soil model, discretize even the remaining long straight buried pipe sections in the
stress layout as detailed below.

Starting CAEPIPE Version 10.30, a feature was included to discretize the long straight buried pipe sections
through Layout Window > Edit > Refine Nodal Mesh > Buried Piping. In other words, the procedure listed below in
this step is done automatically using this command.

In CAEPIPE Version 10.20 or earlier, long straight buried pipe sections in the stress layout need to be discretized
manually using “Multiple Split...” command available through Layout Window > Edit.

For example, a long pipe section at row #3 is split as given below. Since the split length is not known, Influence
Length is calculated as explained above by obtaining the properties required from the CAEPIPE model. The
resulting length is then used to split the long pipe section.

Density of soil S2 = 150 Ib/ft3 = 0.087 Ib/in3

As explained above, dimensionless factor (Ck) is taken as 80 for cohesive and cohesionless soil.
Pipe OD (D) for element at row #3 = 30”

Pipe ID (d) for element at row #3 = 30”- (2 x 0.874) = 28.252”

being a sloped pipe, the average height at the middle of the pipe is considered as given below

H = Depth of Pipe below grade = 3'3” + (11’ + 3’)/2 = 10’3” = 125”

Nh = (0.285H)/D) + 4.3 = (0.285 x 125”/30”) + 4.3 = 5.4875
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Modulus Subgrade Reaction = k = C.N,.w.D = 80 x 5.4875 x 0.087 x 30 = 1145.79 psi
Moment of Inertia (1) = PI1()/64 x (D4 — D"4) = (3.14/64.0) x (3074 — 28.252"4) = 8487.99 in4

Modulus of elasticity of Pipe at Reference Temperature (E) = 30.8E+6 psi

k

1/4
o so L _PE [4EI }
Pipe / Soil System Characteristics = =[1145.79 / (4 x 30.8E+6 x 8487.99)]"1/4 = 0.0057
37
L —

= —
Influence Length (L) = 4B - 3x3.14/(4x0.0057) =413 in

Based on the above, number of splits = (Total Length / 413) + 1 = (1758 / 413) + 1 =5.25=6

Now, split the long pipe element using the command Layout Window > Edit > Multiple Split... by highlighting the
pipe element at row #3.

Split Row # 3

Pipe From 10 To 20
Length = 146.5040 [ft'in")

Intermediate Starting Mode | 20000
Node Increment |10
Mo. of Splits |6

0K | Cancel |

Follow the same procedure to split other long buried straight pipe sections in the stress model.
Step 7:

Save the refined model as “BuriedPipingRefined_StPipes.mod”. Analyze the model through File > Analyze. Upon
successful analysis, CAEPIPE displays an option “Soil Restraints” in addition to other analysis results.

Results
" Sorted stresses (" Support load summary
" Code compliance (" Support loads
" Flange repart " Element forces
" Rat. equip report " Displacements

% Soil restraints

Ok, | Cancel




Buried Piping
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# |From |To Mame | Type Stiffness | Max Load | Stiffness | Max Load | Stiffness [ Max Load | Stiffness | Max Load

(Ibinch) | (Ib) (Ibfinch) | (Ib) (Ibinch) | (Ib) [b/inch) | (Ib)
1 10 20000 |[S2 Cohesive 12484 | 14981 7.826E+6 (9330709 |4.306E+6 (5166812 |7.701E+E | 9240631
2 20000 |20010 |S2 Cohesive 12484 [14981 8.072E+6 | 9686963 |4.310E+6 | 5171866 | 8.028E+6 | 9633850
3 20010 (20020 |52  |Cohesive 12484 |14531 8.319E+6 | 9983217 | 4.314E+6| 5176920 | 8.356E+6 | 1.00E+7
4 20020 120030 |52 Cohesive 12484 |14981 B.56BE+6 | 1.03E+7 |4.318E+6 5181974 |5.684E+6 | 1.04E+7
5 20030 |20040 |52 Cohesive 12484 |14931 8.813E+6 | 1.06E+7 |4.323E+5|5187025 |9.011E+E|1.08E+7
B 20040 |20 52 Cohesive 12484 (14981 060E+6 [ 1.09E+7 |4.327E+6 | 5192079 |9.339E+6 | 1.12E+7
7 20 30 52 Cohesive 25564 | 30677 | 1.886E+6| 2262834 [BBE519 (1063823 |1.953E+6| 2343343
8 30 40 52 Cohesive 2556.4 |3067.7 | 1.89BE+E| 2275256 |886696 | 1064035 |1.967E+E | 2359831
3 40 50 52 Cohesive 2556.4 | 3067.7 | 1.90BE+6| 2287679 |886872 |1064247 |1.980E+6 | 2376319
10 |50 g0 52 Cohesive 25564 | 30677 | 1.917E+6| 2300101 [BB7049 (1064459 |[1.994E+E| 2392808
11 |&0 70 52 Cohesive 25564 30677 | 1.927E+6| 2312624 (887226 (1064671 |2.008E+E | 2409296
12 |70 a0 52 Cohesive 2556.4 |3067.7 | 1.937E+6|2324946 |887402 |10B64883 |2.021E+E | 2425785
13 |80 904, 52 Cohesive 12021 |14426 | 914660 1097592 (417359 |500830 |955347 (1146416
14 |90B 100 52 Cohesive 21034 |25240 |1.660E+6|1992143 [707549 (849059 |1.694E+E6| 2032874
15 |100 110 52 Cohesive 25564 |30676 | 2123E+6|2548164 (861681 (1034018 |2.195E+E | 2633760
16 |110 120 52 Cohesive 2556.4 | 30676 |2240E+6)|2687480 |863598 |1036317 |2.344E+E | 2812676
17 |120 130 52 Cohesive 25564 | 30676 | 2356E+6|2826795 |865514 1038617 |2.493E+6 | 2991591
18 130 140 52 Cohesive 25564 (30676 | 2472E+6| 2966111 (867431 (1040917 |2.642E+E| 3170506
19 |140 16504 (52 Cohesive 8076  [9691 804987 |965984 | 274429 |329315 | 865665 | 1038786
20 |150B 160 52 Cohesive 17258 |2071.0 1.758E+6 | 2109735 (606923 | 728307 |1.963E+E|2356210
21 |160 170 52 Cohesive 2556.4 |3067.6 | 2604E+6)3125043 |899004 |1078805 |2.907E+E | 3488652
22 |170 180 52 Cohesive 22813 |27375 | 2324E+6| 2788760 [B02263 (962716 |2594E+6| 3113242
23 |180 140 52 Cohesive 7129 [8555 726244 1871492 | 250709 | 300880 810745 |972893
24 l1an 20n =) Cohaciua aca®  |11874  lagossa |117ane2 l22a1an lanmnoe 14 nazcael121eom Y




