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Disclaimer 

Please read the following carefully: 

This software and this manual have been developed and checked for correctness and accuracy by SST 

Systems, Inc. However, no warranty, expressed or implied, is made by SST Systems, Inc. as to the 

accuracy and correctness of the manual or the functioning of the software and the accuracy, correctness 

and utilization of its calculations. Users must carry out all necessary tests to assure the proper 

functioning of the software and the applicability of its results. All information presented by the 

software is for review, interpretation, approval and application by a Registered Professional Engineer. 

CAEPIPE and CAdvantagE are trademarks of SST Systems, Inc. All other product names mentioned in 

this document are trademarks or registered trademarks of their respective companies/holders. 
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Thank you for licensing CAEPIPE (pronounced kay-pipe), the simple yet powerful software 
for solving a variety of piping design and stress analysis problems in numerous industries 
listed below. 

Power(fossil & nuclear) Oil & Gas production (onshore & offshore) 
Refinery Chemical & Petrochemical 
Fertilizers Pharmaceutical 
Sugar  & Food Processing Paper & Pulp 
Steel / Metal Process Water & Waste Treatment 
Aircraft and Aerospace Building Services 
Defense Industries Ship Building 

CAEPIPE performs linear and nonlinear static and linear dynamic analyses of piping systems 
by imposing various loads such as deadweight, thermal, seismic, wind, spectrum, time history 
or harmonic, and calculates displacements, forces, moments, stresses, support loads etc. 
Further, it checks whether the piping system is piping code and guideline compliant (ASME, 
B31, European, Swedish, API 610, etc.) and produces concise, formatted and easy to 
understand reports. 

For rapid modeling, CAEPIPE offers you a friendly and productive user interface that 
rigorously adheres to Windows standards. Open up to four windows simultaneously to get 
feedback on different aspects of the model. Extensive graphical display capabilities allow you 
to zoom, pan, rotate the image and see the model from different viewpoints. CAEPIPE uses 

the industry standard OpenGL® to render 3D images realistically for easy visualization. As 

the model is input and modified, CAEPIPE updates the graphics simultaneously to provide 
visual feedback. It animates deflected shapes and mode shapes, and shows color-coded stress 
contours, among others. 

A true powerhouse in its speed of operation, CAEPIPE uses advanced Windows 
programming techniques such as intelligent repainting, scroll box tracking, multithreading, 
memory-mapped files for faster data access, among others, to make your job easier and 
faster. Every effort is made to keep the program and data file sizes small (e.g., program size is 
~2 MB! And a 665-element piping model is 85 KB!). 

Many thoughtful and useful details in the program allow you to work more productively. For 
example, you can annotate your model with copious comments for enhanced 
documentation, or duplicate repetitive input with one hotkey combination or rotate sections 
of the model with one operation. No unnecessary buttons clutter the toolbar nor are you 
forced to use a mouse unnecessarily. The many thoughtful keyboard shortcuts, too, add to 
your productivity. 

Overall, CAEPIPE stands peerless among the tools available today for piping design and 
stress analysis. We invite you to explore the software so that you can make full use of its 
capabilities. Our friendly and knowledgeable support engineers are available to assist you. 
Should you need to reach them, please email:  support@sstusa.com. 

Two sections make up this manual: 

1. Explanation of menus from the different CAEPIPE windows,  
2. Appendices with related information.  

The manual ends with an index. 

file:///C:/Users/PC/Desktop/ULTRA%20CURRENT%20PROJECT/support@sstusa.com
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The full version of CAEPIPE is supplied with either of two protection schemes viz 
Hardware Protected Key or a Software Protected Key. For both the Hardware Protected 
Key and Software Protected Key versions of CAEPIPE, installing requires two steps: 

1. For the Hardware Protected Key, install the hardware key driver or for the Software 
Protected Key install the SST License Manager (SSTLM). 

2. Install the CAEPIPE software. 

Follow the Installation Instructions provided by SST Systems, Inc. via email as the 
CAEPIPE setup files for the Hardware Protected Key and Software Protected Key are hard 
coded to the specific serial number assigned to your company. 

CAEPIPE with Hardware Protected Key  

The Server machine hosts the CAEPIPE license via USB Hardware Protected Key and can 
also have CAEPIPE software installed. This machine can be any computer connected to a 
network. 

1. Download the “Sentinel Installer (exe)” or “Sentinel Installer (zip)” file using the 
link https://www.sstusa.com/support-mes.php to the server machine where the 
CAEPIPE USB Hardware Protected Key will be residing. 

2. Double Click on the executable and follow all instructions to complete the 
installation of the hardware key driver. 

3. Insert your hardware key into the USB port. 

4. On the server machine, configure your firewall to allow all In-Bound and Out-
Bound network traffic on UDP Port 6001. Please visit our SuperProNet Firewall 
Configuration page for more details. 

5. Download the CAEPIPE setup file (.exe or .zip) from PEXit, using the installation 
instructions provided by SST Systems, Inc. via email. 

6. Unzip the downloaded file. Double Click on "Setup.exe" to open the installation 
menu. 

7. Identify the client machine(s) and Install CAEPIPE by following all instructions 
to complete the installation. 

8. Create NSP_HOST environment variable to connect server machine hosting 
CAEPIPE license via Hardware Protected Key to the client machine. Please visit our 
NSP_HOST Configuration page for detailed instructions on how to do this. 

CAEPIPE with Software Protected Key [SST License Manager (SSTLM)] 

1. Download the SST License Manager (SSTLM) from PEXit, using the installation 
instructions provided by SST Systems, Inc. via email.    

2. Unzip the downloaded file.  Double Click on “Setup.exe” to open the installation 
menu.  

3. Follow all the instructions to complete the installation of SST License Manager. 

https://www.sstusa.com/support-mes.php
http://www.sstusa.com/caepipe-firewall.php
http://www.sstusa.com/caepipe-firewall.php
http://www.sstusa.com/caepipe-nsphost.php
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4. For a Network configuration, on the server machine where SSTLM is installed, 
configure your firewall to allow all In-Bound and Out-Bound network traffic on 
TCP Port 12000. This also needs to be done on any client machines where 
CAEPIPE will be installed. 

5. Download the CAEPIPE setup file (.exe or .zip) from PEXit, using the installation 
instructions provided by SST Systems, Inc. via email. 

6. Identify the client machine(s) and Install CAEPIPE by following all instructions 
to complete the installation. 

7. Create SSTLM environment variable to connect server machine hosting 
CAEPIPE license to client machine(s). Please visit our configuration page 
http://www.sstusa.com/sstlm-variable.php for details on setting this variable. 

8. Create SKIPIP environment variable, if needed and set the value to "YES”. This is 
typically used on laptops where CAEPIPE might be used in a different network 
environment with a different TCP/IP address (i.e. at the office/at home/on a project 
site).This should also be used if your machine (where SSTLM is installed) is 
configured to obtain the IP Address automatically from a DHCP server, then user 
should disable the feature of checking the IP Address by defining an environmental 
variable with name “SKIPIP” and setting its value as “YES”. Please visit our 
configuration page http://www.sstusa.com/support-install2.php for details on 
setting this variable. 

For more details on installing the driver for the Hardware Protected Key or installing the 
SST License Manager (SSTLM) for the Software Protected Key scheme, please refer to the 
documentations that are available at the link http://www.sstusa.com/support-install.php. 

Installing CAEPIPE  

To install CAEPIPE, double click on setup executable. 

You will now see the following interactive screens one after another in which you will have 
to answer the usual installation questions. Respond appropriately. 

 

http://www.sstusa.com/sstlm-variable.php
http://www.sstusa.com/support-install2.php
http://www.sstusa.com/support-install.php
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Click Next to continue. 

You must accept the terms of the License agreement by clicking on Yes before proceeding. 

 

A copy of the license agreement (PDF file) is available on the distribution. 

We recommend installing the software to the default folder shown during installation. If you 
have previous installations of CAEPIPE, it will be helpful to name the Start menu folder 
differently for the new version (e.g., 1050 for version 10.50). 
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Once you have picked your choices, you can now begin to install by clicking on “Install” 
button or use the “Back” button to return to previous screens to change your choices. 

 

After installation, you can execute CAEPIPE by double clicking on the Desktop icon or by 
selecting CAEPIPE from the newly created CAEPIPE folder on the Start menu.  

To uninstall CAEPIPE from your Windows 8 and Windows 10 computer, select the option 
“Uninstall” through Start > CAEPIPE > Mouse right click on CAEPIPE executable as 
shown below. 

 

To uninstall CAEPIPE from your Windows versions earlier than Windows 8, select Uninstall 
CAEPIPE from the CAEPIPE folder on the Start menu.  
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Menus 
This section explains the commands under the different menus in the four independent 
CAEPIPE windows: Layout, Graphics, List and Results. Each window contains its own 
menu and toolbar. 

Many commands have keyboard shortcuts, shown next to the Command in the drop-down 
menu and also in online Help. 

The menu items (commands) are shown as 

.Command. 

For the dialogs, the tabs are shown as 

.Tab. 

and the buttons are shown as 

.Button.  
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The Main window is the first window you encounter when you start CAEPIPE. 

 

File Menu 

This menu contains commands to open files and set user preferences. 

 

.New (Ctrl+N). 

This command opens a New File type dialog window.  You can create any of the following 
file types associated with CAEPIPE from this window. 
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Model (.mod) - Creates a blank layout in CAEPIPE for a new piping model file. 

Material Library (.mat) - Creates a user-defined material library. 

Spectrum Library (.spe) - Creates a user-defined spectrum library. 

Valve Library (.val) - Creates a user-defined valve library. 

Beam SectionLibrary (.bli) - Creates a user-defined beam section library 

Flange Qualification (.flg) - Creates a new file for flange qualification. 

Nozzle Evaluation (.noz) - Creates a new file for nozzle evaluation. Refer to Technical 
Reference Manual for details. 

Lug Evaluation (.lug) - Creates a new file for lug evaluation. Refer to Technical Reference 
Manual for details. 

.Open (Ctrl+O). 

From the Open command you can open any number of CAEPIPE compatible files. 
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Model files (*.mod) - Opens CAEPIPE Model files 
Results files (*.res) - Opens CAEPIPE Results files 
Material Library files (*.mat) - Opens CAEPIPE Material Library files 
Beam Section Library files (*.bli) - Opens CAEPIPE Beam Section Library files 
Material Library files (*.mdb) - Opens CAEPIPE old Material Library files created using 
4.x versions of CAEPIPE. If any modification is done to a .mdb file, the modified version is 
always saved in .mat format. 
Spectrum Library files (*.spe) - Opens CAEPIPE Spectrum Library files 
Valve Library files (*.val) - Opens CAEPIPE Valve Library files 
Flange Qualification files (*.flg) - Opens Flange Qualification files 
Nozzle Evaluation files (*.noz) - Opens Nozzle Evaluation files 
LugEvaluation files (*.lug) - Opens Lug Evaluation files 

.Open last model (Enter). 

This command can be useful when you need to open the same model repeatedly. Simply 
pressing Enter from the Main window will open the model for you. There is no need to go 
through the Open File dialog. 

.Import. 

You can import a CAEPIPE neutral file (.mbf), an Algor (Autodesk) PipePakneutral file 
(.pnf) or a COADE (Intergraph) neutral file (.cii) by using this command. 

See Appendix A for details. 

http://www.sstusa.com/downloads/ReadmeSupplement_v65.pdf
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.Preferences. 

Use this command to set your preferences for automatic saving and backup of the model, 
setting text and graphics fonts and toolbar preferences. 

Preferences command has three tabs - Backup, Fonts and Toolbar. 

.General. 

 

Make backup copy 

With this checked, every time you save your model, CAEPIPE copies the previously saved 
model data to another file (for backup, with a .bak extension). You can select the location 
where you want these files saved (click on Folder button). To open a backup file, rename the 
file to somename.mod before opening it in CAEPIPE. 

Disable Graphics Editing 

Graphics editing feature (in the Graphics window) can be turned ON/OFF from here. You 
may want to do this if your windows get garbled while using this feature.  

Automatic Save 

With this checked, and a time value entered, CAEPIPE will periodically save model data to a 
file named yourmodelname.sav, in the directory pointed to by Folder, or to untitled.sav. 

If the software or hardware crashes, you can easily retrieve the most recently saved data. 
Locate the file (yourmodelname.sav) and rename the extensionfrom .savto .mod before 
opening it in CAEPIPE. 

.Folder.  

Select any folder to which you (as a user) have write permission to. Please make sure you 
check with your system administrator. CAEPIPE will try to issue you a warning if the folder 
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you selected does not have write permission. <Default> points to the folder that contains the model 
file (.MOD). 

Example: You can specify a new folder called CAEPIPE.BAK as a backup and save folder, 
so that CAEPIPE writes all backup files (.bak) and timed saves (.sav) to this folder. 

Automatic Renumbering of nodes 

When you delete (an) existing node(s) from a model in Layout, CAEPIPE automatically 
renumbers nodes sequentially from the “Starting Node Number” you specify. So, if you do 
not want CAEPIPE to automatically renumber nodes when you delete any node in the 
Layout window, uncheck this option here. Also note that the renumbering operation upon 
node deletion is instantaneous, making it hard to identify which rows changed. 

Continuous Rendering while modeling 

You can turn ON or OFF the continuous rendering mode for Graphics. This feature will 
work when the Layout Frame is active. When turned ON, the user  can specify the RGB 
color for highlighting the current element or data by specifying the value in the fields 
provided. 

.Fonts. 

 

.Text.  

Select a font face, font style and size to use inside all CAEPIPE text windows (Layout, List 
and Results). 
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.Graphics.  

Select a font face, font style and size to use inside the Graphics window. 
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.Toolbar. 

 

Show 

You may choose to display or not display the toolbar in CAEPIPE windows. 

Large Buttons 

Two sizes for toolbar buttons are available. Selecting this command will show the toolbar 
with large buttons. 
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Help Menu 

From any CAEPIPE window - Main, Layout, List, Graphics or Results, you have access to 
the same Help menu. 

 

.Help. 

Clicking on Help command opens the CAEPIPE on-line help file. 

Note: 

Microsoft Windows 10 has discontinued the feature of opening .hlp file. Hence, clicking this 
“Help” option in Windows 10 will open the link https://support.microsoft.com/en-
us/help/917607/error-opening-help-in-windows-based-programs-feature-not-included-or-
help-not-supported. 

.Tutorial. 

We have three tutorials that are accessible from Start Menu > CAEPIPE: 

1. Basic Pipe Stress Analysis Tutorial (Basic_Pipe_Stress.pdf) 
2. Tutorial 1 (Tutorial_1.pdf) 
3. Tutorial 2 (Tutorial_2.pdf) 

The CAEPIPE Tutorials are available separately as an Adobe Acrobat (PDF) file. If you 
can’t locate them inside your CAEPIPE program files folder, then visit our web site 
www.sstusa.com to get a copy. 

.About. 

 

The About command shows the program version number and (your)hardware key serial 
number if the hardware key was supplied at the time of software delivery. Our support staff 
might ask for this information when you contact them. 

Also from the “About” dialog, you can access the SST website by clicking on 
www.sstusa.com or send email to Technical Support by clicking on support@sstusa.com. 

https://support.microsoft.com/en-us/help/917607/error-opening-help-in-windows-based-programs-feature-not-included-or-help-not-supported
https://support.microsoft.com/en-us/help/917607/error-opening-help-in-windows-based-programs-feature-not-included-or-help-not-supported
https://support.microsoft.com/en-us/help/917607/error-opening-help-in-windows-based-programs-feature-not-included-or-help-not-supported
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The text window displayed (that contains the piping layout) when you open a piping model is 
called the Layout window. 

A Layout window, as the name indicates, allows you to create or modify the layout of your 
piping system. 

Other things you can do here are: 

 Specify material types, pipe sections and loads. 

 Use some graphics features (zoom all, viewpoint, etc.) to view the model. 

 Define analysis options such as piping code to use, reference temperature, cutoff 
frequency for mode extraction, as well as set units, etc. 

 Define load cases (Sustained, Expansion, Response Spectrum, etc.) for analysis.  

In the Layout window, the row you are working on is highlighted by the yellow highlight bar 
(in figure below, the highlight is on the Title row). The following illustration names the 
different fields in the Layout window. Presently, there are ten fields (columns) in the Layout 
window. 

The Header row with column headings (see “Clickable Header row” in the illustration) is a 
special row that allows you to click on it to perform a related operation. For example, you 
can click on Type to show Element types. 

 

Description of Fields (numbers in parentheses refer to numbers in the illustration above). 

# (Row Number) 

The first field contains the row number, automatically incremented and non-editable. 

(1) Node 

This is the node number field where you type in node numbers as you model the piping 
system. The numbers should be numeric except when you are using internally generated 
nodes (A, B, C, D, & J) and absolute coordinate nodes. 

To define an absolute coordinate of a Node, * should be prefixed with the Node number. 
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Nodes with suffix “A” and “B”refer to the end nodes of the curved portion of the bend 
called the near and far ends.  

Similarly, Nodes with suffix “C” and “D” refer to the end nodes of the curved portion of the 
jacketed bend called the near and far ends and Node with suffix “J”refers to the end node of 
a jacket pipe. 

To change an existing node number, click in this field and use Backspace or Delete key and 
type in a new node number. Press Tab or Enter and confirm the change. 

You need not enter each node number. It is automatically generated when you press Tab to 
move to the next field. You can set an increment under the menu Options > Node 
increment command. 

(2) Type 

This is the element type field. An element (in-line) is a fitting or a component between two 
nodes. This could be a pipe, a bend, a valve, an expansion joint or most items listed under 
the Element types dialog. See a description later in this section under Element Types. 

(3) DX, DY, DZ 

These fields are offsets (also called relative coordinates) in the three global X, Y and Z 
directions. They are measured from the previous node’s location. 

Offsets are components of lengths of elements (exceptions are zero-length elements like a 
ball and a hinge joint). For example, the offsets for a 6 feet long pipe routed 30 degrees to 
global X-axis (in X-Y plane) are: DX=5.196 ft. (6 * cosine 30°), DY=3 ft. (6 * sine 30°). 

If the element is in a skewed direction, then calculate the X, Y and the Z components (using 
basic trigonometry) and input them here or use the Slope command to have CAEPIPE 
calculate the components. 

When you specify values for the DX, DY and DZ fields for a “From” element type row, 
they are treated as (absolute) coordinates of the node rather than (relative) offsets from the 
previous node. If the model begins at the global origin (0,0,0), you do not need to specify 
coordinates for the first “From” node. For any other “From” row with a previously defined 
node number, you do not need to enter coordinates either because CAEPIPE already knows 
the coordinates of this node (for example, node 30 on row 8 in the previous figure). 

The offsets can be positive or negative, depending on the way you route your piping.  

Alternatively, you can also enter absolute coordinates of a Node directly in the layout by 
adding “*” following the “Node” number in the Node field instead of calculating DX, DY 
and DZ. For example, with 20* in the Node field, enter the absolute coordinates X, Y and Z 
of Node 20 under DX, DY and DZ columns. 

The default number of decimals you can input for a length value is four. With an 
environment variable “INCREASE_DIGITS” set to “YES”, the number of digits you can 
input after the decimal can be increased to seven. This data can be printed other than to 
TXT and CSV formats.  
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(4) Matl (Material) 

Type in the material name of the material, you want to use for this element and subsequent 
elements until you want to change to another material for another set of elements.  See Find 
and Replace command under Layout window > Edit menu, for editing options. 

(5) Sect (Section) 

Type in the section name of the pipe section you want to use for this element and 
subsequent elements until the pipe section changes.  See Find and Replace command under 
Layout window > Edit menu, for editing options. 

(6) Load 

Type in the load name of the load you want to use for this element and subsequent elements 
until the load (temperature and/or pressure) is modified.  See Find and Replace command 
under Layout window > Edit menu, for editing options. 

(7) Data 

Use this field to enter data items at a node such as anchors, flanges, nozzles, hangers, SIFs, 
etc. See Data types below for how to specify an item. 

(8) Comment 

You can include a comment anywhere you like in the Layout window by simply pressing “c” 
(first) on an empty row at node column. You can use this feature to annotate the model with 
notes. Comments print along with the layout data so you can use this feature to document 
(revisions to) the model. 

A specialized form of a comment can be entered to input a Hydrostatic test load by pressing 
“h” first on an empty row at node column. 

A hydrostatic test is a way in which pipelines are tested for strength and leaks. The test 
involves filling the pipe system with a test liquid, usually water, which may be dyed to aid in 
visual leak detection to the specified test pressure. 

The Hydrostatic load is applied to the model from that row onwards until modified again (in 
the next figure, the Hydrostatic load is applied to model from row 8 onwards). When a 
Hydrostatic load is defined, CAEPIPE will automatically include a new load case 
“Hydrotest” under Layout window > Loads > Load cases. 

 

  

https://en.wikipedia.org/wiki/Pipeline_transport
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Menu bar 

 

File menu: 

 Standard file operations with a few special ones to note - Open Results (model file 
(.mod) must be present for this operation), Print (to file), Analyze (model), QA 
Block, Recently opened file list. You can open not only the CAEPIPE model files, 
but also material and spectrum library files, and the CAEPIPE Results files. 

Edit menu: 

 You can edit all types of data (elements, supports, range of rows) from here. Use Ctrl 
T to edit element (bend, valve), Ctrl D to edit Data (flange, anchor). You can change 
properties for groups of elements, split elements and generate copies of existing 
rows.  

View menu: 

 Mainly for Graphics (Viewpoint, Previous view and Zoom All). Other functions are 
to open the List window (Ctrl L) by selecting one of the displayed items, and search 
for a node number. 

Options menu: 

 For setting Analysis options such as Piping code, Reference Temperature, Pressure 
correction, cutoff frequency for mode extraction, etc., set Units (SI, Metric, English 
or a combination), and customize the look of CAEPIPE by choosing a display font. 

Loads menu: 

 Set the load cases for analysis, and specify loads for the model such as static seismic, 
wind, spectrum, time history, etc.  

Misc menu: 

 View model coordinates, define/view materials, sections, loads (also for beams), 
pumps, compressors and turbines, time functions and spectra. 

Window menu: 

 From here, you can move the focus to another window (such as Graphics or List). 
F2 will move focus between text and Graphics windows and F3 between open text 
windows. The real advantage of these hotkeys (F2 and F3) is for users who have a 
smaller monitor and work with maximized windows for input, list, graphics and 
results. In such a setting, one key press (F2 or F3) will quickly move the focus to 
another window (without having to either minimize the one where the focus is or 
switch windows through the taskbar).  

Help menu: 

 For on-line help and information pertaining to the remaining period of your yearly 
Maintenance, Enhancement and Support (ME&S) agreement with SST.  
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Toolbar 

 

The toolbar presently is organized into three groups: File, Window and Graphics operations. 

 File operations are New (model), Open (a model), Save (model), and Print.  

 Window operations are (move focus to) Graphics window, (move focus to) List 
window (if open), and display a dialog of List of items to show an item in the List 
window.  

 Graphics operations are Viewpoint and Zoom all.  

In the opening window (when you first start CAEPIPE), there is a button to open the last 
opened model file (hotkey: Enter). This is not available from other windows. 

Hotkeys You Can Use 

You can use following hotkeys in the Layout window: 

Tab Move cursor from field to 
field (left to right) 

Home Move cursor to the first 
character in a field 

Shift Tab Same as Tab but right to left End Move cursor to the last 
character in a field 

Page Up Move highlight up one page Ctrl+Home Top of model 

Page Down Move highlight down one 
page 

Ctrl+End End of model 

Delete/BkSp Delete characters Arrow keys Move highlight one 
row/field at a time 

Ctrl+Insert Insert an empty row Ctrl+X Delete a row 

Ctrl+Enter Duplicates last layout row. 
Applicable only for 
Beam/Pipe/Jpipe 

F1 Help 

F2 Graphics window F3 List window 
Ctrl + Up Increase font size in all 

CAEPIPE text windows 
(Layout, List and Results). 

Ctrl + Down Decrease font size in all 
CAEPIPE text windows 
(Layout, List and Results). 

Other hotkeys are listed under menus.  

Hotkey combination: CTRL+ENTER (for duplicating the last layout row) works for Beam 
Elements (in addition to PIPE and JPIPE). 

Function Keys 

F1: Opens on-line help. 

F2: This key moves the focus to and from the Graphics window. 

F3: This key moves focus to and from the List window. 

F4: Opens the Viewpoint dialog which you can set for the Graphics window. 

F5: This function key restores the Graphics window to the previous graphics view. 
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List (Ctrl+L) 

List is a powerful feature that helps you see itemized lists of information in the model. All 
input data can be viewed through this command. For example, you can view all elements and 
data types specified in the model, list Coordinates of the nodes of the model, Specified 
displacements, Nozzle stiffnesses, Branch nodes, Threaded joints, Pumps, Turbines, 
Compressors, Materials, Sections and Loads, etc. 

This is a useful tool to verify information after modeling is finished, for example, to check 
whether all bends have the correct bend radius or whether limit stops are aligned in the 
correct directions or how many anchors have been specified in the model and so on. 

This command is “intelligent” in that the list dialog shows only those items that exist in the 
model. Consequently, List can display a small list or as comprehensive a list as shown in the 
next figure. 
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You can navigate through the different itemized lists by clicking on the two blue-colored 
arrows on the toolbar. 

Element types 

How to input an Element 

To input an element (between two nodes) in a new row, either right-click in the Type field of 
the row or left-click on Type (in the Header row) to display the Element types dialog (or 
press Ctrl+Shft+T). Select the element you want from this dialog to insert into the model. 

 

Notice the different types of elements available. Any of these can be input for “Type.” Some 
of these are strictly not elements such as From, Location, Comment and Hydrostatic test 
load. All of these have keyboard shortcuts. You do not have to necessarily open this dialog 
to input any of these. You can type the first letter or the first few letters (example: Be for 
bend, M for miter, V for valve, etc.) to input an element type. The keyboard shortcuts are 
listed below.  However, for Comment, simply press “c” (first) on an empty row, and for 
Hydrostatic test load, simply press “h” (first) on an empty row.  

Shortcut keys for Element types 

b (Tab) Bend  
ben Bend (no Tab required, and typing “ben” moves the cursor over to the DX field.) 
bea Beam 
bel Bellows 
ba Ball joint 
c Cut pipe (Cold spring) 
e Elastic element 
f From 
h Hinge joint 
j Jacketed pipe 

jb Jacketed Bend 
l (L) Location 
m Miter Bend 
P Pipe (you don’t have to type this because a Pipe is the default element type) 
r (Tab) Reducer 
re Reducer 
ri Rigid element 
s Slip joint 
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v Valve 
t Tierod 
Once input, each element name appears under the Type field. The only exception is the Pipe 
element which is indicated by a blank. For example, see the first annotated figure in this 
section. The field under Type is blank on the row that contains Node 30 signifying a pipe. 

How to change the Element type 

If you want to change a Valve element to an Elastic element, then you have to do the 
following: Move the highlight bar to the row that contains the Valve (or click once on 
Valve). Delete the word “Valve” (Backspace) and press “E”, confirm the change; 

or 

Assuming the highlight is on the Valve row, click on Type (in the header row) to display the 
Element types dialog and then select Elastic element from it. The Valve changes to an Elastic 
element after you confirm the change. 

How to change Element properties 

From the keyboard: Press Ctrl+T (from anywhere on the row) to edit the element. Note: A 
pipe has no editable property, and Ctrl+T does nothing. 

Mouse: Right clicking on the element gives you applicable choices. For example, for a Bend, 
you are shown Edit Bend and List Bends as the choices. 

Notes: 

1. A pipe element is the default element type. So, leave the element type blank for that row.  

2. An existing element type (say, a bend) cannot be changed to a Location type.  

3. To change the element type, you can erase (use Backspace or Delete key) the existing 
element and specify a new one (using accelerator key), or usemouse to specify another 
element by clicking on Type in the header row.  Or, use Ctrl+X to delete the entire row. 

Data types 

How to input a Data item 

When you want to input a support, a restraint, a flange, an SIF, etc., at a node, use the mouse 
or the keyboard (several key accelerators are available to make your job easy) to open the 
Data types dialog and select an item from it. 

Keyboard: Press Ctrl+Shift+D to open the Data types dialog to select an item, or, type one 
of the following keys (under Shortcut keys) that will automatically enter the respective Data 
type (press Ctrl D to position the cursor in this field): 

Mouse: To open the Data types dialog, 

 Left click on Data (in the header row), or  

 Right click in the Data column, or  

 Select Misc menu >> Data Types.  
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Shortcut keys for Data types 

a Anchor (rigid) 
br Branch SIF (Welding tee, Branch connection, etc.) 
c (Enter) Concentrated Mass 
conc Concentrated Mass 
cons Constant Support 
f (Enter) Flange 
fl Flange 
fo Force 

gu Guide 
ge Generic Support 
h (Enter) Hanger (to be designed) 
han Hanger (to be designed) 
har Harmonic load 
j Jacket end cap 
l (L) Limit stop 
n Nozzle 

r (Enter) Restraint (2-way), see also X, Y, Z below 
ro Rod hanger 
s (Enter) Skewed restraint 
sk Skewed restraint 
sn Snubber 
sp Spider 
th Threaded joint 
t (Enter) Time varying load 

ti Time varying load 
u (Enter) User hanger 
user s User SIF 
w Weld 

x X restraint (2-way) 
y Y restraint (2-way) 
z Z restraint (2-way) 
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Notice the different types available. For example, press “a” in the Data field to input an 
Anchor (you do not have to go through the long-winded mouse method of clicking on Data 
in the header row to display the Data types dialog, and then selecting Anchor from it). 

How to change the Data type 

Assume that you want to change an Anchor to a Nozzle. Before you change an existing Data 
type (Anchor), you have to delete it. 

To delete, click on Anchor, delete the word “Anchor” (backspace) or right click on the 
Anchor, and select “Delete Anchor”. Once deleted, then type “n” (for Nozzle). 

Alternately, with the cursor placed on the row for which you need to change the Anchor, 
click on Data on the header row, and pick Nozzle and confirm the change. 

How to edit the Data item’s properties 

To edit properties for anchors, flanges, etc. 

Keyboard: Press Ctrl+D (from anywhere on the row) to edit the item. Note: A Threaded 
Joint has no editable property, and Ctrl D does nothing. 

Mouse: Right clicking on the item gives you applicable choices. Example: For an Anchor, 
you are shown Edit Anchor. 

Notes: 

1. You cannot specify a data item for a Bend, a Miter Bend or a Jacketed Bend, as the node 
number is a tangent intersection point, and does not exist physically on the element. 
Instead, create an intermediate node for the Bend or Jacketed Bend and then specify a 
data item at the new node using Location type. You cannot create an intermediate node 
for a miter bend. 

2a. You can delete an existing data item at anytime: 
- Use the Delete or the Backspace key to erase the item and press Enter. 

 - Right click on the item and select Delete Item.  

2b. Alternately, to change the data type, you can erase (use Backspace or Delete key) the 
existing item and type a new one (using accelerator), or use the mouse to specify another 
data item by clicking on Data in the header row. 

  



Layout Window 

 

25 

Context Menus 

Context menus (right click menus) can be found everywhere in CAEPIPE. For example, 
when you right click on an Anchor, or a Bend, you are shown the following context menus. 
You can perform any listed action that more than often is a shortcut (e.g., Delete Anchor or 
List Anchors). 

 

 

Right clicking on DX/DY/DZ shows you, for example, Insert, Delete (rows), Split (an 
element) and (specify) Slope for an element. Right click in the Matl, Sect or Load column to 
see the respective context menu. 

Export data from CAEPIPE 

CAEPIPE has the in-built ability to Output (Export) model and/or results to the below 
stated formats at this time. 

1. Output model and results data to CSV (Comma Separated Values) and TEXT file 
format through File > Print > Print to file. For further details, see sections titled 
“Print Model” and “Print Results” in this manual.  

2. Output model and results data to PDF file format using a PDF utility such as 
“Microsoft Print to PDF”, “doPdf”, etc. through File > Print. For further details, see 
sections titled “Print Model” and “Print Results” in this manual. 

3. Output model data to MBF (Model Batch File) through File > Export to MBF… 
For further details, see section titled “Import/Export” in Appendix A of this manual. 
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4. Output model data to PCF (Piping Component File) format through Layout Frame 
> File > Export to PCF. For further details, see section titled “Import/Export” in 
Appendix A of this manual. 

5. Output model data to 3D Plant Design software PDMS, E3D and CADMATIC 
through File > Export to 3D Plant Design. For further details, see section titled 
“Export to 3D Plant Design” of this manual. 

6. Output Material library data to an ASCII file. For further details, see section titled 
“Export Material Library” in Appendix A of this manual. 

7. Output Time History results to CSV format through Results Frame > File > Export. 
For further details, see section titled “Export” in “Results Window File Menu” of 
this manual. 

8. Output Hanger Report to LICAD software format (via an ASCII file .cli) through 
Results Frame > File > Export. For further details, see section titled “Export” in 
“Results Window File Menu” of this manual. 

9. Output Deformed Geometry to 3D Plant Design software PDMS, E3D and 
CADMATIC while being in Displacements results through Results Frame > File > 
Export to 3D Plant Design. For further details, see section titled “Export to 3D 
Plant Design” in “Results Window File Menu” of this manual. 
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File Menu 

 

This menu contains commands for standard file operations with a few special ones to note: 

.Open (Ctrl+O). 

You can open the following CAEPIPE file types from the Open menu. 

1. Model files (*.mod)  

2. Results files (*.res)  

3. Material Library files (*.mat) 

4. Beam Section Library files (*.bli) 

5. Material Library files (*.mdb) [old format]  

6. Spectrum Library files (*.spe) 

7. Valve Library files (*.val) 

8. Flange Qualificationfiles (*.flg) 

9. Nozzle Evaluation files (.noz) 

10. Lug Evaluation files (.lug) 

For a description of each file type listed here, see subsection titled “File” under Section 
“Menu” above in this document. 
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.Open Results. 

This command opens the Results files (*.res). The corresponding model file (.mod) must be 
present in the same directory as the results file (.res). For your convenience, the Open 
Results dialog shows the results filename for the currently opened model if it is already 
analyzed; if not, the name of the last opened results file is filled in the name field. 

Note: 

Results file produced out of a specific CAEPIPE Version can be opened ONLY using that 
version of CAEPIPE / CAEPIPE Review / CAEPIPE Evaluation. For example, Results file 
produced out of CAEPIPE Version 10.30 can be opened only using CAEPIPE / CAEPIPE 
Review / CAEPIPE Evaluation Version 10.30. In other words, Results file produced out of 
CAEPIPE Versions earlier than 10.30 cannot be opened using CAEPIPE / CAEPIPE 
Review / CAEPIPE Evaluation Version 10.30. 

.Merge. 

You can merge two or more piping models into one file using this command. This feature 
merges Materials, Sections, Loads, Beam Materials, Beam Sections, Beam Loads, Pumps, 
Compressors, Turbines, Specrums, Spectrum Levels and Elements from the selected model 
into the currently openedmodel. The process, however, skips Analysis Options, Load Cases, 
Wind Loads, Time History and Force Spectrums from the selected model during merging. 
Also, CAEPIPE checks for duplicate nodes and provides an option for renumbering the 
elements. Pressing “Yes” will renumber and merge the model; “No” will merge without 
renumbering, and you will have to manually identify and remove duplicates and/or 
renumber.  

In addition to the above, CAEPIPE will do the following when a model with Spectrum and 
Spectrum level is defined. 

1. Rename the Spectrum automatically when the Spectrum name is already defined in 
the source model. When renaming is done, CAEPIPE will automatically update the 
Spectrum level data with the newly assigned name. 

2. Rename the Spectrum Level name when the Spectrum Level name is already defined 
in the source model. When renaming is done, CAEPIPE will automatically update 
the level tag assigned at support with the updated tag. 

3. Assign fist spectrum level tag name to all supports that has BLANK level tag. 

Refer example under “From” in Technical Reference Manual for a suggestion on how to 
model separate files for merging later. 

Example: 

Here are two models with the note showing where the common merge point is (node 10 in 
the first model and node 539 in the second model).  
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Open Bigmodel.mod first.  Use menu File > Merge to start the process. 
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Select the second model as shown below and click on Open. 

 

To avoid duplication of node numbers, names of materials, sections, loads, etc., click on Yes 
as shown below. 
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Choose a starting node number which is clearly not used in the first model.  CAEPIPE will 
use the starting node number to number the nodes sequentially using the increment shown. 

 

Models are merged now.  The second model starts from row 675 (the row with the yellow 
highlight). 

 

Notice that node 10 in the first model and node 5000 in the second model start from the same global origin 
(0,0,0).  
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So, you need to change node 5000 to the connecting node number in the first model (i.e., 
node 539). Upon doing so, you are asked 

 

Click on “Yes” to make the change. Also, remove the anchor from the data column on row 
676. 

 

The combined model is shown in the graphic view below (with a box – for illustration only - 
around the first model). 
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Zoomed image of the connecting node is shown below. 

 

.Export to .mbf. 

Presently, you can export the model data to CAEPIPE’s neutral file format (called a model 
batch file, .mbf). See Appendix A for format details. 
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.Export to 3D Plant Design. 

This feature exports the 3D CAEPIPE model to PDMS (.mac file) or CADMATIC (.3dd 
file) as structural components (only dumb graphics without attributes). 

 

.Export to PCF. 

CAEPIPE can export model data from inside the Layout window to a PCF file with the 
extension .pcf (piping component file). To export a model, select the menu command File > 
Export to PCF… from the Layout window. See section titled PCF Export in Appendix Afor 
more details. 

 

.Print Model (Ctrl+P). 

The Print command, flexible and customizable, is specific to each window. Here in Layout, 
you can print the model input data only (under the Model tab)to a printer, a PDF file (with a 
free PDF utility or Adobe® Acrobat installed), and change printer settings (under the Printer 
tab). You can customize the look of your report by changing the font, page sizes or margins. 
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Data can be output to either a text file or a CSV (comma separated values) file that can be 
opened in a spreadsheet software (e.g., MS-Excel). 

 

You could change the selected printer and customize other settings in the Printer tab (shown 
next). 
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.Save (Ctrl+S). 

This command saves model data to a .mod file format.  It will also issue warning(s) if errors 
are found in the layout data. 

.Analyze (F12). 

Once you are done modeling, use this command to analyze the model. At the end of analysis, 
you are asked whether you want to “View results?” Click on OK to see results or Cancel to 
return to the main window. 

Shortcut “F12” will work only when the command “Analyze” is active in the “File” menu. 

CAEPIPE may occasionally issue the message “Stiffness not positive definite”. This error 
message appears when the model has a free rigid body movement in one or more degrees of 
freedom.  To avoid this error message, make sure that any portion of the pipe stress model 
does not have free rigid body motion in any of the six (6) degrees of freedom (3 translational 
and 3 rotational). 

 

For example, the Branch line shown in the snapshot above allows free rigid body motion for 
the whole branch line in at least one degree of freedom. Hence, CAEPIPE will issue the 
error message as given above when the model is analyzed.  

A quick fix is to add a support or modify an existing support such that it prevents the free 
body motion.  

For example, the free body motion of the branch line shown above can be prevented in two 
ways as given below. 

a. Replace the Limit Stop located at the beginning of the Branch line with an Anchor. 

b. Replace the Limit Stops located at the Start and End of branch with Guides.  

Note: 

Command “Analyze” in the “File” menu will become inactive when the model is not edited 
and “.res” file is available in the directory where the stress model “.mod” is stored. 
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.QA Block. 

Type in project-specific information here, printable only from the Results window. You 
cannot change this information after analysis in the Results window. If you like to modify 
any information here, do it from the Layout window. You will then need to reanalyze the 
model because CAEPIPE will have deleted the existing results file for this model since the 
old data may no longer apply. 

  

.Revision Record. 

Store and print the details of the revisions carried out in this stress model for future 
reference.  
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Edit Menu 

 

Using this menu, you can edit properties for elements (under Type column) and data items 
(under Data column), insert and delete rows, split an element, rotate and renumber parts of 
the model, change a few properties like friction coefficient for a range of rows, and generate 
copies of existing rows. 

.Edit type (Ctrl+T). 

Double click on the element name in the Type column or press Ctrl+T to edit properties (if 
applicable) of an element (bend, valve, etc.). The appropriate dialog is shown. 

.Edit data (Ctrl+D). 

Double click on the Data item or press Ctrl+D to edit properties (if applicable) of the item 
(flange, anchor, etc.). The appropriate dialog is shown. 

.Copy (Ctrl+C). 

You can copy a specific item on a row such as Material, Data or Type column entries, or an 
entire row or a block of rows, and Paste all, or individual parts of the row.  To copy a desired 
row, move the cursor to that row and press Ctrl+C (or select Edit menu > Copy command).  
The copy command will copy all information on that row irrespective of the specific cursor 
location within that row.  

Copy of multiple rows can be done through Layout Window > Edit > Copy (and NOT 
through Ctrl+C). This feature can be performed ONLY in Layout window and NOT in List 
windows such as Materials, Loads, Section properties, Flange, Valve, etc. Since this is a block 
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operation, you need to specify (a range of) row number(s). Of course, you could accept the 
default row shown (which copies only one row). 

 

Turning ON the option “Remember for multiple paste” will remember the rows copied for 
pasting the elements multiple times. 

Copy command available through “List window > Edit > Copy” will remember the 
information from a row copied for multiple pasting ONLY for the Element types namely 
Valve, Bellow, Slip Joint, Hinge Joint, Ball Joint and Tie Rod, and for the Data types namely 
Flange, Guide, Limit Stop and Skewed Restraint. 

.Paste (Ctrl+V). 

Once you have copied a row through Ctrl+C, move your cursor to the location where you 
want to paste the copied information and press Ctrl+V (or select Edit menu > Paste). If you 
want to paste the entire row, move the cursor to the Node column of the row where you will 
be pasting.  To paste an individual part of a copied row, move the cursor to the specific 
column within the row where you wish to paste the specific datum.  The copied information 
is available for only one operation. Also, note that when an entire row is pasted, it will 
overwrite the existing row (if present). See Example 1 for further details. To update / refresh 
the Graphics window after paste, save the model and use the command “Redraw”available 
through Graphics window > View.  

If you have copied a segment consisting of multiple rows through Edit menu > Copy (and 
NOT through Ctrl+C), move your cursor to the location where you want to paste the copied 
information and press Ctrl+V (or select Edit menu > Paste).  See Example 2 below for 
further details. 

Note: 

If you wish to copy and paste a row multiple times, then invoke Copy command through 
“Edit > Copy” and enter the From # and To # as the desired row # and turn ON the 
option “Remember for multiple paste”. 

Node numbers for the elements pasted will be generated based on “Node increment” 
defined through Layout Window > Options > Node increment.  

Node number for “Location” element is assigned the same node number as the preceeding 
element whose type is other than “Comment”. 
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Example 1: Copy and Paste a Single Row 

 

To copy the row at #33 (30, Reducer, 1.2ft, , ,1, 9, 1, ), you may position the cursor 
anywhere on that row before you invoke the Copy command. But, to paste ALL of this 
information, you must position the cursor under the Node column of a (new) row.  

If you want to paste, however, only the type ‘Reducer’ then place cursor under Type, only for 
DX of 1.2’, place cursor under DX, and so on. 
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Example 2: Copy and Paste a group of elements (multiple rows) including their 
Data in Layout 

This example shows how to Copy a branch pipe starting at Node 100 and ending at Node 
790 and Paste the same at Nodes 65 and 75. Sample model used in this example can be 
downloaded from here. 

1. Navigate in the layout window where the brach pipe layout information is defined as 
shown in the figure below. 

 

2. Invoke the Copy command through Layout Window > Edit (and NOT using the 
shortcut Ctrl+C). Enter the From # as 78 and To # as 86. Turn ON the option 
“Remember for multiple paste” to paste the segment multiple times in the layout. 

 

  

http://www.sstusa.com/downloads/08_ResponseSpectrum.mod
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3. To Paste the branch pipe copied at Node 65, position the cursor at Row # 9 (after 
Node 65 definition) and press Ctrl+V. When done, you will see a message as shown 
below as you are inserting the copied rows in the middle of the layout. Press “Yes” to 
accept. 

 

4. In the figure shown below, you will observe that the new branch is inserted with 
Node numbers from 800 through 880 (rows 9 through 17). Now, to position the 
branch pipe at Node 65 properly, change the Node Number at row # 9 as 65 and 
insert a new row at row # 18 with Node number as 65 and Element type as “From” 
at both row # 9 and row # 18 as shown below. 
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5. Similarly, to Paste the branch pipe at Node 75, position the cursor at row # 21 (after 
Node 75 definition) and press Ctrl+V. Accept by pressing “Yes”. 

 

6. Now, to position the new branch at Node 75, change the Node Number at row 21 as 
75 and insert a new row at row # 30 with Node number as 75 and Element type as 
“From” for both row # 21 and row # 30 as shown below. 
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Example 3: Copy and Paste a Loop multiple times in Layout 

This example shows how to add a Loop to the existing layout and Copy & Paste the same 
loop multiple times (say at Node 340 and at Node 400). Sample model used in this example 
can be downloaded from here. 

1. Edit the existing layout and add a loop at Node 260 (row 31) as shown below. 

 

2. Invoke Copy command through Edit menu > Copy. Enter the From # as 31 and To 
# as 34. Turn ON the option “Remember for multiple paste”. 

3. Now, to insert the loop at Node 340, position the cursor at row 39 and press 
“Ctrl+V”.  

 

4. Delete the rows 33 and 34 (Nodes 340 and 350) as they are already replaced with 
loop through Edit > Delete as shown below. 

http://www.sstusa.com/downloads/08A_ResponseSpectrum.mod
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5. Similarly, to copy the same loop at Node 400, position the cursor at row # 47 (Node 
400) and press “Ctrl+V”. 
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6. Delete the rows 51 and 52 (Nodes 400 and 410) as they are already replaced with 
loop through Edit > Delete as shown below. 
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Example 4: Copy and Paste a Section / Material / Load via List Window 

To copy a Section / Material / Load, position the cursor in the required row and invoke the 
Copy command through List window > Edit > Copy or press “Ctrl+C”. 

 

Now, to paste the row copied, you must position the cursor at an empty row where you wish 
to copy and invoke command through Layout Window > Edit > Paste or press “Ctrl+V”. 
When done, enter the desired material reference name (up to 5 characters) in the column 
Name. 
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Example 5: Copy and Paste a row in List Window multiple times 

For Element types Valve, Bellow, Slip Joint, Hinge Joint, Ball Joint and Tie Rod and Data 
types Flange, Guide, Limit Stop and Skewed Restraint, Copy command available through 
“List window > Edit > Copy” will remember the data copied from a row for pasting the 
same multiple times. As an example, below figure shows how to Copy and Paste a Limit Stop 
data multiple times in a List window.  

 

To Copy data of a Limit Stop at Node 50, from the List window for Limit Stop, position the 
cursor at row # 1 and invoke the Copy command through List window > Edit or press 
“Ctrl+C”.  

Now, to paste the Limit Stop data copied multiple times, position the cursor at the required 
rows (row # 3, row # 4, row #6) and invoke Paste command through List window > Edit or 
press “Ctrl+V”. See figure given below for details. 
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.Find and Replace (Ctrl+H). 

Find and replace Element / Data types, Material, Section, and Load by selecting the Find and 
Replace command from the Edit menu or press Ctrl+H.  The Find and Replace dialog box is 
shown below. 

 

In the shown dialog above, all Valves will be replaced with pipes between rows 2 and 35.  
Use this command, for example, to change all LR elbows to SR elbows.  Note that while 
replacing element(s), you cannot leave the "Replace with" field blank. 
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You could change to different support types while evaluating different “what-if” conditions, 
or remove a specific support type from the model (select “blank” in the Replace with field). 
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You could change to a different material type while evaluating different “what-if” conditions. 
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You could change to a different section while evaluating different “what-if” conditions. 
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You could change to a different load while evaluating different “what-if” conditions. 
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You can assign Level Tag to supports when the model has spectrum with multiple spectrum 
level defined. For example, dialog shown above will find all supports that has no level tag 
defined (BLANK) in the range 2 to 50 and replace with level tag “LVL-0”. Similarly, leaving 
the Replace field BLANK with Find what field defined will remove level tag assigned to all 
supports. 

.Insert (Ctrl+Ins). 

Use Ctrl+Ins to insert an empty row above the present highlighted row in the Layout 
window. This command is also available from the context menu, by right-clicking in the 
Offsets (DX, DY, DZ) columns. 

.Delete (Ctrl+X). 

Use Ctrl+X on a row to delete it. To delete a range of rows, you must select the Delete 
command from the Edit menu, and then type the row numbers to set the range for deletion. 
If you want to delete till the end of the model, either type in a big number for “To #” such 
as 9999 or type in the (total) number (of rows) shown in the title bar in parentheses. 

This command is also available from the context menu (by right clicking), in the Offsets 
(DX, DY, DZ) columns. 
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.Split. 

Use this command to split a straight element or a curved section of a bend into two parts. 
This can be useful to create nodes for supports, applying forces at intermediate locations or 
introducing intermediate mass points. To split curved sections of bends (including jacketed 
bends), specify intermediate nodes at desired angles in the bend dialog. This command is also 
available from the context menu by right clicking on the Offsets (DX, DY, DZ) columns. 

When you have a long sloping pipe, you can create one long element with the slope built into 
it and then use the Split command to break it down into smaller elements. Or, of course, you 
could use the Slope command. 

 

.Multiple Split. 

CAEPIPE can split an element into multiple segments. 
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Assume that you wanted to split an existing element into 3 equal segments. This command 
will let you define the intermediate starting node # (with an increment) and the number of 
splits you want (see dialog above). If a non-pipe element (such as a bend, valve, reducer, etc.) 
is split, multiple pipe elements and anon-pipe element will be generated as a result of this 
operation. 

.Slope. 

You can specify the slope of the line you want to model for an element, in terms of its 
direction cosines (DCs). 

This command calculates the offsets automatically for a sloping element (that does not align 
with one of the major global axes). When a pipe slopes (or is routedat an angle) with respect 
to the global axes, it becomes necessary to calculate the offsets (DX, DY and DZ) using 
those faithful sine and cosine functions. But, therein lies the problem. Sometimes, 
calculations get tricky and time-consuming. 

 

Let us see a few examples. 

Example 1: A 20° line in the XZ plane, 10 feet long 

Method 1: 

Calculate the offsets: 

DX = 10 cosine (20) = 9.4 (ft.), DZ = 10 sine (20) = 3.42 (ft.). Simple! 

Method 2: 

Find direction cosines (DCs) for the line (vector). Direction cosines are simply cosines of the 
angles the vector makes with the global X-, Y- and Z-axes. In this case, A=20° (X), B=90° 
(Y), C=70° (Z). Cosines of these angles are: X comp=0.94, Y comp=0, Z comp=0.342. 

Now, position the cursor on the sloping element row, right click under DX/DY/DZ. Select 
Slope from the menu, enter these numbers into the X comp, Y comp and the Z comp fields 
of the Slope dialog that opens, and type the length, 10 ft. Press Enter. CAEPIPE calculates 
the respective offsets using the DCs you input. 

Once you input the slope, follow this pipe with other elements down the line by inputting 
different lengths while you retain the same direction cosines. 
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Example 2: A 40° line in the X(-Y) plane 

Method 2: 

Find direction cosines, if the line is at 40 deg. to X-axis in X(-Y) plane, it makes 50° with the 
(-Y) axis. So, the DCs are: cos (40°) = 0.766, cos (50°) = 0.643, So, X comp = 0.766, Y 
comp = -0.643, Z comp = 0.0. Type these DCs and a length into the Slope dialog. Press 
Enter. 

More information about Direction cosines is available under the section on Direction in the 
Technical Reference Manual. 

.Rotate. 

You can rotate a model or a part of it about the global axes. CAEPIPE will adjust the offsets 
for new orientation. 

Example 

Let us rotate the branch line of the familiar Sample model. The branch line is between nodes 
30 to 80 (rows 8 to 11 in the Layout window). Say, we wanted to route this branch line in the 
–X direction (i.e., it needs to rotate 180°). 
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Select Rotate from the Edit menu and type in the shown values. 

 

Notice the rotated offsets (now they are in the -X direction). 

Note: The valve additional weight is shown in the negative direction because of the rotation. 
To make it positive, edit the Valve (Ctrl+T) properties and change its DY offset from -18 to 
18 inches. 
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.Change. 

Use this command for block operations such as changing friction coefficient for all guides 
and limit stops within a range of rows, or changing the material, section or load for a range 
of rows or level tags for all supports (available only when spectrum and spectrum level 
defined) or span length (i.e., DX, DY and/or DZ between adjacent nodes) for a range of 
rows. You are asked for the range when you select this command from the Edit menu. 

 

.Combine (Ctrl+B). 

You can combine current PIPE/BEND elements with previous PIPE elements. 
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If you have a Data type (such as a support) defined on one of the “to-be-combined” rows, 
CAEPIPE will alert you to the fact that you will lose that data type definition during the 
Combine process. 

 

If you accidentally combine two elements, you can always UNDO the operation. 

.Renumber Nodes. 

You can renumber existing node numbers in your model using this handy feature;really 
useful when you have a big model and want to adopt a consistent node numbering system 
after multiple edits. You can renumber the whole or parts of the modelkeeping in mind that 
the greatest node number in a model cannot exceed 99,999. 

Renumbering a segment of a piping system also renumbers all those nodes of the segment 
that appear as “Connected to” nodes in the remaining segments of the piping system. 

Before using this feature, please make a copy of your model and work on the copy. Note:  
This feature is unrelated to “Automatic Renumbering of Nodes” found in the main 
window>Preferences. 
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Automatic Renumbering in the Main window > Preferences 

When this feature is turned on, deleting row(s)in Layout triggers an automatic (and 
instantaneous) renumbering operation, while the topic being discussed here allows you to 
renumber selectively for a range of rows. 

Example 

Assume that for the CAEPIPE Sample model, you wanted to change the node numbers for 
the header to begin from 100, and the branch line to begin from 1000. This can be easily 
done as shown next: 

 

1. Changing header node numbers: 
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Select the menu Edit > Renumber nodes. The Renumber Nodes dialog will open. In the 
dialog, type in:  

 2 and 6 for From Row# and To Row#, 

 100 for Starting node number and  

 10 for Increase node numbers by. 

 

Press Enter (or click on OK) and CAEPIPE changes the node numbers. 

2. Changing branch line numbering: 

Again, use the menu Edit > Renumber nodes, in the Renumber Nodes dialog, type in 

 8 and 11 for From Row# and To Row#, 

 1000 for Starting node number and 

 10 for Increase node numbers by. 

 

Press Enter (or click on OK) and CAEPIPE changes the node numbers. 

The final layout looks like the following. Note that CAEPIPE tracks all occurrences of a 
specific node number (e.g., 1000, the hanger node, occurs on two rows 4 and 8) throughout 
the model so you do not have to remember to change every occurrence of the same node 
number in multiple places in your model. 
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Other reasons you may want to use the Renumbering feature: 

1. In a big model, multiple edits sometimes bring about confusing node numbering. Use 
this feature to organize the numbering system. 

2. You may need to follow a guideline for numbering just to make parts of the piping 
system easily recognizable; all branch lines could get node numbers greater than 1000, all 
bypass lines could get node numbers greater than 2000, and so on. 

.Refine Nodal Mesh. 

This powerful command allows you to refine the Nodal Mesh for buried piping as well as for 
Dynamic Analysis.  

Refine Nodal Mesh for Buried Piping 

See section “Buried Piping” in the Technical Reference Manual for more details on “Refine 
Nodal Mesh for Buried Piping”. 

 

Refine Nodal Mesh for Dynamic Analysis 
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The purpose of this feature is to ensure that there are a sufficient number of mass points for 
an accurate dynamic model for the dynamic loading under consideration. 

Intermediate mass points along a span are generated based on the mass modeling frequency 
defined by the user. See section “Refinement of Nodal Mesh for Dynamic Analysis” in the 
Technical Reference Manual for more details. 

.Refine Branches for B31J. 

This command is active and available only if the “Piping Code” selected for Analysis is 
“ASME B31.1/ASME B31.3/ASME B31.4/ASME B31.5/ASME B31.8/ASME B31.9/ 
ASME B31.12” with the option “Use B31J for SIFs and Flexibility Factors” turned ON. 

The purpose of this feature is to refine the elements connected to the Branch SIF node to 
have additional node points to compute and apply Flexibility Factors for Run and Branch 
Pipe as specified in ASME B31J.  

 

a. Two (2) nodes on Run Pipe (one on either side of the Branch SIF node) at a distance 
equal to Run Split Factor x Run Pipe OD, where the Run Split Factor can be input 
by the user.  

b. One (1) node on Branch Pipe at a distance equal to Branch Split Factor x Branch 
Pipe ODfrom the Branch SIF node, where the Branch Split Factor can be input by 
the user. 
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Kb 

Kr 
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.Generate (Ctrl+G). 

This powerful command allows you to generate copies of the whole or parts of the model 
while automatically taking care of node numbering and offsets. Its power is best illustrated 
by an example. 

During “Generate” command execution, CAEPIPE issues a warning and stops when it 
encounters a Node number that already exists. 

Example 1: 

Assume that we want to go from the model shown in the first figure to the one shown in the 
second figure. There are two ways to reach the result. The first is by manually modeling 
every line like shown in the second figure. The second is the faster way using the Generate 
command, as you will see. 
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Summary of using the Generate command for the example: 

1. First identify the part of the model that repeats and model it. In this case, it is the part 
comprising of nodes 40 to 70 (rows 5 to 8). 

2. Next, use the Generate command to create four additional branches, each starting with 
say 140, 240, 340 and 440 (these node numbers could be any numbers). 

3. Then, create one connecting element (from node 40 to 140). 

4. Further generate three additional connecting elements. 

That is it. A number of figures follow to depict the above process pictorially. 

 

The above window shows the layout for the starting point of the model. Use the Generate 
command. 
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Notice the four sets that are generated (only the first one marked in the following figure). 

 

Look at the graphics that corresponds to the above Layout window. 

 

Next, create one connecting element between 40 and 140, and generate the remaining three. 

Example for Generate command Generate

Mar 15,2017

X

Y

Z

10

20

30

40

50
60

70

140

150
160

170

240

250
260

270

340

350
360

370

440

450
460

470
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Type 40 on an empty row, Tab to Type, press“F” for “From,” press Enter (rows 25 and 26 
above). Now, generate the rest. 
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Final model as shown is the desired result. So, as you saw, Generate command allowed us to 
create four branch lines from one existing line in three operations. 

Example 2: 

See example under Beam section in the Technical Reference Manual (Example 1: Pipe Rack 
using Beams) 

.Regenerate. 

Sometimes, owing to multiple edits, the model may be in an indeterminate stage. If you have 
made many edits, use this command to regenerate the model which will reinterpret the input 
and bring the model to a consistent state. 

.Duplicate Last Row (Ctrl+Enter). 

This is another handy feature that increases your productivity. For rows that repeat 
themselves (except for node number), this is a time saver. This is useful in modeling pipe 
racks or straight runs of pipe. Simply input all data on to a row and press Ctrl+Enter to 
duplicate this row on to the next with the node number automatically incremented. 

CAEPIPE cannot duplicate a Location/Comment/Hydrotest row, nor can it duplicate a row 
between two existing rows. This command works only on new empty rows at the end of a 
model. If you press Ctrl+Enter right after a Location/Comment/Hydrotest row, CAEPIPE 
will duplicate the row right before the Location/Comment/Hydrotest row. 

.Undo (Ctrl+Z). 

CAEPIPE can perform an Undo operation over 1000 times (1024)! This operation includes 
most user-input/edit actions through the Layout, List and Graphics windows. 
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Example 1: If you change your mind after individually deleting rows 10-14 and the first three 
guides (see figure above), you could use the Undo command (Ctrl+Z) eight times to undo all 
of these operations.  

Example 2: If you were to change a few of the analysis options (such as piping code, # of 
thermal loads and Bourdon effect through the menus), you could undo these changes by 
using this command three times, even though these changes are not made visible. 

.Redo (Ctrl+Y). 

Conversely, CAEPIPE can perform a Redo operation over a 1000 times (1024), which can 
include most user-input/edit actions through Layout, List and Graphics windows, including 
recently performed Undo operations.  

For example 1 under Undo: You could use the Redo operation to delete what you undid in 
the above example! In other words, delete rows 10-14 and the first three guides. 
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View Menu 

 

A few commands for the Graphics window can be carried out from here. 

.Graphics (F2). 

Use this command to move focus to the Graphics window. If the window is not open, then 
F2 will open the Graphics window and move focus to it. Pressing F2 again moves focus back 
to the Text window. 

.Viewpoint (F4). 

 

Use this command to set the graphics viewpoint. Several useful buttons inside the dialog 
allow you to change viewpoint to a preset one. For example, if you want to see the “plan” 
view (Y-vertical), click on “Y view” button. 

.Previous View (F5). 

Use this command to display the previously viewed graphics (zoom level and image area) in 
the Graphics window. 

.Zoom All (Ctrl+A). 

Use this command to view the whole model inside the Graphics window. Note that this 
command does not move focus to the Graphics window but brings the whole model 
graphics into view. 

.List (Ctrl+L). 

This is one of many CAEPIPE’s unique features. This command allows you to view itemized 
lists of every input data (pipes, bends, materials, valves, spectra, etc.) in a separate window. 
See more detailed explanation under the section titled “Layout Window” in this manual. 
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.Find Node (Ctrl+F). 

Use this command to search for a node number inside this window.  You may also search 
for jacket and bend end nodes (e.g., 20A, 30C, 160J), if they are referenced on the layout 
screen. 

 

.Find Text(Ctrl+Shift+F). 

You can quickly search for every occurrence of a specific word or phrase from “Comment” 
rows of CAEPIPE using this command. In the dialog box shown, type the word or phrase 
that you want to find from “Comment” rows. Any instance of the found text is highlighted 
in the layout window.  

 

 

To repeat “Find” the last word or phrase (after closing Find Text window), use “Ctrl+F3”.
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Options Menu 

 

This menu allows you to specify analysis options, units, font and the node number increment 
(for automatic generation of the next node number while inputting a model). 

.Analysis. 

The Analysis Options dialog is shown. Here you can specify analysis options related to 
piping codes, temperature, pressure, dynamic analysis, etc., in various tabs of the dialog. 

.Code. 

On this tab you can choose the piping code and also set options for that piping code. 
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Piping Code 

Select a piping code from the “Piping code” drop-down combo box. The following codes 
are currently available: 

 None 

 B31.1 

 B31.1 (1967) 

 B31.3  

 B31.4  

 B31.5  

 B31.8 

 B31.9 

 B31.12 

 ASME Section III Class 2 (1980, 1986, 1992, 2015 and 2017) 

 ASME Section III Class 3 (2017) 

 BS 806 (British) 

 IGEM 

 EN 13480 (European)  

 Norwegian (1983 and 1990)  

 RCC-M (French)  

 CODETI (French)  

 Stoomwezen (Dutch)  

 Swedish  

 Z183 (Canadian)  

 Z184 (Canadian) 

 Z662 (Canadian) 

Notes: 

For piping code = NONE, Rotating Equipment Qualification and Dynamic 
Analysis (Harmonic Analysis, Time History Analysis and Force Spectrum Analysis) 
are disabled in CAEPIPE. Hence, changing the analysis code to NONE from other 
code will delete all data related to Rotating Equipment, Harmonic load, Time 
History and Force Spectrum from the stress model without any warning. 

 When the selected piping code is “None,” a “Static analysis” load case, which 
includes weight, pressure, thermal, cold spring, static seismic and wind loads, all 
applied at the same time, is available for analysis. No dynamic loads (time history, 
response spectrum, etc.) are included. For“Piping code = None” and a non-FRP 
material, the in-plane and out-of-plane Stress Intensification Factors (SIF) for a 90° 
bend/elbow are taken to be the same as those computed using ANSI B31.3. For a 
bend with bend angle less than 90°, the in-plane and out-of-plane SIFsarecomputed 
using the procedure given in ASME/BPVC Section III, Division1, Case N-319-2 
“Alternate Procedure for Evaluation of Stresses in Butt Welding Elbows in Class 1 
Piping.” 

 For some piping codes, you need to select an additional option (such as Design 
Factor for B31.8, equation level for ASME and RCC-M, Location Factor for Z183 
and Z184, Occasional load factor for EN13480). These are shown below.  
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Use B31J for SIFs and Flexibility Factors 

This option visible only if the Piping Code selected for Analysis is ASME B31.1/ASME 
B31.3/ASME B31.4/ASME B31.5/ASME B31.8/ASME B31.9/ASME B31.12.  
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By checking this box, you can instruct CAEPIPE to compute Stress Intensification Factors 
(SIFs) and Flexibility Factors (FFs) as per ASME B31J. 

When this option is not checked, then CAEPIPE will compute SIFs and FFs as per 
Appendix D of the ASME code selected for Analysis. 

For further details on implementation, see CAEPIPE Code Compliance Manual. 

Include axial force in stress calculations 

By checking or un-checking this box, you can include or exclude axial force in stress 
calculations (F/A term). This option applies to all stresses (Sustained, Occasional and 
Expansion) and is provided since many piping codes do not clearly mandate the axial term’s 
inclusion. When included, CAEPIPE includes the axial term F/A (where F=axial load, 

A=Pipe cross-sectional area)in itscalculation of all stress equationssuch as 𝑆𝐿, 𝑆𝑂and𝑆𝐸 . 

Note that this option may be turned on depending on the code requirements.  

Use Liberal Allowable Stresses 

For B31.1, B31.1(1967), B31.3, B31.5, B31.12 and CODETI piping codes, the allowable 
expansion stress may be increased by a difference between the allowable sustained stress and 
the actual sustained stress times the stress range reduction factor. See Thermal Expansion 
Stress Range or equivalent under each piping code in CAEPIPE Code Compliance Manual. 

A piping code committee member opines as follows. 

Perhaps the term “liberal allowable” is not the best to describe the allowable. The allowable 
stress in B31.1 Eq. 13, i.e.,𝑆𝐴 + 𝑓(𝑆ℎ − 𝑆𝐿), can be used anytime. The only prerequisite is 
knowing the 𝑆𝐿 stresses, which will only be the case after the supports are known or implicit. 
The Eq. 1 allowable stress, 𝑆𝐴, is the allowable stress traditionally used in the flexibility 
analysis when no supports other than the equipment anchors are known. The flexibility 
analysis is used to determine whether the layout of piping between the equipment anchors is 
adequate. The displacements determined in the flexibility analysis will allow the designer to 
devise the pipe weight supports to interfere with the flexibility of the pipe as little as possible, 
i.e., the designer will use rigid supports where the piping does not move much, use variable 
springs where the piping moves a small amount (most typically 1/4” to 4”), and use constant 
springs where the movement is great (again, typically over 4”). For lateral loads the same 
concept as used for the pipe weight supports is used for the lateral supports, i.e., if lateral 
displacements are small, rigid supports may be used, for larger lateral movements, gapped or 
shock suppressor supports are used (although shock suppressor supports require 
considerable maintenance attention and in the long run are usually not preferable to gapped 
supports). 

General Note on Thermal Allowable Calculation for All Piping Codes 

Cold allowable (Sc) and Hot allowable (Sh) stresses used in thermal stress calculations are 
calculated as follows for all piping codes:  

 For Expansion Cases T1 through T10, Cold allowable (Sc) is taken at Minimum (Tref, 
Tn) and Hot allowable (Sh) is at Maximum (Tref, Tn), where n = 1 to 10. 
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 For Thermal Ranges Tx-Ty, Cold allowable (Sc) is at Minimum (Tx, Ty) and Hot 
allowable (Sh) is at Maximum (Tx, Ty), where x = 1 to10 and y = 1 to 10 and x is not 
equal to y.  

The specifics are summarized for each B31.x piping code under the title“Thickness and 
Section Modulus used in Weight, Pressure and Stress Calculations for ANSI B31.x Codes” of 
the CAEPIPE Code Compliance Manual. 

.Temperature. 

On this tab you can set options related to thermal loads. 

 

Reference Temperature 

Input the reference temperature here, usually 70°F (21.1°C) corresponding to the installation 
temperature.CAEPIPE uses this temperature to lookup material properties table for the 
elastic modulus (see subsection titled “Elastic Modulus” below) and to calculate thermal 
stress ranges such as (T1 – Tref), (T2 – Tref), (T1 – T2) = (T1 – Tref) – (T2 – Tref), etc. 
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Number of Thermal cycles 

CAEPIPE uses this number to determine the stress range reduction factor, f, which is used 
to reduce the allowable expansion stress range, 𝑆𝐴. 

The reduction factor “f” used by CAEPIPE for different piping codes are described / listed 
in the Code Compliance Manual.  

The typical equation for calculating thermal expansion stress range (e.g., for B31.1 code) is 

𝑆𝐴 = 𝑓(1.25𝑆𝑐 + 0.25𝑆ℎ) 

where 

𝑆𝑐 = allowable stress at cold temperature 

𝑆ℎ = hot allowable stress 

𝑓 = stress range reduction factor  

Number of Thermal Loads 

You can enter up to 10 thermal loads. This feature must be first set through Layout window 
> Options > Analysis > Temperature.  The maximum number of thermal loadsthat one or 
more elements of a stress model can experience during operation should be input for the 
Number of Thermal Loads. Up to 10 operating temperatures may be applied as part of Load 
(along with 10 operating pressures) under Misc menu > Loads. 

In addition to 10 thermal loads and 10 pressures, you can also enter the Design Pressure and 
Design Temperature through the fields Desg.T and Desg.P respectively. Refer to Section 
titled “Load” in the Technical Reference Manual for details on Design Temperature and 
Design Pressure. 

 

This also enables you to enter 10 temperatures under Miscmenu > Beam Loads. 
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Additionally, up to 10 specified thermal displacements can be entered for Anchor and Nozzle 
data types. 

 

Thermal = Operating – Sustained 

Thermal load case results can be calculated as the difference between the Operating and the 
Sustained load cases, i.e., the thermal load case is not solved independently. This is the 
recommended procedure to solve thermal cases (T1 through T10) especially when 
nonlinearities (limit stops, friction, etc.) are present. 

When a model has no nonlinearities, the forces, moments and displacements at nodes add up 
(i.e., Sustained load + Thermal load = Operating load). When a nonlinearity is present, each 
load case can be solved independently, i.e., the numbers are not added from Sustained 
(W+P) to Thermal (T1) to get Operating (W+P+T1); in other words, the results do not 
always add up. In the past, this used to be the only method of solving when nonlinearities 
were present. However, now you can use the new (recommended) option called “Thermal = 
Operating – Sustained”, which is in line with the requirement that thermal stress range is to 
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be calculated between two actual thermal states. Use it to solve for the thermal case as the 
difference between Operating and Sustained cases, which will also ensure that sustained and 
thermal case results add up to operating case results. 

Solve Thermal case 

Results for the thermal load case are obtained by solving this case independently.This option 
is generally not recommended. See above discussion. 

Elastic Modulus 
User can select one of the two options available in CAEPIPE (as given below).  

 Use temperature dependent modulus 

 Use modulus at reference temperature 

When the option “Use temperature dependent modulus” is chosen in CAEPIPE, then 
CAEPIPE computes the elastic modulus at the temperature under consideration (Ehot) while 
forming the Global stiffness matrix for each load case, i.e., at temperature T1 for Operating 
1, T2 for Operating 2, … T10 for Operating 10. In short, CAEPIPE uses hot modulus (Ehot) 
to compute the Displacements, Element Forces & Moments, Support Loads and Stresses 
when the option “Use temperature dependent modulus” is chosen. 

On the other hand, when the option “Use modulus at reference temperature” is chosen in 
CAEPIPE, then CAEPIPE computes the elastic modulus at “Reference Temperature (Tref)” 
(hereafter referred to as Ecold) while forming the Global stiffness matrix for each load case. In 
short, CAEPIPE uses cold modulus (Ecold) to compute the Displacements, Element Forces 
& Moments, Support Loads and Stresses when the option “Use modulus at reference 
temperature” is chosen. 

Note: 

“Expansion Stresses” for Restrained portionof piping (i.e., buried portion) for the 
piping code Z662 are calculated using elastic modulus at reference temperature 
(Ecold) irrespective of the option (among the above two options) chosen by the user 
for Elastic Modulus. On the otherhand, for Restrained portion of piping, 
Displacements, Element Forces & Moments, Support Loads and Stresses (excepting 
Expansion Stresses) are computed using the elastic modulus option chosen by the 
user, i.e., Ehot or Ecold. 

For Unrestrained portion of piping (portion not buried), for the piping code Z662, 
Displacements, Element Forces & Moments, Support Loads and Stresses are 
computed using the elastic modulus option chosen by the user, i.e., Ehot or Ecold. 

As per para. 402.2.2 of ASME B31.4 (2019) and para. 832.2 (g) of ASME B31.8 (2018), 
flexibility calculations shall be based on the modulus of elasticity at ambient 
temperature, i.e., modulus at reference temperature (Ecold). Hence, "Use modulus at 
reference temperature" (available through CAEPIPE Layout > Options > Analysis > 
Temperature) is set as "default" and is disabled for user to modify when B31.4 or 
B31.8 code is selected. In short, for both Restrained and Unrestrained portions of 
piping, Ecold is used in CAEPIPE to calculate Displacements, Element Forces & 
Moments, Support Loads and Stresses for B31.4 and B31.8 codes. 
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As per para. 519.4.5(a) of ASME B31.5 (2016) code, Bending and Torsional stresses 
shall be computed using the as-installed modulus of elasticity, i.e., modulus at 
installation temperature (Ecold). Hence, "Use modulus at reference temperature" 
(available through CAEPIPE Layout > Options > Analysis > Temperature) is set as 
"default" and is disabled for user to modify when ASME B31.5 code is selected. 

Similarly, as per para. 12.2.7.2 of EN 13480-3 (2017), value of the modulus of elasticity 
(Et) used for flexibility analysis shall be the value taken at the temperature of the 
piping load under consideration, i.e., modulus at temperature under consideration 
(Ehot). Hence, "Use temperature dependent modulus" (available through CAEPIPE 
Layout > Options > Analysis > Temperature) is set as "default" and is disabled for 
user to modify when EN 13480 code is selected. 

.Pressure. 

On this tab you can set options related to pressure loads. 

 

Pressure Stress 

The longitudinal pressure stress may be calculated as: 

pD/4t orpd2/(D2 − d2), both given as options.  

However, for B31.8 code, the pressure stress term pd2/(D2 − d2) is not an option. 

For EN 13480, the options are [pD/4t] or [pd2/(D2 − d2) + (p/2)]. 

Peak Pressure Factor 

For occasional loads (seismic, spectrum and wind), the pressure ‘p’ in longitudinal pressure 
stress is multiplied by this factor. 

  



Layout Window Options Menu 

 

83 

Bourdon Effect 

Bourdon effect is the tendency of straight pipes to elongate due to internal pressure. This 
may be included or excluded from the analysis by checking or unchecking the box. 

Internal pressure will expand the pipe cross-section radially outward (i.e., bulge out) thereby 
contracting the length of the pipe due to Poisson’s effect.  On the other hand, external 
pressure will contract the pipe cross-section radially inward (i.e., shrinking inwards) thereby 
elongating the pipe length again due to Poisson’s effect.  On the contrary, due to end-cap 
force developed by pressure, straight pipe elements will elongate for internal pressure and 
contract for external pressure. These physical phenomena are included in CAEPIPE 
calculations when the "Bourdon effect" button is turned ON. Pipe stresses and support 
loads generated due to such "Bourdon effect" deformations are generally considered as 
"Secondary Stresses and Support loads" and normally considered as part of the thermal 
expansion load case. 

Therefore, by default, this effect is treated as an expansion load and included in the expansion and operating 
load cases. It is not applied to the sustained and occasional load cases. 

If an environment variable (“BOURDONP”) is set (to YES), however, the Bourdon effect is 
instead treated as a sustained load and included in the sustained and operating load cases. It 
is not applied to the expansion load case. 

For a straight pipe, the following equation is used. 

𝑃𝑟𝑒𝑠𝑠𝑢𝑟𝑒 𝑑𝑒𝑓𝑙𝑒𝑐𝑡𝑖𝑜𝑛 =
𝑃𝑟𝑒𝑠𝑠𝑢𝑟𝑒 × 𝑟𝑚 × 𝐿 × (1 − 2𝜈)

2 × 𝐸 × 𝑡
 

where 

rm = mean radius of the pipe 
L = length of the pipe element 
ν = Poisson’s Ratio 
E = Elastic Modulus (Axial modulus in the case of FRP pipes) 
t = pipe thickness 

Pressure Correction for Bends (Pressure stiffening effect) 

Pressure correction for bends is different from and unaffected by Bourdon effect. In large 
diameter thin-wall bends, pressure can significantly affect their flexibility and SIF. If pressure 
correction for bends is used: the Flexibility of the bend is divided by 
 

1 + 6 × (
𝑃

𝐸
) (

𝑟

𝑡
)

7/3

(
𝑅

𝑟
)

1/3

 

and the SIF for the bend is divided by 

1 + 3.25 × (
𝑃

𝐸
) (

𝑟

𝑡
)

5/2

(
𝑅

𝑟
)

2/3

 

where 
P = pressure 
E = elastic modulus 
r = mean radius of matching pipe 
t = nominal wall thickness 
R = bend radius 
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It is recommended that this option be turned ‘ON’ whenever the internal or external 
pressure is high, so that the stiffening of the bend due to internal or external pressure is 
considered in the analysis.  In other words, when a thin-walled pipe bend is bent by bending 
moments at its two ends, the bend will ovalize and increase its flexibility.  Internal or external 
pressure will reduce this bend ovalization, thereby increasing its stiffness. 

Pressure correction decreases the flexibility of the piping system (by increasing the stiffness 
of the system because of the stiffened elbows). Hence, the system frequencies (in modal 
analysis) tend to increase. 

This pressure correction option is provided for all piping codes available in CAEPIPE.  

.Dynamics. 

On this tab you can set options related to dynamic analysis. 

 

Cutoff Frequency / Number of Modes 

These two options jointly control how the modal analysis routine works to extract the natural 
frequencies. Frequency(Hertz)and the chosen number of modes will determine the minimum 
number of modes extracted. The modal analysis will terminate either when the number of 
modes requested has been extracted or after extracting an additional frequency above the 
specified cutoff frequency value, whichever occurs first.   

For earthquake analysis, a typical value for cutoff frequency is 33 Hz. The maximum 
frequency you can input is 9999 Hz. 

When the selected piping code is “None,” and the model contains nonlinearities (limit stops, 
certain expansion joints), a static analysis for a given model with and without a g-load input 
may produce different frequencies depending upon the status of the nonlinearities due to the 
presence or absence of the g-load in the static load case. 
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Include Missing Mass Correction 

Missing mass correction to the response spectrum analysis can be included using this check 
box. See topic by the same name in the Technical Reference Manual. 

Use Friction in Dynamic Analysis 

Friction is optional in dynamic analysis. If friction is included in dynamic analysis, the global 
stiffness matrix arrived at upon completion of the iterative calculations for the first operating 
case (W+P1+T1) is used to compute frequencies and mode shapes for the piping system. 

.Misc. 

On this tab you can set miscellaneous options. 

 

Include Hanger stiffness 

When the checkbox is checked, CAEPIPE adds the hanger spring rates for variable spring 
and user hangers to the global stiffness matrix (recommended setting).  Hanger spring rates 
for rod hangers (if active) are always included even when this checkbox is not checked. 

If the checkbox is not checked, CAEPIPE does not include the hanger stiffnesses in the 
analysis (excepting for hanger spring rates for “active” rod hangers). Some users prefer this 
as it more closely matches “hand calculations.” 

In the 1970s, performing pipe stress analysis on mainframe computers was expensive (about 
$1,000/run). So, pipe stress analysts would run a Thermal (T1) case alone first. Then, they 
would run a deadweight (DW) case with rigid supports at chosen hanger locations. Using the 
support loads and the hanger travel, analysts would select appropriate variable spring hangers 
from hanger manufacturer catalogs. To save on computing costs, they would not update the 
global stiffness matrix [K] with the hanger stiffnesses for the newly selected hangers because 
they would have to reanalyze the model which would cost more money. Many industrial 
plants built 30 or 40 years ago in the USA and presumably in other countries have pipe stress 
analyses done in this manner. These plants have archived such analysis reports that do not 
include hanger stiffnesses (as part of the global stiffness matrix [K]). 
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In later years, as and when the analysts for these plants needed to reanalyze those piping 
systems, they had to use modern programs like CAEPIPE. But, before they accepted the 
new results, they sometimes liked to verify that the new results (from CAEPIPE) matched 
the results from the old reports generated by the mainframe pipe stress analysis programs. 
This is why CAEPIPE provides the option “Do not include (or include) hanger stiffnesses.” 
It helps the engineers compare results from CAEPIPE with the old archived reports. 

Today, with cheap PC computing power, there is no reason why hanger stiffnesses should be 
excluded from analysis. In fact, including hanger stiffnesses provides a more accurate picture 
of system behavior. As such, we recommend that you “include hanger stiffnesses” in every 
analysis. 

Vertical Direction 

You may specify either Y or Z as the vertical global axis for the model. If the vertical global 
axis is modified while building the stress layout, CAEPIPE will display the message as shown 
below. Press the button “Yes” to change the vertical axis and rotate the stress layout. 

 

Pressing the button “No” will change the axis without rotating the model.  

Yield Displacement Factor 

Soil (in Buried piping analysis) is modeled with an initial stiffness and an ultimate load, after 
reaching which, displacement continues without a further increase in load (i.e., yield stiffness 
becomes zero). You can change the initial stiffness by changing the Yield Displacement 
Factor (default=0.04, range from 0.04 to 1.0). No changes are recommended unless there is a 
problem with convergence during Buried Piping analysis. 

.Units (Ctrl+U). 

A flexible command, Units allows you to set any combination of units: English, SI or Metric, for 
any item. For convenience “All English,”“All SI” and “All Metric” buttons set all the units to 
that particular choice with a single button click. 

As an example, engineers in the USA sometimes use lb/in. for stiffnesses but use SI units for the 
rest, for their international clients. The specific combination of units that you create is saved with 
the model so you do not have to reset them every time. You could do your analysis in English 
units and present your results to your client in SI units with the click of a button. 
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.All English.  

All English units are shown below. 

 

.All SI.  

All SI units are shown below. 
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.All Metric.  

All Metric units are shown below. 

 

Note:  

CAEPIPE input screens for Concentrated Mass, Ball Joint, Rigid Element, Valve, 
Bellows, Slip Joint etc. require only the “Weight” of that item to be input in lbf, kgf 
etc. and NOT its mass. Hence, unit for “Mass” is not listed in the Units menu. So, 
whenever mass is required for a calculation as in the case of forming Mass matrix for 
dynamic analysis, or in calculating inertia force as (mass x acceleration) for static 
seismic analysis, CAEPIPE internally computes the mass for each item to be equal to 
(weight / g-value).  

Similarly, for density of pipe, insulation and lining materials, CAEPIPE requires 
“Weight Density” to be input in lbf/in3, kgf/m3 etc. and NOT its mass density. 

CAEPIPE performs all its calculations in one consistent set of units and does all unit 
conversions internally based on the units selected through this Units Command. 
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.Font. 

You can display the text in all CAEPIPE text windows (Layout, List and Results) in a font 
face and size of your choice. Here, the font chosen is Times New Roman, 8 point: 

 

.Node Increment. 

You can increase your productivity by having CAEPIPE automatically increment the node 
number when you model a piping system in CAEPIPE. You can turn this feature off by 
specifying a zero (0) increment here. The default is set to 10. 
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Loads Menu 

From this menu, you can specify the load cases for analysis. 

 

.Load cases. 

Click on this command to select the different load cases for analysis. Most of the time, 
selecting a load case is as simple as checking the corresponding checkbox. 

 
Empty Weight (W): 

Empty Weight (W) analysis includes the weight of piping, components, insulation and lining 
but excludes the weight of content. In addition, pressure stress is excluded from the analysis.  

Sustained (W+Px): 

Sustained (W+Px where x = 1 to 10) analysis includes the weight of piping, components, 
content, insulation and lining. It also includes operating fluid pressure and its effect in the 
analysis.  

Operating (W+Px+Tx): 

Operating (W+Px+Tx where x = 1 to 10) analysis includes the weight of piping, 
components, content, insulation and lining. It also includes operating fluid pressure and its 
effect as well as the effect of temperature increase/decrease in the analysis.  
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Design (W+PD+TD): 

Design (W+PD+TD) analysis includes the weight of piping, components, content, insulation 
and lining. It also includes Design and its effect as well as the effect of Design temperature 
increase/decrease in the analysiswhere PD = Design Pressure and TD = Design 
Temperature.  

Cold Spring (W+PD+TD) will be shown only when a cold spring (Cut pipe element) is input 
into the model. When these load cases are selected for Analysis, CAEPIPE will compute and 
show results for Displacements, Element Forces & Moments, Support Loads and Support 
Load Summary. These load cases are NOT included in Stress Calculations, Rotating 
Equipment Qualifications and Flange Equivalent Pressure Calculations. 

For a few others, load cases appear in this dialog only after you input their related data. For 
example, to perform a Response Spectrum analysis, you need to 

 First input Spectrums (under Misc menu)  

 Then, select those spectrums under the menu Loads > Spectrum.  

 Finally, you go back into menu Loads > Load Cases and check the box next to 
Response Spectrum for analysis.  

As another example, the Cold Spring load cases do not appear in this dialog if you have not 
input a “Cut pipe” element in the layout window. 

Further, multiple expansion and operating load cases appear here only when you set multiple 
thermal loads under Options > Analysis > Temperature in the Layout window. 

.Static Seismic Load. 

Use this load to apply static seismic loads (g-loads) computed using ASCE/SEI 7-16 or 
entered directly to the model. CAEPIPE applies the g-load to the piping system mass 
separately for X, Y and Z directions. The computed results (displacements, forces and 
moments) from each of the three (internal) load cases (i.e., one case corresponding to each 
global directional g-load) are combined using your choice of Absolute sum or Square root of 
sum of squares (SRSS).  
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CAEPIPE performs only an algebraic sum of the results for the three directional g-load cases 
when the Piping code = None is selected. 

Static seismic is an unsigned case and you will not see a sign (+ or –) in the results for this 
case. 

Under menu Loads > Load cases, check the box next to Static Seismic (g’s) to select this case 
for analysis. This load is treated as an Occasional load. 

The g-loads are applied only in the specified direction, i.e., a Z (g-load) of -0.189 is applied 
only in the -Z direction, and not in +Z direction. 

A g-load input may affect the extracted natural frequencies when no piping code is selected 
(i.e., Piping code = None). See under “Dynamics > Cutoff Frequency” for how. 

Acceleration in the vertical direction, if not provided explicitly, is generally taken to be 75% 
of the g-load in the horizontal directions. 

The g-load values can be calculated from any of the several sources available (ASCE/SEI 7-
16, ASCE A58.1, UBC, etc.). Refer to Section titled “Static Seismic Load” in CAEPIPE 
Technical Reference Manual for details on the implementation of ASCE/SEI 7-16 in 
CAEPIPE starting Version 10.30 and manual calculation as per ANSI A58.1. 

Static Seismic Analysis 

CAEPIPE computes the inertia force (as mass * acceleration) for each direction and applies 
it as an occasional load. The g-loads for the above example are 0.50g in the global X, 0.75g in 
the global Z, and then 0.25g in the vertical Y direction. CAEPIPE applies an X acceleration 
(of 0.50g) first and solves the case. This procedure is then repeated to apply accelerations in 
Y and Z directions as independent cases and obtain the corresponding results. 
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The above procedure results in three sets of solutions (displacements, element forces and 
moments, and support loads) to acceleration loads in X, Y and Z directions, which are 
typically combined in some manner. In CAEPIPE, two directional combination methods are 
available: SRSS (Square root of sum of squares) and ABS (Absolute). 

In the SRSS method, each directional component of displacements, element forces and 
moments, and support loads from the three X, Y and Z acceleration analyses are squared 
individually and added. The square roots of these respective sums are the displacement, 
element force and moment, and support load at a given node. InABS method, all absolute 
values of each directional component of displacements, element forces and moments, and 
support loads are added to get the absolute values for total displacements, element forces 
and moments, and support loads. 

The occasional stresses(SO) are added to sustained stresses(SL)and shown under Occasional 
stresses (SL + SO). 

CAEPIPE does not include piping system weight in Seismic load case, a few reasons being: 

1. The weight is already included in Sustained load case, and  

2. Piping codes such as B31.3 specifically mention that MA and MB calculations (moments 
due to sustained and occasional loads respectively) be done separately before combining 
them to calculate Occasional stresses (SL + SO). 

If you can, avoid nonlinearities such as gaps and friction when youranalysisincludesseismic 
loads. As it is, Static Seismic analysis is an approximation of Response Spectrum analysis, 
which is, in turn, an approximation of Time History analysis for a seismic event wherein 
seismic accelerations are applied as a function of time only at piping supports! So, the result 
you get from a static seismic analysis is a gross approximation. 

CAEPIPE adds the support loads from a static seismic case to those from Sustained and 
Operating load cases to produce the combination loads at supports. Look under the Support 
load summary to get the different combination loads at each support. 

To evaluate different directional seismic analyses: 

In linear analysis (i.e., no gaps and no friction), the results from a seismic load in +X and –X 
directions should be the same. So, the combination ranges can be seen by studying support 
load summary (e.g., Sustained+Seismic, Sustained–Seismic).  

In nonlinear analysis, however, the results from a seismic load in +X may NOT be the same 
as those from –X. In such a case, you will have to make two runs, i.e., analyze the original 
(say, model1.mod) with +X g-load; copy the model to model2.mod, specify a –X g-load and 
compute results. Now you have two sets of results, one from each model. Compare the two 
results carefully to identify the range (least to the most). 

Or, for further post processing, export the results from each model to a CSV file via the 
Print > Print to Filecommand (select file type as: CSV). Import each CSV file into a 
spreadsheet (e.g., MS-Excel) and combine the results of interest manually. 

In summary, you can set up as many runs as required for the g-loads (+ or –), depending on 
whether your model is linear or non-linear, and export results for those runs that you cannot 
combine inside CAEPIPE.  



Layout Window Loads Menu 

 

94 

As another example, for a nonlinear model with g-loads only in the X-Y plane, you can 
analyze four runs (or four identical models with four different seismic loads) thus: 

Run 1. Specify +X/+Y g-load 
Run 2. Specify -X/-Y g-load 
Run 3. Specify -X/+Y g-load 
Run 4. Specify +X/-Y g-load 

Examine the seismic and combination forces and moments from all runs, or in a spreadsheet 
(using the .CSV files CAEPIPE exports for each model) to determine the most conservative 
of results (and range) for further interpretation. 

As another example, in a linear model with g-loads only in the X-Y plane, the two runs 

Run 1. Specify +X/-Y g-load  
Run 2. Specify -X/+Y g-load 

are the same. So, either case (run) alone is adequate. 

Or, another example, for a nonlinear model with g-loads in all three global directions, you 
could set up eight runs/models: 

Run 1. Specify +X/+Y/+Z g-load 
Run 2. Specify +X/+Y/-Z g-load 

Run 3. Specify +X/-Y/+Z g-load 
Run 4. Specify +X/-Y/-Z g-load 

Run 5. Specify -X/+Y/+Z g-load 
Run 6. Specify -X/+Y/-Z g-load 

Run 7. Specify -X/-Y/+Z g-load 
Run 8. Specify -X/-Y/-Z g-load 

Each of these runs may yield different results. So, a careful evaluation of all eight runs is 
necessary to identify the most conservative solution and/or determine a range. 
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Wind Load. 

You can enter up to four (4) wind load profiles namelyWind1, Wind2, Wind3 and Wind4. 

 

Load Combinations  

With 10 thermal and four wind loads, you can analyze a total of up to 95+ load combinations 
(including 55 thermal load cases). 

 

You can apply a wind load to the whole or parts of the model. CAEPIPE applies it as a 
lumped (concentrated force) load at the nodes (i.e., it is not a distributed load along the 
element). A wind profile is required for the region in which the system is installed.  

The dialog for specifying wind load is given below. 
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When Wind Code is NOT selected then the following wind load related fields are to be 
specified. 

Shape factor 

Input a shape factor value here. CAEPIPE uses a constant value for shape factor. For 
example, ANSI A58.1-1982, “Minimum Design loads for Buildings and other 
Structures”provides a shape factor of 0.6 for circular cross-section. 

When user selects Pressure versus Elevation, CAEPIPE does not use the shape factor. 

Direction 

Input the direction of the wind using the direction cosines (examples: for wind in Z 
direction, Z comp = 1; for wind in 45° X-Y plane, X comp=1, Y comp=1, Z comp=0). See 
section on Direction in the Technical Reference Manual. 

Wind or Pressure Profile 

You need to input values for wind velocity or pressure at different elevations. See Subsection 
titled “Wind Load” in the CAEPIPE Technical Reference Manual for details on how to computeWind 
Forces as per ANSI A58.1-1982. 

CAEPIPE computes the wind load on an element by interpolating the wind forces between 
the elevations.  
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Units 

You can specify any combination of units for elevation, pressure and velocity. 

To exclude an element(s) from wind loading, the Load definition dialog for that element(s) 
should not have Wind load checked. In the dialog below, Wind load is checked. 

 

ASCE/SEI 7-16 

Starting Version 10.30, CAEPIPE has the built-in feature to compute the Design Wind 
Forces as per ASCE/SEI 7-16, when this code is selected. For using this feature, basic wind 
parameters are required to be defined for the stress system. Selecting this code without 
defining the basic wind parameters listed above will show a popup as shown below. 

Refer to Section titled “Wind Load” in CAEPIPE Technical Reference Manual for details on 
implementation of ASCE/SEI 7-16 in CAEPIPE starting Version 10.30. 
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EN1991-1-4 (2010) 

Starting Version 10.30, CAEPIPE has the built-in feature to compute the Design Wind 
Forces as per EN 1991-1-4 (2010), when this code is selected. For using this feature, basic 
wind parameters are required to be defined for the stress system. Selecting this code without 
defining the basic wind parameters listed above will show a popup as shown below.  

Refer to Section titled “Wind Load” in CAEPIPE Technical Reference Manual for details on 
implementation of EN 1991-1-4 (2010) in CAEPIPE starting version 10.30 
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.Spectrum Load. 

Shock waves (due to a seismic event), where wavelengths could be long, travel through the 
soil causing ground motion. Every support of a piping system connected to the ground will 
then experience the same excitation (hence “uniform” excitation at those supports).  

On the other hand, if the piping is routed along the wall of a tall building, then the seismic 
motion at the ground level will cause higher excitations at higher elevations of the building. 
In this case, the piping supports at higher elevations will be subject to higher excitations. It is 
fairly common in the industry to “envelope” the excitations at different elevations to arrive at 
one “uniform” excitation for all supports of a piping system. Such “uniform” excitation is 
then specified in CAEPIPE using a response spectrum, which is a table of maximum 
response versus natural frequency (with damping) for single degree-of-freedom systems. 

Starting Version 10.50, CAEPIPE can also perform Multi-level Response Spectrum Analysis 
of piping systems experiencing different spectrum loads at different supports. The supports 
could be at different elevations or at the same elevation, grouped under different Spectrum 
level tags as shown below.  

The response spectrum analysis can only be initiated after at least one spectrum level is defined (under menu 
Load > Spectrums). If the pipe is supported on multiple levels, with different levels experiencing different 
spectrum loads, each of the spectrum levels should be defined here. The same level tag should be assigned to all 
the supports located at that particular level. 

  

Double click on the row to assign the spectrum load. Then, select the spectrum that can only be input using the 
drop-down menu from the spectrums defined under menu Misc> Spectrums. 
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Level Tag 

Type an alpha-numeric name (up to 8 characters long) in this field. Example: If you have 
three elevation levels (ground, 100m and 300m)  with different spectrum loads, you could 
name them as L000, L100 and L300. If a single level is defined for uniform spectrum 
analysis, the same level tag will be automatically assigned to all supports. For multi-level 
response spectrum analysis, the level tags defined here need to be assigned to each support 
individually or assigned to the group of supports using the Layout window > Edit > Change. 

X, Y and Z spectrums 

Select a spectrum from the drop-down combo box, which should have been input in the 
spectrum table for each global direction. The spectrum tables can be input in Layout 
Window Menu: Misc > Spectrums. 

Factor 

The multiplying (scale) factor for the spectrum is input here. The same spectrum may be 
multiplied by different (Scale) factors to apply spectrum loads for different dynamic events. 

Mode Sum 

Pick one of three choices, SRSS (square root of sum of squares), Closely spaced or Absolute. 
See section on Dynamic Analysis in Technical Reference Manual for more information. 

Direction Sum 

Pick one of two choices, SRSS (square root of the sum of squares) or Absolute. See section 
on Dynamic Analysis in Technical Reference Manual for more information. 

Level Sum 

Pick one of two choices, SRSS (square root of the sum of squares) or Absolute. Level Sum is 
only enabled when multiple spectrum levels are assigned. See section titled Dynamic Analysis 
in Technical Reference Manual for further details. 

Uniform Response Spectrum and Multi-Level Response Spectrum Analysis  

CAEPIPE will automatically switch between Uniform Response Spectrum and Multi-level 
Response Spectrum depending on the loads defined.  

1) If a single spectrum level is defined, the spectrum load will be applied simultaneously 
at all piping supports, and CAEPIPE will perform a “Uniform response spectrum” 
analysis. It will compute the modal and directional responses (to this uniform 
excitation), which are further combined in a manner you specify. 

2) If more than one level is assigned to supports, then CAEPIPE will further check if 
the spectrum loads are the same or different.  Please refer to the flowchart below for 
details on the decision-making process by CAEPIPE. The Multi-level Response 
Spectrum Analysis will be initiated when more than one spectrum load is assigned to 
the supports. The combination over level contributions will be performed first, 
followed by interspatial and then intermodal combination. 
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Note: CAEPIPE will compare only the “Name” of the spectrum and "Factor” in deciding 
whether Uniform or Multi-level Response Spectrum Anaylsis is to be performed as shown in 
the flow chart below.  
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.Time History Load. 

A phenomenon that causes loads to vary with time can be applied in CAEPIPE for time 
history analysis. You may hand-calculate these values or use a simulation program (such as a 
transient fluid flow program for fluid hammer analysis) to get the variation of forces or 
moments with time at different points in the piping system. These loads are then input into 
CAEPIPE as time functions, which are later applied at the corresponding nodes of the 
CAEPIPE model as “Time Varying Loads.” 

Time functions (input under menu Misc> Time Functions) are a series of non-dimensional 
values versus time, which describe the variation of the forcing function with time. The actual 
value of the time function at any time is found by linear interpolation between time points. 

When you input a “Time Varying Load” at a node, you may apply a scale factor, if necessary, 
along with the direction of the force or moment. 

CAEPIPE will then apply these loads to compute the response of the piping system by 
performing a time history analysis. 

Various parameters for time history analysis are specified in the Time History Analysis 
Control dialog under menu Loads > Time History. 

 

Time step 

The time step (time interval) at which the analysis is performed should be typically no more 
than 10% (smaller the better) of the period of the highest frequency of interest, i.e., higher 
the frequency, smaller the time step, e.g., for a 33 Hz maximum frequency, the time step 
would be about 0.003 seconds {=10% of (1/33)}. 

Number of time steps 

The time history response is calculated for a total time (in seconds) of Time step × Number 
of time steps. This is how long you want to study system response. The total time may 
exceed the range of available data in the time function. The time function is only a forcing 
function. But, CAEPIPE can compute system response to it well after the forcing function 
ceases. For example, the effect of a heavy steam hammer could linger on for a minute while 
your forcing function data could span only 8s (seconds). 

Output interval 

The output interval is a multiple of time step at which you want CAEPIPE to save (and later 
display) results. For example, assuming a time step of 0.01s, if you wanted to see results at 
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every 10th time step (i.e., at 0.1s, 0.2s, 0.3s, and so on), enter 10 for output interval. You 
need to check the “Save Results” checkbox to see these time varying results which are saved 
in the file modelname.rth. If the “Save Results” checkbox is not checked, only the enveloped 
results are available but not their variation in time. The .RTH files may be large for big 
models with many time steps (so ensure that you have adequate storage and permission 
settings before performing time history analysis with “Save Results” checked). 

Note that CAEPIPE calculates the enveloped (maximum) results at every time step and not 
just at every output interval. The output interval is strictly for display purpose in the results 
and for saving in the .RTH file. The output interval does not affect the analysis. 

Damping 

Express the damping factor as a percentage (not as a fraction). Enter 5, not 0.05, for 5% 
damping. 

Example: 

Input: Time step = 0.01s, Number of time steps: 1000, Output interval: 10, Damping: 5%, 
Save Results checkbox Checked. 

CAEPIPE calculates the solutions at every 0.01s up to 10s. The results are saved every 0.1s 
in the .rth file. Note however, that CAEPIPE calculates the enveloped (maximum) results at 
every time step interval and not just at every output interval. The output interval is strictly for 
display purpose in the results and does not affect analysis. 

The Time Varying Load dialog is shown below: 

 

The Time Varying Load at a node is specified by its direction, units, the associated time 
function and a scale factor. This scalefactor is a scalar value, which when multiplied by the 
non-dimensional time function will give the actual magnitude of the forcing function in the 
unit selected in the above dialog. 
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.Harmonic Load. 

 

Harmonic loads can be loads from any sinusoidal loading, such as from rotating equipment 
or reciprocating pumps on a line. The magnitude of the loading should be determined before 
analysis. If only one compressor is on a line, then only one harmonic load is input. If more 
than one load is acting on the same line, then the phase (angle) or the separation in timing of 
application of each harmonic load becomes important (consider for example that the two 
loads may be equal and opposite thus canceling out any dynamic imbalance, or the two loads 
can be in the same direction, say +X and separated by 30° phase angle). So, the situation 
must be carefully analyzed before imposing these loads. 

Harmonic analyses of linear structures are generally performed to determine the steady-state 
response to long-duration loads, which vary sinusoidally (harmonically) with time, thus 
enabling you to verify whether your designs will successfully overcome resonance, fatigue, 
and other harmful effects of harmonic vibrations. In a harmonic analysis, all long-duration 
loads and the structural response vary sinusoidally at the same frequency.  

Various parameters for harmonic analysis are specified in this dialog shown above. 

Damping 

CAEPIPE applies this factor to all the modes. Enter value of critical damping as a percent, 
not as a fraction (Example: For 5%, enter 5, not 0.05). 

Combination 

CAEPIPE combines modal responses using one of two methods: Root mean square (RMS) 
or Absolute sum (which may be too conservative). Pick one. 

After you input the data here, then apply Harmonic loads at the Data column of the 
corresponding nodes of interest in the piping model. Then, select Harmonic under the menu 
Loads > Load cases for analysis. 
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The Harmonic Load dialog is shown below: 

 

The harmonic load can be imposed as a Force (FX/FY/FZ) at a specified frequency and 
phase angle. You may be able to get more information on the harmonic loading (mass, rpm, 
eccentricity, etc.) from the manufacturer of the equipment. 

Since a harmonic load response is unsigned, results do not have signs (+ or –). 

.Hydrotest  Load. 

Hydrostatic test load can be entered as a specialized form of a comment. Refer to the section 
titled “Comment” for details.  
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Misc Menu 

A few utilities such as Check bends, Check Connections and Check Branch SIF, sundry 
items such as opening the list screens for materials, sections, loads, pumps, compressors and 
turbines, and commands to enter data for spectrums, time functions, etc., are among the 
commands on this menu. When Piping code is set to “None” under menu Options > 
Analysis, all items from Pumps to User Allowables excluding Soils are disabled. 
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.Coordinates (Ctrl+Shft+C). 

This command lists the coordinates of all the nodes (including internally generated nodes 
such as A, B nodes) in the model. 

 

 

Straight line distance between two nodes can be found by using the menu View > Distance 
or by the command (Ctrl+D) in the coordinates window. 



Layout Window Misc Menu 

 

108 

 

Also shown are the angles the straight line (between the two nodes) makes 
in the X-Y plane (phi) and from the X-Y plane (beta). 

.Element types (Ctrl+Shft+T). / .Data types (Ctrl+Shft+D). 

You can open these dialogs that contain the different elements or data items you can input at 
a node. You can also open the same dialogs by clicking on the header row in the Layout 
window or right clicking in the Type or Data column on an empty row. 

More information about these commands is available under Layout Window in the Technical 
Reference Manual. 

.Check Bends. 

CAEPIPE can identify incorrectly and incompletely modeled bends. If you have any, you 
must correct them before analysis.  

Case 1 (Incorrect modeling) 

An “Invalid Bend” occurs if the bend geometry is input incorrectly in the layout. For 
example, for 90° bends, the bend radius should be less than or equal to the shorter of the 
two lengths, namely from the previous node to the bend node (same as “tangent intersection 
point”) or from the bend node to the next node. 

Case 2 (Incomplete modeling) 

A bend needs to be given a change in direction from the previous direction on the row 
below it. If this change is either not specified or incorrectly specified, CAEPIPE flags this 
bend as an invalid bend. An example follows. 
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When you select the Check bends command under the Misc menu, you get the following 
message for this model. 

 

 

By studying the image and the Layout window above, you can see that the bend at node 20 
turns from X direction into Z direction, and the bend at node 30 turns from Z direction into 
Y direction. But, the bend at node 40 incorrectly turns from Y direction into Y direction. To 
correct this, this bend needs to turn into any direction other than Y. The following screen 
shots show the correction. The bend at node 40 now turns into Z direction. 
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When you run the same Check bends command again, you get the following message. 
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.Check Branch SIF. 

CAEPIPE will validate Branch SIFs defined in the stress model against those SIFs applicable 
for the selected piping code before saving the model. If any Branch SIF defined in the stress 
model does not match with those applicable for the piping code selected, an option is given 
to change that Branch SIF before saving the model. 

In addition to the above check, this feature will check the layout for Branch Points without 
Branch SIFs defined and report the same to the user as shown below. 

 

.Check Connections. 

While not foolproof, this command checks for missing connections between pipes. By 
studying the following two figures, can you identify what is wrong with the modeling shown 
below? Check connections command will. 
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By studying the previous Layout window, you will notice that even though node 50 appears 
to be on the header (node 10 to node 25), it actually is not. Node 10 connects directly to 
node 20 which further connects to node 25. The loop begins from node 20 and goes up to 
node 50. But node 50 is not defined on the header. So, there is no connection between the 
loop and the header! 

When you run the Check connections command, you get the following message. 

 

So, you might want to run this command on complicated models with loops just to ensure 
that all such connections are properly modeled. 

Corrected modeling is shown next. Notice that node 50 is now defined as part of the header 
from node 10 to node 25. 
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.Materials, Sections and Loads. 

Please see the respective sections with the same titles in the Technical Reference Manual. 

.Beam Materials, Beam Sections and Beam Loads. 

These three can be found under Beam in the Technical Reference Manual. 

.Pumps, Compressors and Turbines. 

Please see the respective sections with the same title in the Technical Reference Manual. 

.Spectrums. 

A (uniform response) spectrum is a table of maximum response versus natural frequency for 
a specific excitation in single degree-of-freedom systems. You can input spectrums in three 
ways: 

1. Input spectrums directly into the model.  

2. Create a spectrum library and load spectrums from it.  

3. Input spectrums from a text file.  

When you use the first two methods, you may use menu Options > Spectrum command to 
set the different units for the X- and the Y-axes, and also choose the interpolation method. 
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1. Input spectrums directly into the model 

Select Spectrums from the Misc menu. You are shown the List window for spectrums. Start 
typing pairs of values into it. The frequencies or periods do not have to be in any order; 
CAEPIPE will sort them later. You can input as many pairs of values as required. 

 

2. Create a spectrum library and load spectrums from it 

From the Main, Layout or Results window, select menu File > New. 

 

Select Spectrum library. The spectrum library List window is shown. Start typing pairs of 
values into it. 
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The frequencies or periods you type can be in any order. CAEPIPE will sort them later. You 
can input as many pairs of values as required. Be sure to save the file (it will be saved to a 
filename you specify, with a .spe extension) using the Save command in the File menu. 

Note: Fourteen (14) Spectrum Libraries have been added corresponding to EL Centro (May 
18, 1940), Uniform Building Code (1991 Edition) and Nuclear Regulatory Commission 
(NRC) Guide 1.60 [July 2014, Revision 2]. Refer to Appendix B for more details. 

Now, open the CAEPIPE model that needs these spectrums. Open the saved library (menu 
File > Library) and input spectrums into the model from the shown list. 

 

3. Input spectrums from a text file 

This method involves creating a separate text file (in the format shown below) for each 
spectrum you want to input. The steps are given below. 

a) For each spectrum, on the first line, type the Name of the spectrum (up to 31 
characters).  On the second line, type units for Abscissa (X-axis) and Ordinate 
(Y-axis) axes, separated by a space.  

b) After these two lines, on each line, you can input a value pair. You can input as 
many of these value pair lines as required.  

c) Each spectrum should be saved to a separate text file. More than one spectrum 
should not be input in one text file as it cannot be read into CAEPIPE.  

d) Now, open the CAEPIPE model that needs these spectrums. Select Read 
Spectrum from the File menu, read all text files you created one after the other.  

 

The format of a spectrum text file is shown below. The spectrum that is read appears on the 
row where the yellow highlight is placed (under the Name column). You can use the Edit 
menu commands to insert an empty row or delete an existing spectrum. Ensure that no two 
spectrums share the same Name. CAEPIPE issues a warning should such occur. 

The spectrum text file should be in the following format: 

Name  (up to 31 characters 

Abscissa units Ordinate units 

Abscissa value1 Ordinate value1 
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Abscissa value2 Ordinate value2 

. . 

. . 

. . 
Where  

Abscissa units 0 = Frequency (Hz) 

 1 = Period (Sec) 

 

Ordinate units 0 = Displacement (inch) 

 1 = Displacement (mm) 

 2 = Acceleration (in/sec2) 

 3 = Acceleration (mm/sec2) 

 4 = Acceleration (g’s) 

Example file 

Test Spectrum 

0 2 

1 190 

2 220 

3 250 

4 1932 

5 1000 

6 1800 

. . 

. . 

Analysis note: 

While analyzing the response spectrum case, when a mode (frequency or period) falls outside 
the spectrum table, CAEPIPE issues a warning and uses the value corresponding to the 
closest frequency or period in the spectrum table (for example, CAEPIPE uses the value 
corresponding to the lowest frequency if the calculated frequency is lower than the lowest in 
the spectrum table or uses the value corresponding to the highest frequency if the calculated 
frequency is higher than the highest in the spectrum table). 

Once you are done inputting the different spectrums using any one of the three methods, 
you need to input the Spectrum load itself under the menu Loads > Spectrum in the Layout 
window.  Details on inputting the Spectrum Load are provided earlier under the Loads 
menu. 
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.Force Spectrums. 

Select “Force Spectrum” through Layout window > Misc. The Force spectrum list appears. 

 

Enter a name for the force spectrum and spectrum values versus frequencies table. In 
addition to inputting the force spectrum directly, it can also be read from a text file or 
converted from a previously defined time function. 
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To read a force spectrum from a text file: 

use the List menu: File > Read force spectrum. 

 

The text file should be in the following format: 

Name (up to 31 characters) 
Frequency (Hz)   Spectrum value 
Frequency (Hz)   Spectrum value 
Frequency (Hz)   Spectrum value 

. . 

. . 

. . 

The frequencies can be in any order. They will be sorted in ascending order after reading 
from the file. 

To convert a previously defined time function to force spectrum: 

use the List menu: File > Convert time function. 

 

The Convert Time Function dialog appears. 
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Select the time function to convert from the Time function name drop down combo box. 
Then input the Force spectrum name (defaults to the Time function name), Maximum 
frequency, Number of frequencies and the Damping. When you press Enter or click on OK, 
the time function will be converted to a force spectrum and entered into the force spectrum 
list. 

The time function is converted to a force spectrum by solving the dynamic equation of 
motion for a damped single spring mass system with the time function as a forcing function 
at each frequency using Duhamel’s integral and dividing the absolute maximum dynamic 
displacement by the static displacement. 

Force Spectrum Load 

The force spectrum loads are applied at nodes (in Data column in Layout window). At least 
one force spectrum must be defined before a force spectrum load at a node can be input. 

To apply the force spectrum load at a node click on the Data heading or press Ctrl+Shift+D 
for Data Types dialog. 

 

Select “Force Sp. Load” as the data type and click on OK. This opens the Force Spectrum 
Load dialog. 

 

Select the direction, units and force spectrum using the drop down combo boxes and input 
appropriate scale factor. The scale factor can be a scalar value, which, when multiplied by the 
non-dimensional force spectrum, will give the actual magnitudes of the force versus 
frequency in the global direction and unit selected in the above dialog.  Then click on OK to 
enter the force spectrum load at that node. 
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Input force spectrum loads at other nodes similarly. Then select the force spectrum load case 
for analysis using the Layout menu: Loads > Load cases. 

 

Note that Modal analysis and Sustained (W+P) load cases are automatically selected when 
you select Force spectrum load case. The force spectrum load case is analyzed as an 
Occasional load. 

For more details,seetopic on Force Spectrum in the Technical Reference Manual. 

.Time functions. 

Time functions are non-dimensionaltables (i.e., a series of time versus value pairs) which 
describe the variation of the forcing function with time. Usually, a transient fluid flow 
analysis program computes forces as a function of time at all changes in directions 
(bends/tees) and other points of interest. These forces/moments result from a transient 
event such as a fluid hammer. Separate force-time histories are then input as time functions 
and applied as Time Varying Loads within CAEPIPE at the Data column of 
thecorresponding nodes of interest in the piping model. 

In CAEPIPE, the time function you define can have any interval between two time values. 
You can make that table as fine as you want it to be. 

You must have a zero entry for the Value next to the first Time input. Time history analysis 
begins at time t=0.0. You can input as many time-value pairs as required. 

There are two methods for inputting time functions. 

1. Input time functions directly into the model.  

2. Create a text file for each function and read it into CAEPIPE.  

1. Input time functions directly into the model  

Click on menu Misc> Time functions to type in time functions. Time is measured in 
seconds. Value is non-dimensional. You can assign units to these Values when you input a 
Time varying load at a node. For now, simply start typing the time-value pairs. Next, input 
parameters for the Time History Analysis Control dialog, and then input Time Varying 
Loads at nodes of interest. 
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2. Create a text file for each function and read it into CAEPIPE 

Read these text files into CAEPIPE using the menu File > Read Time Function command. 
For each function, you need to type a Name (up to 31 characters) on the first line, type time 
followed by a Value (separated by a space) on the following line. You can input as many 
time-value pairs (one pair on each line) as required. 

 

The format of the time function text file is shown below. The time function that is read from 
a file appears on the row where the yellow highlight is placed (under the Name column). You 
can use the Edit menu commands to insert an empty row or delete an existing time function. 
Ensure that no two time functions share the same Name. CAEPIPE issues a warning should 
such occur. 

Time Function 

0.0 0 

0.1 0 

0.2 0.025 

0.3 26.65 

0.4 112 

0.5 806 

0.6 7984 

0.7 1882 

0.8 2531 

0.9 2480 

1 2109 

. . 

. . 
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Once you are done entering time functions, specify the parameters in the Time History 
Analysis Control dialog under menu Loads > Time History, details of which are provided 
earlier under the Loads menu topic. 

 

Then, specify Time Varying Loads at applicable nodes in the model. The following figure 
shows the time function as a time-varying force applied in the X direction (FX) at node 30. 
Under Units, you can specify one of several depending on whether you are applying the 
Values in the time function as a force (FX, FY, FZ) or a moment (MX, MY, MZ). For more 
details, please see discussion under menu Loads > Time History. 

 

.Relief Valve Load Analysis. 

See the topic Relief Valve Load Analysis in the Technical Reference Manual for details. 

.Soils. 

See Buried Piping Example in the topic on Buried Piping in the Technical Reference Manual. 

.User-Defined Allowables. 

CAEPIPE allows you to define "User Allowables" for Anchors, Generic Supports, Nozzles and 

Restraints through Misc> User Allowables. 
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The allowables thus defined are compared against calculated loads and printed in Support 
Load Summary outputs. 

 

If the calculated loads exceed the allowables, they are highlighted in red. 

 

.Internal Pressure Design: EN 13480-3. 

See the topic Pressure Design of Pipe and Pipe Fittings in the Technical Reference Manual 
for details. 

.External Pressure Design: EN 13480-3. 

See the topic Pressure Design of Pipe and Pipe Fittings in the Technical Reference Manual 
for details. 
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.Wind Load – ASCE/SEI 7-16. 

Refer to Section titled “Wind Load” in CAEPIPE Technical Reference Manual for details on 
the implementation of ASCE/SEI 7-16 in CAEPIPE starting Version 10.30 and manual 
calculation as per ANSI A58.1. 

.Wind Load – EN 1991-1-4 (2010). 

Refer to Section titled “Wind Load” in CAEPIPE Technical Reference Manual for details on 
the implementation of EN 1991-1-4 (2010) in CAEPIPE starting Version 10.30. 
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Window Menu 

For a single model file, CAEPIPE can keep up to four open windows simultaneously for 
your enhanced understanding of the presented information.  

The windows are:  
 Layout  

 Graphics  

 List, and  

 Results  

From any window, you can move focus to any other window (such as Graphics or List) 
using the F2 and F3 hotkeys. F2 will move focus between text (Layout, List or Results) and 
Graphics windows, and F3 between open text windows (between Results and Layout or 
Results and List). 

Users who have a smaller monitor and work with maximized windows for input, list, 
graphics and results, will see more the advantage of these hotkeys (F2 and F3). In such a 
setting, one key press (F2 or F3) will quickly move the focus to another window (without 
having to either minimize the one where the focus is or switch to another window through 
the taskbar). 

From the Layout window: 

 

From the List window: 

 

From the Graphics window: 

 

From the Results window: 
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Note: In the above Window menu from the Results window, if you moved focus to the 
Layout window (by opening “Layout window” through “Results window > Window > 
Layout”), then the hotkey F3 would be assigned to Layout (not List as shown). So, the 
Window menu would look like: 



Graphics Window 
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When you open a model, CAEPIPE automatically opens the Layout and the Graphics 
windows. Many commands to manipulate the image such as zoom, turn (rotate), pan and 
print are available in this window. 

 

 

You could opt to display the image with a white background too (use Graphics window 
>Options > Background > White). 

When a model is opened, CAEPIPE displays the last saved model view in the Graphics 
window.
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Context Menu 

Right-clicking anywhere inside this window displays the context menu. 

 

In addition to a few commands constantly available on this menu, other commands appear 
on the menu depending on the results item shown in the Results window. For example, 
when Sorted stresses are shown, the context menu shows three commands specific to Sorted 
stresses (Show Stresses, Show stress ratios and [set stress/ratio] Thresholds). 

 

Right click on the mouse anywhere inside this 
window to show the context menu 
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Editing in Graphics Window 

Clicking on an editable element or data item brings up the related dialog (same as that you 
see opened in the Layout window). You can enter or modify properties inside the dialog just 
as if you were editing in the Layout window. This feature gives you more flexibility during 
editing your model. See next page for illustrative images.  

Modified or newly entered data is immediately updated in the Layout and the List windows. 
When you click on any graphics symbol, CAEPIPE automatically synchronizes the highlights 
in the Layout and the List windows to the row that contains the element/data item you 
clicked on, so that you see all the pertinent data about that element at the same time. 

This feature works in Render mode too. Sometimes when symbols are closely grouped, you 
may want to zoom in on that area before clicking on a symbol. That way, CAEPIPE presents 
you the correct dialog box. Dialog boxes are opened only for elements/data that have 
editable data. For example, clicking on a pipe element will do nothing but will still 
synchronize the highlights anyway in the other windows to the same pipe element. 

When you are viewing results, you can still click on an element/data item, except now the 
data you see presented are read-only (you cannot edit them). 

 

Clicking on a valve (as shown above) will open the dialog in the window shown next. You 
may modify any value inside the dialog and have it updated across all open windows. 

Click on any element or data 
type to edit its properties 
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Hotkeys You Can Use 

In addition to conventional MS-Windows hotkeys (such as Ctrl+P for Print, Ctrl+C for copy 
image, etc.), you may use the following keys. The usage of these hotkeys are explained in 
detail in later section of the manual. 

Ctrl+A  Zoom All 
Ctrl+Shift+C  Center image around a chosen point 
Ctrl+T  Turn (rotate) image ON/OFF 
Ctrl+S  Show 
Ctrl+N  Show node numbers 
Ctrl+D  Redraw image 
Ctrl+R  Render image 
 
Ctrl+Shift+X  View X 
Ctrl+Shift+Y  View Y 
Ctrl+Shift+Z  View Z 
Ctrl+Shift+I   View Isometric 
 
Mouse Scroll      Zoom In/Out 
Ctrl+Mouse Scroll    Pan Up/Down 
Shift+Mouse Scroll    Pan Left/Right 
Ctrl+Mouse Left Button+Drag Pan Graphics in Horizontal/ Vertical direction 
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Ctrl+T followed by 
Ctrl+Mouse Scroll    Rotate in Vertical plane 
Shift+Mouse Scroll    Rotate in Horizontal plane 
Ctrl+Mouse Left Button+Drag Rotate in Horizontal/Vertical plane 
 
Ctrl+Numpad 8   Increase Symbol size 
Ctrl+Numpad 2   Decrease Symbol size 
 
Page Up Zoom in 
Page Down Zoom out 
 
F2 Move focus to Layout or List window (wherever the focus was before) 
F3 Show/Hide Dots + Numbers 
F4 Viewpoint 
F5 Previous view 
F6 Hide Current Element 
F7 Make Transparent 
F8 Freeze View 
F9 Show All 
F10 All Transparent 
F11 All Opaque 
F12 Show/Hide Selected Elements 

Dynamic Resizing of Window Image 

When you resize the Graphics window, CAEPIPE will automatically resize the image 
proportionately isotropically. Dynamic scaling makes it unnecessary for you to “Zoom All” 
every time you resize the window. 
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Using Scroll Thumbs 

When you want to move or pan the image, simply drag the scroll thumbs in the scrollbar and 
the image moves accordingly. If you have activated the Turn command (menu View > Turn, 
or Ctrl+T), then the scroll thumbs when moved using the mouse will rotate the image. 

Graphics Synchronization with Open Text Windows 

The graphics image has a flashing cursor (such as on an anchor or bend) that always 
synchronizes with the text window that has the focus. In congested models, the flashing 
cursor points precisely to the location of the element you are working on by acting as a 
flashing beacon. Example: Move the highlight in Layout to an anchor. The Graphics and the 
List windows (if open) automatically show or highlight the same anchor. 

Dynamic Updating of Data in All Open windows: Layout, Graphics and List 

Example: Delete an Anchor or change a Material name in the List window. The Layout and 
the Graphics windows are automatically updated immediately, showing the changes. You are 
not forced to perform edits from any one given window. You can get instant feedback. 

Simultaneous Visual Updates of Deflected and Mode Shapes 

Simply switch between different load cases (or mode shapes) in the Results window to see 
the respective deflected/mode shape change too in the Graphics window. 

Zoom Window 

To enlarge an area of image, simply use the mouse to draw a window (a box) around an area 
you are interested in.  CAEPIPE enlarges the image (inside the drawn box) when you release 
the mouse button. 

 

 

Click and drag mouse to draw a window 
around image that you want magnified 
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The zoomed image is shown next. 

 

Menus and Toolbar 

The different menus in this window are explained in detail in the Menus section. A summary 
is given here. 

 

File menu: 

 You may print the image to a printer or a file (formats supported are Windows 
Enhanced Metafile (EMF), Encapsulated Postscript (EPS), HPGL plot file (PLT) 
and AutoCAD DXF). You can change the printer font from here.  

Before printing to a printer or a file, you can change the title for the printout using the 
Plot Title command. Before printing a rendered image, you may want to select a white 
background and a quality of rendering (default is High).  For DXF & PLT files use the 
“Drawing Size” command to change size. 
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View menu: 

 Mainly for Graphics operations (Viewpoint, Previous view and Zoom All). 

 Selective display of node numbers and graphic symbols makes CAEPIPE flexible 
and powerful (use Show and Show Nodes commands). In addition, other standard 
graphical operations such as pan, zoom, previous view, viewpoint change, center 
image, etc., are available through the menus or a readily available context menu. 

 Selective display of elements is possible.  Use the commands such as “Make 
Transparent”, “All Opaque”, etc.  

 Render Mode: Use this mode for realistic visualization of your model using 
OpenGL®. 

Even in this mode, you can selectively display symbols and/or node numbers. Use a 
combination of Show and Show Nodes commands available in the context menu (or from 
View menu). Image can be printed, too. 

Options menu: 

 Customize the display image by choosing a display font, repositioning the Axes 
symbol, and changing the size of the toolbar icons. 

Window menu: 

 From here, you can move the focus to the text window from which it came. F2 will 
move focus between text and Graphics windows. The real advantage of this hotkey 
(F2) is for users who have a small monitor and work with maximized windows for 
input, list, graphics and results. In such a setting, one keystroke (F2) will quickly 
move the focus to another window (without having to either minimize the one where 
the focus is or switch windows through the taskbar).  

Help menu: 

For online, Tutorial and About CAEPIPE. 
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File Menu 

This menu has commands for printing and copying graphics images to the clipboard. You 
can also set the drawing size for a printer/plotter/DXF file and type in a new title for the 
image (different from the Title entered on row 1 of the Layout window). 

 

.Print (Ctrl+P). 

The Print command here opens the Print Graphics dialog which allows you to select a 
printer and customize other print settings. 

 

.Printer. 

On the Printer tab, you can setup the printer and the graphics print page as well as select the 
font for printing graphics. 

.Font.  

The font you select here is different from the Font selected in the Graphics Font dialog 
under the Options menu. The Font command here sets the font for printing only, 
whereasthe Font commandunder the Options menu sets the font to use for Graphics display 
only as explained earlier in this manual. 
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.Preview.  

Before you print an image, you can preview it by clicking on this button. 

 

While in the Preview mode, click on Close to return to the Graphics window or click on 
Print to send the job to the printer. 

.Print to File.  

This can be a useful command to convert the line drawing (vector) graphics to other vector 
formats such as Encapsulated Postscript (EPS), Windows Enhanced Metafile (EMF), 
AutoCAD’s DXF or HPGL’s PLT. You can specify a filename for the graphics file. 
CAEPIPE can also convert other vector graphics such as non-rendered stress and stress 
ratio plots, deflected and mode shapes to the above vector formats. 
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Note on DXF output 

CAEPIPE sends only the model information including the line drawing into a DXF file in 
different layers. It does not send any results (like stresses or deflected shapes) to a DXF file. 

Print Dialog for OpenGL Rendered Images 

For rendered images, you will see a different Print dialog.  Here, as in the earlier Print dialog, 
you can select a printer and customize certain print settings. The resolution and image 
background can be set, too. A black background will consume more of your printer ink. 

 

Setting the resolution to High (300 DPI) or HD (1200 DPI) might take up a lot of system 
memory and slow your system down. Should such happen, use the Low (100 DPI) or 
Medium (200 DPI) setting. 
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.Preview.  

Preview the OpenGL graphics rendering by clicking on this button. 

 

.Copy (Ctrl+C). 

You can copy the displayed graphics image to the clipboard and then paste this image into 
any other program that accepts it. For example, you can copy the rendered view of a model 
and paste it into your paint or a graphics processing program so that you can use the finished 
image (possibly with your annotations) in a word processing program of your choice to 
generate a report. 

.Drawing Size. 

The drawing size command applies only to DXF and PLT files. Before you generate a DXF 
or a PLT from menu File > Print > Print to File, you need to set the drawing size here. The 
default is set to US A size (Letter – 8.5” x 11”). 
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There are several US and ISO sizes available. 

 

.Plot Title. 

For the graphics image printout (or for the image copied through the Copy command), you 
may type in an image title different from the model title (in the Layout window). Clicking on 
Reset will restore the title to the original model Title from row 1 in the Layout window. 
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View Menu 

This menu contains commands for graphics operations. 

 

.Viewpoint (F4). 

 

Use this command to set the graphics viewpoint. Several useful buttons inside the dialog 
allow you to change viewpoint to a preset one. 

For example, if you want to see the “plan” view (Y-vertical), click on “Y view” button. 

.View X (Ctrl+Shift+X). 

Use this command to view the graphics from X direction.  
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.View Y (Ctrl+Shift+Y). 

Use this command to view the graphics from Y direction.  

.View Z (Ctrl+Shift+Z). 

Use this command to view the graphics from Z direction.  

.View ISO (Ctrl+Shift+I). 

Use this command to view the graphics in Isometric mode.  

.Previous View (F5). 

Use this command to display the previously viewed graphics image in the Graphics window. 
The last used viewpoint, zoom level and area of the image are brought back into view. 

.Center (Ctrl+Shift+C). 

Use this command for centering the image around a particular location. When you select this 
command, the mouse pointer turns into a crosshair. It can be moved around by moving the 
mouse. Position the crosshair at the image location that you want centered and then left-click 
on the mouse to center the whole image around that point. 

.Turn/Do not Turn (Ctrl+T). 

Use this command to Turn ON / OFF image rotation mode.  

To rotate the image about the horizontal or the vertical axis,move the thumb on the scroll 
bars or use the arrow keys on the keyboard. 

Or, use  

“Shift + Mouse Scroll Button Up and Down” for horizontal rotation of model 

“Ctrl + Mouse Scroll Button Up and Down” for vertical rotation of model 

Note: 

While NOT in rotate mode (Do not turn): use: 

“Shift + Mouse Scroll Button Up and Down” for horizontal translation of model 

“Ctrl + Mouse Scroll Button Up and Down” for vertical translation of model 

.Zoom All (Ctrl+A). 

Use this command to view the whole model in the Graphics window. 

.Zoom In, Zoom Out. 

Use these commands to increase or decrease the magnification level for the image. Hotkeys 
are Page Up (for Zoom in) and Page Down (for Zoom out).  You can also use the mouse 
wheel button to Zoom in and Zoom out. 
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.Show. 

Use this command to either display or suppress display of various items in the Graphics 
window. This feature helps in reducing clutter in the displayed image. In addition, it enables 
you to display selectively one or more items in the Graphics window. Select or deselect items 
and click on OK or Apply (to see the effect immediately while keeping the dialog open). 
Click on All or None button to select all or deselect all the items with one click. 

 

The Local Coordinate system can be shown for all the elements while viewing Results. 

.Show/Hide Dots and Numbers (F3). 

Use the hotkey F3 to remove Dots and Node numbers from the graphics display. 

.Show Nodes. 

 

Use this feature to show node numbers selectively at different locations (such as anchors, 
limit stops, valves, etc.) to check your input or to display node numbers selectively for one or 
more items (anchors, hangers, etc.) in the Graphics window. To show node numbers, select 
or deselect the required items and click on OK or Apply (to see the effect immediately while 
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keeping the dialog open). Click on All or None button to select all or deselect all the items 
with one click. 

.Redraw (Ctrl+D). 

Use this command to redraw the entire graphics image. This will refresh the window with the 
existing image. This feature is useful when you are working with a two-monitor system. 

.Render (Ctrl+R). 

Use this command to generate a realistic 3-D image of the model. Once you have a rendered 
image, you can use the Zoom All, Zoom in, Zoom out, Turn and other graphics commands 
on it. You can use the Show and the Show Nodes commands too to show specific items 
and/or node numbers. This image can be printed to a (color) printer. 

Materials, Sections and Loads are shown graphically using Color Codes in rendered graphics. 
Press the “Color Graphics” icon available in Materials, Sections and Loads List windows to 
execute the command. 

 



Graphics Window Options Menu 

 

144 

 

 

Users can also plot Color Coded rendered graphics based on Specific Gravity defined. This 
help in identifying piping systems with different services. This can be performed by selecting 
the option "Color Graphicsusing Sp. Gr" by mouse right click on "List Loads" window while 
being in Color Graphics plot. 
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.Hide Current Element (F6). 

With the graphics cursor flashing on the element of interest, press F6 (or select this 
command) to hide it from view (in rendered mode). 

.Show All (F9). 

Press F9 (or select this command) to display all elements in the Graphics window including 
those that were hidden using the “Hide Current Element” command. 

.Make Transparent (F7). 

Press F7 (or select this command) to make an element transparent so you can see what is 
behind it; useful in congested models. 

.All Transparent (F10). 

Press F10 (or select this command) to make all elements transparent. F11 will make them 
opaque. 

.All Opaque (F11). 

This is the opposite of the previous command in that it makes all transparent elements 
opaque. F10 will make all elements transparent. 

.Show/Hide Selected Elements (F12). 

This command works on showing or hiding a group of elements defined in a range. See 
figure for the different choices. 
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.Increase Symbol Size (Ctrl+Numpad 8). 

This command increases the symbol size in Rendered and Line plots. Alternatively, you can 

use the Icon  to increase the symbol size. 

.Decrease Symbol Size (Ctrl+Numpad 2). 

This command decreases the symbol size in Rendered and Line plots. Alternatively, you can 
use the Icon  to decrease the symbol size. 

.Freeze View (F8). 

This key is a toggle. Pressing F8 freezes or unfreezes the display so you do not lose your 
point of view while modeling. 

You may still perform the Zoom, Pan, Rotate, etc., with the frozen view. Also, the option 
“Freeze View” disables the dynamic updating of view (i.e., view remains unchanged) when 
you scroll in the Layout window. 

.Show/Hide Dots and Numbers (F3). 

Use the hotkey (F3) to remove the Dots and Node numbers from the Graphics window 
simultaneously. Pressing F3 (toggle) again will bring them back. 

Options Menu 

This menu contains commands to change the axes symbol location, color of graphics 
background, OpenGL rendering quality and the graphics font. 

 

.Axes. 

The axes symbol can be displayed in any one of the four corners of the Graphics window or 
not at all. 
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.Background. 

The default background color for the Graphics windows is black. You can change 
background to white or Off white.  Changing so will save printer ink when you print a 
graphics image. 

 

Rendering Quality. 

This feature allows you to set the quality of the rendered image. It is best to set this to High 
unless your computer renders images noticeably slowly. 

 

.Font. 

You can select any available font for the graphics display here. Note: Font for printing 
graphics is selected in the Print Graphics dialog as explained earlier under the “Print” 
command. 
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The text in the image below is shown in Impact font. 

 

.Recover Graphics. 

If CAEPIPE abnormally terminates, such may result in garbled graphics. You can recover 
the graphics image, however, using two methods: 

a) Open the model, enter the data to complete the inputs and save.  Re-open the 
model to recover the graphics, OR 

b) Open the model, enter the data to complete the inputs and save.  Select the 
command "Recover graphics" through Graphics Window > Options. 
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CAEPIPE opens the Results window, one among the four independent windows, either 
after analysis of a model or after you open a results file (.res) from the File menu in the Main, 
Layout or Results windows. 

On successful completion of model analysis, CAEPIPE asks you whether you want to see 
results. Click on Yes to continue.  

 

When you do so, the Results window opens, in which you can view every computed result 
for the piping model. This window displays results in an organized manner conducive to easy 
understanding of the results. The other windows (Layout and List) may be opened from here 
in read-only mode for better comprehension, i.e., any detail in these windows may be viewed 
but cannot be modified. To modify the input data, you must open the Layout window in 
input mode (by selecting menu File > Input). 

A dialog listing the different results for a model is shown below. Select an item to see it. 
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While viewing results, it is helpful to be aware of the following: 

 The name of the results item and the load case (if applicable) are always shown in the 
title bar of the Results window.  See image below. 

 

 Synchronized highlight: When you move the highlight to a node number (or an 
element) in the Results window, the highlight in the Graphics window is 
automatically synchronized to the corresponding node number (or element). 

 One key navigation: By merely pressing the Tab key, you can move forward through 
the different results one at a time (Sorted stresses, Code Compliance, Support Loads, 
Element forces, etc.). Move backward by using Shift+Tab, or by clicking on the cyan 
colored arrows (left and right). In this window, the display order of results is circular, 
i.e., if you press Tab from Sorted Stresses, you will see Code compliance next, or if 
you press Shift+Tab, you will see Time History results (or whichever is the last item 
on the list of computed results).  

 Changing Toolbar and Menus: As you move forward or backward through the 
results, the toolbar changes with the displayed result. Also, the menu commands in 
Results and View menus change. They will contain commands relevant to the 
displayed result.  

 Simultaneous graphics: You can view graphics simultaneously with results (and 
input).  
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 For a few items, you will notice left and right black arrows. By clicking on these 
arrow buttons (or pressing the corresponding arrow keys on the keyboard), you can 
change the load case. Similarly, in some other results, you will notice left and right 
white arrows. By clicking on these arrow buttons (or pressing the corresponding 
arrow keys on the keyboard with the CTRL key), you can display results for other 
related items (for example, while viewing Support loads, you can change over to 
other supports [like limit stops, hangers, restraints, etc.]).  

 

Depending on the model configuration, you might see more choices within a topic. For 
example, you might see the Other Forces dialog from Pipe Forces results screen. You might 
also see the Other Supports dialog from Support Loads results. 

Each results item has a context menu as shown in the sorted stresses window (see previous 
image). Right-click in the results window to see what the context menu offers. 

Sorted Stresses 

For sorted stresses, you are shown Show stresses, Show stress ratios, Thresholds and Hide 
Allowables (see image on previous page). The resulting actions of the first three commands 
apply to the Graphics window and the last one applies to the Results window. For example, 
in the previous image CAEPIPE will remove five columns (1.5SH, SA, SH+SA, 1.8SH and 
3.0SC) when you select “Hide Allowables” thereby allowing you to reduce the information 
presented. See next figure (in which “Allowables” are hidden). 

 

A few screenshots of Results window with the different results items are shown next. 
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Code Compliance 

Here, CAEPIPE displays the stresses on an element-by-element basis. Sorted stresses screen 
(i.e., the previous results item) shows stresses at nodes sorted in the descending order of 
stress ratios. In this Code Compliance results item, CAEPIPE displays stresses for each 
element (highlight is on element 19, nodes 120 and 122). 

From the sample “Code Compliance” results of CAEPIPE shown below, you will observe 
that the 2nd Column titled “Press. Allow” output the following for each element. 

1. First row outputs the “Design Pressure” input for that element. 

2. Second row outputs the “Calculated Allowable Pressure” for that element as per the 
equation provided in the corresponding piping code selected for analysis. Please note, 
when the “Design Pressure” input for an element exceedsthe  “Allowable  
Pressure”computed for that element, then CAEPIPE will change the display color of 
Design Pressure to RED. 

 

Branch Connection Stresses 

Branch connection stresses are available only for ASME Section III codes.You can change 
the load case by pressing the left or right black arrow key. 
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Hanger Report 

 

Flange Report 

 

See the end of the “Flange” section in the Technical Reference Manualfor suggestions on 
how to reduce the ratio in the last column. 

Rotating Equipment Reports 

The rotating equipment reports are produced for all Operating load cases. The example 
model shown below has several cold spring operating load cases and hence you see the left 
and right black arrow keys. 

The left and right white arrow keys advance (or go back) to the next (or previous) rotating 
equipment report.  
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Soil Restraints 

Soil restraints are shown when you have buried piping in your model. 

 

Support Load Summary for 150+ Load Combinations 

This gives you a summary of many combinations of different load cases by showing the 
algebraically minimum and maximum loads. This table can be of use to a support designer. 

CAEPIPE will report support load summaries at every support in the model for over 150 
load combinations (not all are shown below). 
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The supports at which a load summary is available can be shown by clicking on the Other 
Supports button (immediately to the left of the left white arrow button). Select the support 
from the list of available supports. 

 

 

Here, support load summaries are available for the four supports shown. Summaries may be 
included in the “Print to file” option (in addition to inclusion in formatted reports). 

To clearly show the direction of each limit stop among multiple limit stops at the same node, 
the direction is shown alongside the limit stop (see node 60 below). 

 

Note: 

For Time History load case, CAEPIPE will find Signed Forces and/or Moments with 
Maximum Absolute Magnitude under Support Loads at a particular node as shown below 
and add the same along with its sign to other load cases such as Sustained, Operating, etc. in 
the Support Load Summary results. 
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Support Loads 

Support Loads are shown for all support types. For a support type, the support loads can be 
shown for all load cases by clicking on the black right/left arrow or simply press arrow keys 
on the keyboard. A list of load cases can be shown by clicking on the Load cases button. 
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Support loads on all the supports in the model are shown in the next window. The window 
first shows anchor loads, if present. Then, when you click on the left or right white arrow, it 
shows you loads at different supports. 

 

You can find out which other supports are in the model by clicking on the Other Supports 
button (immediately to the left of the left white arrow button). When you click on this 
button, the list of available support types is shown. Select the type. 

 

 

In any window of CAEPIPE, whenever it displays the results in LCS, it will label the heading 
texts with the “Lower Case” letters. For example, the “Forces & Moments” in LCS are 
designated using “fx/fy/fz” and “mx/my/mz”. Similarly, the displacements in LCS using 
“x/y/z/xx/yy/zz”. 
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On the other hand, CAEPIPE displays the results in GCS by designating the heading texts 
with the “Upper Case” letters”. For example, the “Forces & Moments” in GCS are 
designated using “FX/FY/FZ” and “MX/MY/MZ” and the displacements in GCS as 
“X/Y/Z/XX/YY/ZZ”. 

For example, when a Guide is located in a vertical section of pipe, then the local x-axis for 
the Guide is vertical, whereas the local y-axis and local z-axis are in the horizontal plane. 
Local Coordinate System (LCS) for the Guide can be displayed through View > List > 
Guide and right-click mouse and select the option “Show LCS”. Since the pipe can freely 
move axially at the Guide (assuming zero friction), only lateral forces fy and fz are generated 
at the Guide in the local y-axis and local z-axis directions.  On the other hand, pipe 
displacements at the Guide can be seen both in Global and Local Coordinate Systems.  
These can be seen in the snapshots below.  
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In summary, CAEPIPE displays / output the “Support Loads” for different types of 
supports in different coordinate systems as stated below. 
 

a. Anchor – Always in Global Coordinate System (GCS). 

b. Rigid Restraints – Always in GCS. 

c. Guide – By default in Local Coordinate System (LCS). User can view the “Support 
Loads” in GCS by clicking the icon “G” available in the tool bar.  
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d. Limit Stops (Resting / Roller Supports) –  By default in LCS. User can view the 
“Support Loads” in GCS by clicking the icon “G” available in the tool bar. 

e. Skewed Restraints – Always in the direction of the support defined. 

f. Spring Hangers / Rod Hangers / User Hanger / Constant Support Hangers – 
Always in Global Vertical direction. 

Global Forces & Moments can be transformed into Local Forces & Moments using a 
Rotation Matrix formed by the direction vector of the preceding element (or succeeding 
element, if there is no preceding element).  For your convenience, an Excel sheet that 
converts Global Forces & Moments to the Local Forces & Moments once the required 
values are input is available at www.sstusa.com/downloads/GCS_LCS.xlsx.   

To validate this Excel sheet procedure, two (2) CAEPIPE models were analyzed. First one 
has an Anchor attached to a skewed pipe wherein the Anchor loads are output in GCS 
(www.sstusa.com/downloads/BMS.mod). In the 2nd model, the Anchor has been replaced 
with 6 skewed restraints (3 translational and 3 rotational) in the adjacent element’s LCS 
system.  The GCS results from the first model were entered in the Excel sheet in order to 
obtain forces and moments in LCS. These forces and moments in LCS are identical to the 
results from the 2nd model with skewed restraints 
(www.sstusa.com/downloads/BMS_SR.mod).  We recommend that an independent 
validation of the excel procedure is carried out at your end to convert Global Forces & 
Moments to the Local Forces & Moments. 

Results from MultipleThermal and Wind Loads  

Displacements, Support Loads, Element Forces, etc., are calculated for the below shown 
thermal and wind load cases, among others. The sorted stresses screen will always display for 
a specific node the highest expansion stress among all the selected thermal load cases. 
Similarly, if any of the four wind load cases happens to be the worst among all occasional 
loads for a specific node, then that occasional stress value will be shown under occasional 
stresses. 

http://www.sstusa.com/downloads/GCS_LCS.xlsx
http://www.sstusa.com/downloads/BMS.mod
http://www.sstusa.com/downloads/BMS_SR.mod
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Element Forces 

Forces and moments on all pipe elements are shown next. If you had other elements such as 
a valve, you can display forces and moments for them too by clicking on the Other Forces 
button on the toolbar. 
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The default view for forces and moments is in the local coordinate system. They can be 
shown in the global coordinate system too by clicking on the Global forces button (or 
selecting Global Forces command from the Results menu, hotkey: F7). When you select 
Global forces, the forces and moments are shown in global coordinates and the button 
changes in the same location (on the toolbar) to an “L” for Local forces. So, should you 
want to return to pipe forces in local coordinates, simply click again at the same location on 
the Local forces button. 

 

The convention in CAEPIPE is to display the headings for global forces and moments in 
uppercase (FX, FY, FZ, etc.) and display the headings for local forces and moments in lower 
case (fx, fy, fz, etc.). 

Sorted FRP Stresses 
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The various FRP stresses such as hoop, maximum and minimum longitudinal and torsional 
stresses are sorted here by descending order of stress ratios assuming you have input the 
material allowables. 

Displacements 

Displacements for all load cases can be shown (operating load case shown here). Click on the 
black left/right arrow to show displacements for other load cases. You can show the 
deflected shape in the graphics window for any load case by clicking on the button to the left 
of the “A” button. 

 

You can animate the same deflected shape by clicking on Show animated deflected shape 
(last) button in the toolbar. 



Results Window 
 

165 

You have the option of showing the deformed state coordinates in the global coordinate 
system along with the displacements at each node. Is snapshot below updated from V8.0? 

 

These deformed state coordinates are useful in locating hanger attachment points on the steel 
structures or concrete slabs/walls from which the hangers are to be hung, such that the 
hangers remain almost “vertical” (and not skewed) during normal operating load case. 

 

Also, you can show Minimum/Maximum displacements, displacements at flexible joints (if 
any) by clicking on the Other displacements button and selecting the item of interest (or by 
clicking on the left/right white arrows). 
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Displacements in local coordinates for all flexible joints (bellows, ball, hinge, etc.) are shown 
under Flex joints. 

 

Minimum/Maximum displacements for each load case can be shown (Operating load case 
shown below). You can show minimum/maximum displacements for other load cases by 
clicking on the black arrows. 
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Displacements at “Other supports” can be shown (limit stops shown here). 

 

Frequencies 

A list of natural frequencies, periods, modal participation factors and modal mass fractions is 
shown next. You can show each frequency’s mode shape graphically or animate it by clicking 
on Show mode shape or Show animated mode shape button in the toolbar. 
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Each frequency’s mode shape detail is shown in the next window. As in the earlier window, 
you can show graphically the mode shape or animate it by clicking on the appropriate button.  

 

Dynamic Susceptibility 

Please refer to topic by this name in the Technical Reference Manual and also Annexure I of 
the Technical Reference Manual to understand the screen shots shown below. 
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Time History 

For time history results, you are shown the following dialog from which you need to select 
an item. 

 

Then, you are shown a list of supports in the model from which you need to select one. 
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Once you select a support from the list, then you are shown the time history at that location. 

 

While viewing these results, you can export time history results to a comma separated values (.csv) file that can 
be read by a spreadsheet program such as MS-Excel (see menu File > Export) for plotting, etc. 
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Hotkeys You Can Use 

For keyboard operations, the following list of hotkeys (in addition to MS-Windows keys for 
open, print, exit, etc.) can make you more productive. 

Tab Next results item 
(Shift) Tab Previous results item 
Right Arrow Key Next load case or mode shape 
Left Arrow Key Previous load case or mode shape 

Ctrl+Right Arrow Key Next item of same type (e.g., next support) 
Ctrl+Left Arrow Key Previous item of same type (e.g., previous support) 
Ctrl+F Find node 
Ctrl+L List 
Ctrl+U Units 

Ctrl+A Graphics - Zoom all 
F2 Move focus to Graphics window 

F3 Move focus to Layout, List or Results window 
 (wherever the focus was before) 

F4 Graphics - Set Viewpoint 
F5 Graphics - Previous view 

F6 Show list of Other supports, forces, displacements, etc. 
F7 Show forces, displacements in global/local coordinates 

Ctrl+D Show/Hide deflected shape*  
Ctrl+Shift+A Show/Hide animated deflected/mode shape* 

* Works only while reviewing Displacement Results / Mode Shapes / Frequencies. 
Menus and Toolbar 

These items are explained in detail under Menus. A summary is given here. 

 

File menu 

This menu contains commands for file operations including starting a new model, opening a 
Results file, printing, etc. 

Results menu 

This is one of the menus that changes with the displayed result. At all times, it contains 
commands for 

 Display list of Results  

 Move forward to Next Result (Tab key)  

 Move backward to Previous Result (Shift+Tab key) 

An example of the additions to the Results menu: 
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When Support Loads are displayed, the menu displays, in addition to the above, the 
following commands: 

 Other supports  

 Next Support  

 Previous Support  

 Load cases  

 Next Load case  

 Previous Load case  

All of the above commands also appear on the (context-sensitive) toolbar. 

View menu 

Commands for graphics operations are available from here. This menu, like the Results 
menu, changes with displayed results. 

An example of the changes: 

When Sorted Stresses are displayed, the menu displays, in addition to the above, the 
following commands: 

 Show stresses in the Graphics window  

 Show stress ratios in the Graphics window  

 Set stress or stress ratio thresholds (to display stresses or stress ratios that are above a 
specific threshold value). 

You do not have to move focus to the Graphics window to execute these commands. 

Options menu 

You can change units or font from the options menu. Any change here in units or font will 
affect all text windows. But the change in units is not saved when you close the Results 
window (they will be saved only when you change units in input mode and save the model). 

Window menu 

You can move focus to other windows. Use F2 to move between text and Graphics 
windows, and F3 to move focus between open text windows. This is helpful to those who 
work with maximized windows (perhaps, because of a lower monitor resolution). 

Open Other Windows 

You can open the remaining text windows from here - List and Layout - to have all four 
windows open at the same time to enhance your understanding of the model results. Use the 
Window menu to open the other windows.  They are displayed in non-editable mode. 

Help menu 

For on-line help and information pertaining to the remaining period of your yearly 
Maintenance, Enhancement and Support (ME&S) agreement with SST. 
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File Menu 

 

The File menu here is similar to the File menu in the Layout window. You can open or close 
any CAEPIPE model, material, spectrum library or CAEPIPE results file from here. 

.Print (Ctrl+P). 

This is a comprehensive command that lets you print all model input and computed results. 
This dialog has five tabs and six buttons. 

.Model. 

On this tab, check those input data items that you would like to print. 
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.Load cases. 

On this tab, check the different load cases for which you want to print results. 

 

.Results. 

On this tab, check the different results items that you want to print. 
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.Misc. 

On this tab, select the items of interest that you want to print. 

 

.Printer. 

On this tab, you can customize your printer settings such as selecting a different printer, 
setting different margins, and the print font. By selecting a custom Adobe Acrobat-
compatible printer (if available on your system), you can generate an Adobe PDF (Portable 
Document Format) file that contains the whole model input and output. 
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Print Dialog Buttons 

.Print.  

After selecting the items you want to print, click on Print button to send output to the 
printer selected under the Printer tab. 

.Cancel.  

You can click on Cancel to exit the dialog without printing. 

.Preview.  

Before printing, you can preview how the printed output will appear by clicking on Preview. 
If necessary, you can adjust the printer settings (under the Printer tab) to change the print 
font and margins, and preview again. 
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.To File.  

If you want to send all of your selected items (input and results) click on the To File button. 

 

You can export the data to a .txt file or to a .csv file. 
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Here's an example of what the .csv file looks like with the exported data (reading from a 
spreadsheet software). 

 

.All.  

To select all items, click on the All button. 

.None.  

To deselect all items, click on the None button. 

.Export. 

This command lets you export Time History results to .CSV file and Hanger Report to 
LICAD software using an ASCII file with extension (.cli). 

.Export to 3D Plant Design. 

This command lets you export deformed geometry to 3D Plant Design software 
E3D/PDMS and CADMATIC while being in Displacements results. 

In order to comply with space constraints, piping designers check for interferences between 
piping and the adjacent structures, concrete buildings, equipment and reserve volumes for 
walkthrough, maintenance space etc. either manually on General Arrangement drawings or 
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nowadays in a 3D Plant model. Unfortunately, such “Clash-check” is performed using only 
“as-designed” drawings/3D model. In reality, piping systems deform due to its own dead-
weight during installed/shut-down condition, during hydrotest as well as during operating 
condition. Clash-checks for piping systems under such “deformed conditions” are usually 
never performed till date. This option transfers “deformed shapes” for the piping system for 
different loading conditions to the 3D Plant Design software. 

The 3D Plant Design software, in turn, could then check for interference under different 
loading conditions as well as under the traditional “as-designed” model condition by 
exporting the “deformed layouts for loading conditions of interest”through the option 
Results Window > File > Export 3D Plant Design. 

.Input. 

This useful command allows you to go to the model Layout window quickly without having 
to go through a model File > Open… command. 

.QA Block. 

This command shows you the QA information you input in the Layout window. As the 
shown information is not editable here, to make changes to it, you need to go back to the 
Layout window and use the same command under the File menu. After you make edits, you 
need to save the model and reanalyze. 
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Results Menu 

.Results Navigation 

 

You can open the list of all results computed by selecting Results command (Ctrl+R). Press 
Tab or Shift+Tab to move forward or backward through the different results items, each of 
which will be shown in the same Results window. 

This menu may change with the displayed results item. For example, the menu shows like in 
the above figure for Sorted Stresses, Code Compliance and Hanger Report. 

You can open “Support load summary” results by selecting Results command (Ctrl+R) and 
then the radio button “Support load summary”. 

For Support load summary, the menu shows similar to the following figure. The first set of 
commands is for showing the support load summary for other supports, one at a time. The 
second set of commands is as before. 

 

Pressing F6 key will display the window for “Other supports” as shown below. 
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For Support Loads, the menu changes to show related commands for the new results item. 

 

The first set of commands is for showing the support loads for other supports (hangers, limit 
stops, etc.), one at a time (you can also click on the white right or left arrow). 

 

The second set of commands (Load cases, etc.) is for changing the load case for the 
displayed support. For example, the title bar of the figure shows Loads on Anchors: 
Sustained. You can change the load case to Expansion load case for this support by selecting 
the Next load case command (you can also click on the black right or left arrow). The last set 
of commands is as before, moving through different Results screens. 

For Element forces, the menu changes to show related commands. 

 

The first set of commands is for showing other forces (at other elements such as expansion 
joints and valves), one at a time (you can also click on the white right or left arrow). 
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The second set of commands (Load cases, etc.) is for changing the load case for the 
displayed Element forces. For example, if the title bar of the figure showed Sustained load 
case, then by selecting the Next Load case command, you can display forces for the 
Expansion load case (you can also click on the black right or left arrow). The last set of 
commands is as before, moving through different Results screens. 

For Displacements, the menu changes to show related commands as follows: 

 

The first set of commands is for showing other displacements (such as minimum and 
maximum displacements and displacements at Hangers, Guides, Limit Stops, etc.).You can 
also click on the white right or left arrow. 

  

The second set of commands (Load cases, etc.) is for changing the load case for the 
displayed displacements. For example, if the title bar of the figure showed Sustained load 
case, then you can show displacements for the Expansion load case by selecting the Next 
Load case command. (You can also click on the black right or left arrow). The last set of 
commands is as before. 
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For Mode Shapes, the menu changes to show two commands specific to the new results. 

 

They are to move forward or backward through the available mode shape details. The last set 
of commands is as before. 

So, depending on the displayed results item, the Results menu (Ctrl+R) will show different 
menus with at least one common set of commands for moving forward or backward through 
the different results. 

 

.First-Level Checks. 
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This menu is available only when the load cases “Sustained (W+P)” and “Expansion (T1)” 
are turned ON for all piping codes excepting the “NONE” code. For NONE code, the load 
case “Static” should be turned ON. 

Pipe stress engineers normally carry out a number of analysis iterations on each stress model 
to arrive at a suitable support scheme that would meet all required pipe stress criteria.  When 
performing such analysis iterations, they would like to review only key results (summarized 
under one command) at the end of each analysis. Based on such key results, they decide their 
next course of action on each stress model. The menu “First-level Checks” provides an easy 
way for stress engineers to review key results for their analyses. 

Key results that can be reviewed using this menu are as follows. 

Contour plots of stress ratios for Sustained, Expansion and Occasional stresses 

Deflected shapes for Sustained, Thermal, Operating, Seismic (static) and Wind loads 

Support Load Summary for Nozzles and Anchors 

Hanger Report 

Status of Piping at Resting Supports for Sustained and Operating loads (resting or lifted-off) 

Frequencies and Mode Shapes 

When piping designers use CAEPIPE 3D+ along with 3D Plant Design systems, they can 
use this menu “First-level Checks” to review key results that would guide them to arrive at 
piping layouts that would be flexible enough to absorb thermal expansion/contraction. 
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View Menu 

 

This menu contains commands mostly forgraphics operations. The List and Find Node 
commands function like they do in Layout window > View menu. Center of Gravity 
command is covered later in this section. As with the Results menu, this menu too changes 
its offerings depending on the results item being viewed. 

The first menu shown here is available from the Sorted Stresses results. The first set of 
commands helps you view stresses graphically in the Graphics window. 

.Color code stresses./ .No color coding. 

Displays or removes the color coded stress (or stress ratio) contour in the Graphics window. 
To display a color coded contour, place the yellow highlight on the type of stress you want to 
see graphically, for example, on Expansion stress. Then, select Color code stresses. Next, 
click on Show stresses or stress ratios button on the toolbar. The Graphics window will 
show the color coded contour plot. 

For Jacketed piping, the color coded contour plot shown is for the core pipe. You can also 
view the stress contour plot for the jacket piping using the command “Show Jacket stresses 
/Ratios” as shown in the graphics below. 
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When you select No color coding, numeric values for stresses or stress ratios are shown (see 
next image). 

 

.Thresholds. 

Use this command to display stresses (or stress ratios) over a specified stress or stress ratio 
value.  
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.Hide Allowables. 

Selecting this command will remove the Allowables columns from the Results display. For 
some codes that have too many columns, this command helps by lessening the number of 
columns displayed. 

All commands (except Hide Ratios and Center of Gravity) function like they do under the 
Layout window > View menu. 

Under the Code Compliance results display, the View menu shows only one command to 
Hide (Stress) Ratios (such as SL/SH, SE/SA). The remaining commands are the same as 
before. 

 

For the Pipe element (or Other element) forces display, the following View menu is shown. 

 

The only item new here is a command to Show LCS (Local Coordinate system)/Hide LCS in 
the Graphics window for each element. As you keep scrolling through the different elements 
in the results display, the corresponding element in the Graphics window will show a small 
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coordinate symbol that depicts the element’s LCS. The remaining commands are the same as 
before. 

 

For Displacements results display, two commands to show and animate the deflected shape 
are shown. The remaining commands are the same as before. 

The deflected shape shown in CAEPIPE graphics is “Magnified” with a scale factor greater 
than 1.0. For the Deflected shape shown below for operating load case, CAEPIPE has 
magnified the deflected shape by a factor of 9. This magnification factor can be modified 
through Results Windows > View > Magnification… while being in deflected shape plot in 
CAEPIPE as shown below.  

 



Results Window View Menu 

 

190 

 

For Frequencies and Mode Shapes results display, two commands to show and animate the 
mode shapes are shown. The remaining commands are the same as before. 
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.Center of Gravity. 

This command displays the center of gravity and total weight of the piping system as 
modeled. This information can be useful when you are comparing the weight of this model 
with total weight obtained from another source. 

 

The Total weight is the sum of empty, insulation, content and lining weights. 
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Environmental Variable for Import / Export 

It is possible to export model to MBF file with length units in "Inches" and moment units in 
“lb-in”. This can be done by setting the following. 

1. Length unit is defined in inches in .mod file and  

2. An environmental variable with name "EXPORT_INCHES" with value is set to 
"YES".  

This option is introduced to maintain the accuracy of the model by avoiding rounding-off 
issues while exporting and importing via MBF.  

MBF Import 

CAEPIPE can import model data from a text file, which may be created using a text editor 
and should have the extension: .mbf (model batch file). This text file may also be created for 
an existing model using the Export command from the Layout window. 

To import a model, select the menu command File > Import from the Main window. 

 

The Import Model dialog is shown. 
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Select the model batch file (.mbf) and then click on the Import button. The batch file will be 
read and the corresponding model file (.mod) will be created and then shown in the Layout 
window which can be further modified or analyzed. 

For detailed information on the .pnf and .cii file import capabilities please contact us at 
support@sstusa.com.  

Command line operation 

Dragging and dropping an .mbf file on CAEPIPE.exe will import, analyze and produce the 
results in .csv format and close the program. On the other hand, dragging and dropping the 
.mod file on CAEPIPE.exe will open the .mod file. Using the command line, you may have 
CAEPIPE analyze and produce a CSV results file thus: 

C:\CAEPIPE> caepipe.exe sample.mbf (Enter)  

The above command will produce a “sample.csv” file in the same folder as the .mbf file. 

Format of .MBF 

The input data is given in the following order. Except for the heading the start of each 
section is indicated by a keyword. The data for that section follow. Only the first three 
characters of the keyword are significant. See an example MBF at the end of this appendix. 

Note: 

CAEPIPE input for Concentrated Mass, Ball Joint, Rigid Element, Valve, Bellows, 
Slip Joint etc. require the “Weight” of that item to be input in lbf, kgf etc. and NOT 
its mass. So, whenever mass is required for a calculation as in the case of forming 
Mass matrix for dynamic analysis, or in calculating inertia force as (mass x 
acceleration) for static seismic analysis, CAEPIPE internally computes the mass for 
each item to be equal to (weight / g-value).  

Similarly, for density of pipe, insulation and lining materials, CAEPIPE requires 
“Weight Density” to be input in lbf/in3, kgf/m3 etc. and NOT its mass density. 

Keyword Data 
 Heading 
OPTIONS Program options 
MATERIAL Material properties 
SOILS Soil properties 
PIPE Section properties 
LOADS Loads data 
BMATERIALS Beam Materials 
BSECTIONS Beam section properties 
BLOADS Beam loads 
SPCMS Spectrums (available in CAEPIPE Version 10.50 or later) 
SPLVL Spectrum Levels (available in CAEPIPE Version 10.50 or later) 
LAYOUT Layout data 
PUMPS Pump data 
COMPRESSORS Compressor data 
TURBINES Turbine data 
SEISMIC Seismic load 
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WIND Wind load 
ALLOWABLES User allowable loads 

Heading 

Any number of heading lines may be given.  Only the first will be used as Title in the 
CAEPIPE model. 

OPTIONS 

Hanger design 

HGRA Grinnell (Default) 
HGRB Bergen-Paterson 
HGRC Fee and Mason 
HGRD Basic Engineers 
HGRE Power Piping 
HGRF Nordon 
HGRG Carpenter and Paterson 
HGRH NPS 
HGRI PTP 
HGRJ Corner and Lada 
HGRK Elcen 

Piping Code 

B311 ASME B31.1 
B311-67 USAS B31.1 (1967) 
B313 ASME B31.3 
B314 ASME B31.4 
B315 ASME B31.5 
B318 ASME B31.8 
B319 ASME B31.9 
B3112 ASME B31.12 
ASME ASME Section III, Class 2 (1980) 
ASME-86 ASME Section III, Class 2 (1986) 
ASME-92 ASME Section III, Class 2 (1992) 
ASME-2015 ASME Section III, Class 2 (2015) 
ASME-2017 ASME Section III, Class 2 (2017) 
ASME-ND-2017 ASME Section III, Class 3 (2017) 
BS806 British code 
NORWEIGIAN-83 Norwegian code (1983) 
NORWEIGIAN-90 Norwegian code (1990) 
RCC-M French code (1985) 
SNCT CODETI (1995) 
SWEDISH Swedish code (1978) 
STOOMWEZEN Dutch code (1989) 
Z183 Z183 (1990) 
Z184 Z183 (1992) 
Z662 Z662 
EUROPEAN EN 13480 
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Units 

SI SI units (default is English units) 
RAD Radians for angles (default is degrees) 

Vertical Axis 

Z Vertical axis is Z (Default is Y) 

OPTIONS Example 

OPTIONS 
HGRA,B311,RAD 

[OPCODE] 

[Options > Analysis > Code. Optional Section valid for CAEPIPE Version 10.10 and later]  

This Section is Optional. If defined, then the syntax should be as given below. The values in 
square brackets ([...]) are optional. 

Include axial force in stress calculation (0 = Off, 1 = On), Liberal allowable (0 = Off, 1 = 
On), [Use B31J (0 = Off, 1 = On. Valid only for ASME B31.x codes, for other codes, this 
field is ignored)], [Service level (valid for ASME Class 2 and Class 3 codes. 0 = B(Upset), 1 = 
C(Emergency) and 2 = D(Faulted). For other piping codes, leave this field as 0], [B31.8 
Design Factor Index (F), Valid for B31.8 Code. Set 0 = 0.80, 1 = 0.72, 2 = 0.60, 3 = 0.5 and 
4 = 0.4. For other piping codes, leave this field as 0], [Z183 Location Factor Index (L). Valid 
for Z183 Code. Set 0 = 1.0 and 1 = 0.8. For other piping codes, leave this field as 0], [Class 
Location (L). Valid for Z184 and Z662 Code. Value can be 1, 2, 3 or 4 for Z184 and 1 to 120 
for Z662 [available in CAEPIPE Version 10.50 or later]. For other codes, leave this field 
as 1],  [Z184 Sour Service. Valid for Z184 Code. Set 0 = Nonsour service, 1 = Sour service. 
For other codes, leave this field as 0], [EN 13480 Seismic Factor (K). Valid only for EN 
13480 code. Value should be > 1.00] 
 
Example 1 [for ASME B31.3 Code] 
OPCODE 
1, 1, 1 
Example 2 [for ASME Class 2 Code] 
OPCODE 
1, 0, 0, 2 
Example 3 [for ASME B31.8 Code] 
OPCODE 
1, 1, 0, 0, 3 
Example 4 [for Z183 Code] 
OPCODE 
1, 0, 0, 0, 0, 1 
Example 5 [for Z184 Code] 
OPCODE 
1, 0, 0, 0, 0, 0, 4, 1 
Example 6 [for EN 13480 Code] 
OPCODE 
1, 0, 0, 0, 0, 0, 1, 0, 1.33 
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[OPTEMP] 

[Options > Analysis > Temperature. Optional Section valid for CAEPIPE Version 10.10 and later] 

This Section is Optional. If defined, then the syntax should be as given below. The values in 
square brackets ([...]) are optional. 

English units 

Reference Temperature (F), [Number of Thermal Cycles], [Number of Thermal Loads (1, 2, 
3 or 10)], [Solve Thermal Case (0 = Off, 1 = ON)], [Use Cold Modulus (0 = Off, 1 = ON. 
This field is ignored for ASME B31.3, B31.4, B31.5, 31.8, B31.12 and EN 13480] 
 
SI units 

Reference Temperature (C), [Number of Thermal Cycles], [Number of Thermal Loads (1, 2, 
3 or 10)], [Solve Thermal Case (0 = Off, 1 = ON)], [Use Cold Modulus (0 = Off, 1 = ON. 
This field is ignored for ASME B31.3, B31.4, B31.5, 31.8, B31.12 and EN 13480] 
 
Example 1 [English units] 
OPTEMP 
70 
Example 2 [SI units] 
OPTEMP 
21.11, 7000, 1 
Example 3 [English units with ASME B3.1 code] 
OPTEMP 
70, 7000, 0, 0 
 
[OPPRES] 

[Options > Analysis > Pressure. Optional Section valid for CAEPIPE Version 10.10 and later] 

This Section is Optional. If defined, then the syntax should be as given below. The values in 
square brackets ([...]) are optional. 

[Pressure Stress Option (0 or 1); 0 = Use PD/4t], [Bourdon effect (0 = Off, 1 = ON)], 
[Pressure Correction for Bends (0 = Off, 1 = On)], [Peak Pressure factor. Value should be 
>= 1.00] 
Example 1 
OPPRES 
0, 1, 1, 1.50 
Example 2 
OPPRES 
 
Note:  
Leaving a BLANK line following the Section heading “OPPRES” will set the values as 0, 1, 
1, 1.00.  
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[OPMISC]  

[Options > Analysis >Dynamics &Misc. Optional Section valid for CAEPIPE Version 10.10 and 
later] 

This Section is Optional. If defined, then the syntax should be as given below. The values in 
square brackets ([...]) are optional. Spectrum related options given below are available in 
CAEPIPE Version 10.50 or later 

[Cutoff Frequency], [Number of modes], [Include Missing Mass (0 = Off, 1 = On)], [Include 
Friction in Dynamics (0 = Off, 1 = On)], [Include Hanger Stiffness (0 = Off, 1 = On)], 
[Spectrum Mode Sum (1 = Absolute, 2 = SRSS, 3 = Closely Spaced, 4 = NRL )], [Spectrum 
Direction Sum (1 = Absolute, 2 = SRSS)], [Spectrum Group Sum (1 = Absolute, 2 = SRSS)] 

Example 1 

OPMISC 
100, 20, 1, 0, 1, 2, 2, 1 

Example 2 

OPMISC 
 
Note:  
Leaving a BLANK line following the Section heading “OPMISC” will set the values as 33, 
20, 1, 1, 1, 2, 2, 1  
 
SPCMS 

[This section is available in CAEPIPE Version 10.50 or later] 

Name of Spectrum (up to 32 characters).  

First line: Name, No. of Spectrum entries, Abscissa Interpolation, Ordinate Interpolation, 
Abscissa Units, Ordinate Units. 

Following lines: Name, Abscissa, Ordinate 
. 
. 
SPLVL  

[This section is available in CAEPIPE Version 10.50 or later] 

Name of Spectrum Level (up to 8 characters).  

Name, Abscissa Interpolation (0 = linear, 1 = log), Ordinate Interpolation (0 = linear, 1 = 
log), Abscissa Units(0 = frequency, 1 = period), Ordinate Units (0 = inch, 1 = mm, 2 = 
in/sec2, 3 = mm/sec2, 4 = g’s). 

MATERIAL 

Name is Material Name (up to 5 characters). The values in square brackets ([...]) are optional. 

English units 

First line: Name, Density (lbf/in3), Poisson’s ratio, [Long. joint factor], [circ. joint factor] 
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Following lines: Name, Temp (F), E (psi), alfa (in/in/F), [allowable stress (psi)], [yield stress 
(psi)], [rupture stress (psi)] 
. 
. 
SI units 

First line: Name, Density (kgf/m3), Poisson’s ratio, [Long. joint factor], [circ.joint factor] 

Following lines: Name, Temp (C), E (N/mm2), alfa (mm/mm/C), [allowable stress 
(N/mm2)], [yield stress (N/mm2)], [rupture stress (N/mm2)] 
. 
. 
MATERIAL Example (English units) 

MATERIAL 
A53,0.283,0.300,1.00 
A53,70,29.5E+6,6.07E-6,20000 
A53,200,28.8E+6,6.38E-6,20000 
A53,300,28.3E+6,6.60E-6,20000 
A53,400,27.7E+6,6.82E-6,20000 
A53,500,27.3E+6,7.02E-6,18900 
ALU,0.098,0.330,1.00 
ALU,70,10.0E+6,12.25E-6,10000 
ALU,150,9.80E+6,12.67E-6,10000 
ALU,200,9.60E+6,12.95E-6,9800 
ALU,250,9.40E+6,13.12E-6,9000 
ALU,300,9.20E+6,13.28E-6,6600 

SOILS (Soil properties) 

Soil properties are input as follows: 

Note: 
Name is Soil Name (up to 3 characters) 
Type must be 0 or 1 (1 = Cohesive; 0 = Cohesive less) 
If Type = 0, then Delta and Ks is required 
If Type = 1, then Strength is required 

English units 

Name, Type (0 or 1), Density (lbf/ft3), Ground level (ft’in”), [Strength (psi) /Delta (deg or 
rad], [Ks] 

SI units 

Name, Type (0 or 1), Density (kgf/m3), Ground level (mm), [Strength (N/mm2) / Delta 
(deg or rad ], [Ks] 

PIPE (Section properties) 

Section properties are input as follows for pipe sections: 

Note: 

Name is Section Name (up to 5 characters). 
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OD must be actual OD and not Nominal pipe size (e.g., input 2.125 and not 2.0 for 2” NPS) 
Thk must be an actual numerical value and not a schedule. 
Soil name is Name of the soil (up to 3 characters). It should be defined in the soil section 
before use in this section. 

English units 

Name, OD (inch), Thk (inch), Corrosion allowance (inch), Mill tolerance (%), Insulation 
density (lbf/ft3), Insulation Thk (inch), Lining density (lbf/ft3), Lining Thk (inch), Soil name 

SI units 

Name, OD (mm), Thk (mm), Corrosion allowance (mm), Mill tolerance (%), Insulation 
density (kgf/m3), Insulation Thk (mm), Lining density (kgf/m3), Lining Thk (mm), Soil name 

PIPE Example (English units) 

PIPE 

8,8.625,0.5,0,0.0,11,2 

6,6.625,0.28,0,0.0,11,2 

LOADS (Load data) 
Load data are input as follows: 

Note: 
Name is Load Name (up to 5 characters). 
T2 through T10are Temperature 2 and through Temperature 10. 
P2 through P10are Pressure 2 and through Pressure 10. 
The values in square brackets ([...]) are optional. 

English units 

Name, Temperature 1 (F), Pressure 1 (psi), Specific Gravity, [T2,P2,T3,P3, Additional weight 
(lbf/ft), Design Temperature, Design Pressure, T4, P4, T5, P5, T6, P6, T7, P7, T8, P8, T9, 
P9, T10, P10, Wind] 

SI units 

Name, Temperature 1 (c), Pressure 1 (bar), Specific Gravity, [T2,P2,T3,P3, Additional weight 
(kgf/m), Design Temperature, Design Pressure, T4, P4, T5, P5, T6, P6, T7, P7, T8, P8, T9, 
P9, T10, P10, Wind 1, Wind 2, Wind 3, Wind 4] 

Note: 

Design Temperature, Design Pressure, T4, P4, T5, P5, T6, P6, T7, P7, T8, P8, T9, P9, T10, 
P10 are valid for CAEPIPE Version 10.10 or later. 

Wind = Include or Exclude Wind 1 (1 = Include, 0 = Exclude). Valid for CAEPIPE Version 
10.20 or later 

Wind 2 = Include or Exclude Wind 1 (1 = Include, 0 = Exclude). Valid for CAEPIPE 
Version 10.40 or later 

Wind 3 = Include or Exclude Wind 1 (1 = Include, 0 = Exclude). Valid for CAEPIPE 
Version 10.40 or later 
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Wind 4 = Include or Exclude Wind 1 (1 = Include, 0 = Exclude). Valid for CAEPIPE 
Version 10.40 or later 

If Design Temperature and Design Pressure is not available then the Maximum of Operating 
Temperature and Maximum of Pressure input will be assigned as Design Temperature and 
Design Pressure respectively. 

Example 1 [English Units] 

LOADS 

1,366,120,1.0,70,0,70,0,0 

Example 2 [English Units] 

LOADS 

1,366,120,1.0,70,0,70,0,0,366,160 

Example 2 [SI Units] 

LOADS 

C1,21.11,0,0.01,121.1,0.70,121.1,0.70,0,121.1,0.70,121.1,0.70,121.1,0.70,21.11,0,21.11,0,21.11,0,
21.11,0,21.11,0,1,0,0,1 

BMATERIALS (Beam Materials) 

Name is Material Name (up to 5 characters). The values in square brackets ([...]) are optional. 

English units 

Name, Young’s Modulus (psi), [Poisson’s ratio, Density (lbf/in3), Alfa (in/in/F)] 

SI units 

Name, Young’s Modulus (Mpa), [Poisson’s ratio, Density (kgf/m3), Alfa (mm/mm/c)] 

BSECTIONS (Beam Sections) 

Name is Beam Section name (up to 5 characters). The values in square brackets ([...]) are 
optional. 

English units 

Name, Axial area (in2), Major moment of inertia (in4), Minor moment of inertia (in4), 
[Torsional inertia (in4), Major shear area (in2), Minor shear area (in2), Depth (inch), Width 
(inch)] 

SI units 

Name, Axial area (mm2), Major moment of inertia (mm4), Minor moment of inertia (mm4), 
[Torsional inertia (mm4), Major shear area (mm2), Minor shear area (mm2), Depth (mm), 
Width (mm)] 

BLOADS (Beam Loads) 

Name is Beam Load name (up to 5 characters). The values in square brackets ([...]) are 
optional. 
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T2 through T10are Temperature 2 and through Temperature 10. Valid for CAEPIPE 
Version 10.10 or later. 

Wind 1 = Include or Exclude Wind (1 = Include, 0 = Exclude) 

Wind 2 = Include or Exclude Wind 1 (1 = Include, 0 = Exclude). Valid for CAEPIPE 
Version 10.40 or later 

Wind 3 = Include or Exclude Wind 1 (1 = Include, 0 = Exclude). Valid for CAEPIPE 
Version 10.40 or later 

Wind 4 = Include or Exclude Wind 1 (1 = Include, 0 = Exclude). Valid for CAEPIPE 
Version 10.40 or later 

English units 

Name, T1 (F), [T2 (F), T3 (F), Additional weight (lbf/ft), T4, T5, T6, T7, T8, T9, T10, Wind 
1, Wind 2, Wind 3, Wind 4] 

SI units 

Name, T1 (c), [T2 (c), T3 (c), Additional weight (kgf/m), T4, T5, T6, T7, T8, T9, T10, Wind 
1, Wind 2, Wind 3, Wind 4] 

LAYOUT 

The piping layout is entered as a (key letter-data) pair, which may be input in any order. The 
exceptions to this convention are the comments which must always appear last. The pairs are 
separated by commas. A data line which contains only continued comments (from the 
previous line) is acceptable. A list of key letters follows: 

* Model comments 
F From node 
T To node 
H Hydro test Load 
L Location node 
K Code for node 
M Material number 
P Pipe (Section) property number 
J Joint code 
X X offset 
Y Y offset 
Z Z offset 
B Bend radius 
C Comments (separated by commas) 
LAYOUT Example (English units) 

LAYOUT 
F10,KA,M5,P12,CT=650,P=500 
T20,KI,X10’8-1/2,B20 
T30,Z8 
T40,JR,X1’6,CWGT=250 

 

*  The model comment section allows entry of notes relevant to analysis 
model.  The model comment can be up to 70 characters. 
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 Example:  *Load cases considered for analysis are T1 and P1. 

F (From) From node is specified.  When a new branch is started, the first node of 
the branch is specified as a “From” node.  The X, Y and the Z fields are 
taken as coordinates rather than offsets from the previous node. 

T (To) To node is specified. This is a “To” node from the previous “From”node 
or the previous “To” node (but not from the previous “Location node”). 

L (Location) Location node is used to input additional data at a node when the node has 
more than one data item such as a hanger/force, etc. 

K (Code) The following codes may be used: 

 Code Description 

 A Anchor 
 B Branch connection 
 G Generic Support (valid for CAEPIPE Version 10.30 or later) 
 H Hinge (To node only) 
 M Miter bend (To node only) 
 I Tangent intersection (To node only) 
 T Welding Tee 
 S Sweepolet 
 W Weldolet 
 F Fabricated Tee 
 E Extruded Tee 
 R Radiused branch 
 P Branch on thickened pipe 

M (Material) A material is retained until altered.  Another material should be entered 
only when there is a change. 

P (Pipe) A pipe (section property) is retained until altered.  Another section 
property should be entered only when there is a change. 

J (Joint Code) Code Description 

 B Ball joint 
 C Cut pipe 
 D Reducer 
 E Expansion 
 I Jacket bend 
 L Elastic element 
 M Beam 
 P Jacket pipe 
 R Rigid 
 S Slip joint 
 T Tierod 
 V Valve 

 The weight of a rigid joint or a valve should be entered using 
aWGTcomment. The stiffnesses of the expansion joint should be entered 
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using an ES comment and the pressure thrust area should be entered using 
the TA comment. 

X, Y and Z The offsets May be entered in combination of feet, inches and fractions of 
an inch for English units and mm for SI units. 

 Example (English units) 

 Entry  Value 
 -10  -10 ft 
 10’8 or 10-8 10 ft 8 in 
 0’8 or 0-8 8 in 
 10.5  10 ft 6 in 
 1’6-3/8 or 1-6-3/8 1 ft 6.375 in 

B (Bend Radius) The bend radius (inch or mm) is entered only if a tangent intersection(i.e., 
Bend, Jbend and Miter Bend) has been specified.  The default is the long 
radius for the bend and jacketed bend. 

C (Comment) The comment section allows entry of data related to a particular node or 
element.  For example, a pipe end specified as a hinge would have the 
rotational spring constant and the direction vector entered in the comment 
section. A line temperature can be entered as comment and is retained 
until changed. Multiple comments may be entered separated by commas.  
If the last comment is followed by a comma, the comment is continued on 
the next line. 

The comments are as follows: 

AMB Ambient or reference temperature (F or C) 
 Default is 70 F. 
 Example: AMB=80 

AXIAL Set support axis along the local-x direction (pipe axis). Use only for Limit 
Stop, Skewed Restraint and Snubber to define support axis along the local-
x direction (pipe axis). Available in CAEPIPE Version 10.50 or later. 

AWGT Additional weight for valve (lbf. or kgf) 
 Use only for valve. 
 Example: AWGT=100 

BTHK Bend thickness (inch or mm) 
 Use for Bend and Jbend (core). 
 Example:  BTHK=6.01 

BMAT Name of Bend Material (Up to 5 characters) 
 Should be defined in Material section before use. 
 Example: BMAT=BM1 

BK Bending stiffness (in-lb/deg or Nm/deg) 
 Use only for Bellows 
 Example:  BK=10000 

BSIF Bend SIF 
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 In-plane 
 Out-plane 
 Example:  BSIF(1.5,2.0) 
 For Piping code with one SIF, use in-plane=Out-plane=SIF 
 Example:  BSIF (2.0,2.0) 

BETA Beta angle for Beam (deg or rad) 
 Use only for Beam 
 Example:  BETA=90  

CONE Cone angle for reducer (deg. or rad.) 

CNOD Connected to Node  
 Use for Guide, Hanger, Limit Stop, Rod Hanger, Skewed Restraint, User  
 Hanger, Snubber and Constant Support  
 Example: CNOD=150 

CLD  Cold load  
 Use only for User Hanger.  
 Example: CLD=1 

CRTCH Crotch radius for an extruded tee (inch or mm) 
 Example: CRTCH=1.25 

CS Constant support spring 
 Example: CS=2: Two constant support springs 

CWGT Concentrated weight (lbf or kgf) 
 Use only for concentrated weight. 
 Example: CWGT=200 

D or DIS Specified displacements (Inch or mm) 
 Use for Anchor. 
 Also valid for Nozzle (valid for CAEPIPE 10.10 or later).  
 Note: Entry of zero is ignored and not treated as a specified displacement. 
 Example: D(0.1,-0.25,0) or DIS(0.1,-0.25,0) 
 DX=0.1,DY=-0.25 or DISX=0.1,DISY=-0.25 

DV Direction vector.DV(xcomp, ycomp, zcomp)  
 Use for Hinge, Snubber and Nozzle  

 Example: DV(1,-2,0)  

DIS2  Specified Displacement for Temperature 2 (inch or mm)  
 Use only for Anchor 
 Also valid for Nozzle (valid for CAEPIPE 10.10 or later).  
 Note: Entry of zero is ignored and not treated as a specified displacement.  
 Example: DIS2(1,-2,0)  

DIS3  Specified Displacement for Temperature 3 (inch or mm)  
 Use only for Anchor. 
 Also valid for Nozzle (from CAEPIPE 10.10 or later).  
 Note: Entry of zero is ignored and not treated as a specified displacement.  
 Example: DIS3(1,-2,0) 
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DISn Specified Displacement for Temperature 4 through 10 (inch or mm). n can 
be 4 through 10. Valid for CAEPIPE 10.10 or later. 

 Use only for Anchor and Nozzle 
 Note: Entry of zero is ignored and not treated as a specified displacement.  
 Example: DIS4(1,-2,0), DIS7(1,-1,0) 

E  Young’s modulus (psi or Mpa)  
 Use only for Nozzle  
 Example: E=28E6 

ES Expansion joint stiffnesses 

 Axial(lb/in or N/mm) 
 Lateral(lb/in or N/mm) 
 Torsional(in-lb/deg or NM/deg) 
 Example: ES(1000,5000,200) 

F or FIXD Translational restraint 
 Example: FIXD(1,0,1) : Restrain X and Z translations 
 FIXDX=1 or FX or FIXDX 

FF  Bend Flexibility factor  
 Use for Bends and Miter bends 
 Example: FF=1.5 

FIXR Rotational restraint 
 Example: FIXR(0,1,0) : Restrain Y rotation. 
 FIXRY=1 or FIXRY 

FLANGE FLANGE = Type, where 

 Type Description 

 WN Weld neck flange 

 SO Single welded slip on 
 DW Double welded slip on 
 SW Socket welded 
 FW Fillet welded 

 LJ Lap joint 
 TH Threaded 
 Example: FLANGE=TH (Threaded flange) 

FOR Force (lb or N) 
 Use for Force and Harmonic load. 
 Example: FOR(100,0,-200) or FORX=100,FORZ=-200 

FLC Apply Force defined to the specified load case. Available for CAEPIPE 
Version 10.30 or later 

 Use 1 to add it to Sustained Load Case 
 Use 2 to 11 to add it to T1 through T10 load cases. 
 Use 12 to add it to Static Seismic Load case 

 Example: FLC=12 

FFOR  Friction force (lb or N)  
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 Use for Slip joint  
 Example: FFOR=100  

FTOR Friction torque (ft-lb or Nm)  
 Use for Slip joint  
 Example: FTOR=100  

FRCT Bending and Torsional friction Torque (ft-lb or Nm). 
 FCRT(Bending, Torsional)  
 Use only for Ball joint  
 Example: FCRT(100,150) 

FREE Free anchor during hanger design 
 Example: FREE: Free all directions 
 FREEY: Free Y direction 

FRE  Frequency (Hz)  
 Use only for Harmonic Load.  
 Example: FRE=30 

G Guide 

GRA1 Generic Support - Group A Stiffness for (1,1) (1,2) and (1,3) in (lb/in or 
N/mm). Available for CAEPIPE Version 10.30 or later. 

 GRA1(Rigid, 0, 0) 

GRA2 Generic Support - Group A Stiffness for (2, 2) (2, 3) and (3,3) in (lb/in or 
N/mm). Available for CAEPIPE Version 10.30 or later. 

 GRA2(1E+10, 0, Rigid) 

GRB1 Generic Support - Group B Stiffness for (1,4) (1,5) and (1,6) in (lb/deg or 
N/deg). Available for CAEPIPE Version 10.30 or later. 

 GRB1(1000, 0, 0) 

GRB2 Generic Support - Group B Stiffness for (2,4) (2,5) and (2,6) in (lb/deg or 
N/deg). Available for CAEPIPE Version 10.30 or later. 

 GRB2(1000, -2000, 0) 

GRB3 Generic Support - Group B Stiffness for (3,4) (3,5) and (3,6) in (lb/deg or 
N/deg). Available for CAEPIPE Version 10.30 or later. 

 GRB3(1000, 0, 0) 

GRC1 Generic Support - Group C Stiffness for (4,4) (4,5) and (4,6) in (in-lb/deg 
or Nm/deg). Available for CAEPIPE Version 10.30 or later. 

 GRC1(Rigid, 0, 1000) 

GRC2 Generic Support - Group C Stiffness for (5,5) (5,6) and (6,6) in (in-lb/deg 
or Nm/deg). Available for CAEPIPE Version 10.30 or later. 

 GRC2(Rigid, 0, 1E+8) 
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GAP  Tension and Compression gap (inch or mm)  
 GAP(Tension, Compression)  
 Use only for Tie rod.  
 Example: GAP(10,15)  

GGAP  Guide Gap (inch or mm)  
 Use only for guide  
 Example: GGAP=5  

HSG  Hydrotest Specific Gravity  
 Use only for Hydrotest Load  
 Example: HSG=0.7  

HPRES Hydrostatic Pressure (psi or bar)  
 Use only for Hydrotest Load  
 Example: HPRES=3  

HTYP  Defines the Hanger Type. Refer to end of this appendix for details.  
 Use only for Hanger  
 Example: HTYP=16 (Grinnell)  

IN1  Intermediate Node 1 for Bends. Node Number (>1 and < 99999)  
 Angle (deg or rad)  
 Use for Bend and Jbend 
 Example: IN1(300,30) 

IN2  Intermediate Node 2 for Bends. Node Number (>1 and < 99999)  
 Angle (deg or rad)  
 Use for Bend and Jbend 
 Example: IN2(400,30)  

INSF  Insulation factor  
 Use only for Valve  
 Example: INSF=3.0  

IPS User Sustained SCF - Pressure 
 Use only for IGEM Code 
 Example: IPS=1.3 

IBS User Sustained SCF - Bending 
 Use only for IGEM Code 
 Example: IBS=1.5 

ITS User Sustained SCF - Thrust 
 Use only for IGEM Code 
 Example: ITS=1.2 

IQS User Sustained SCF - Torsion 
 Use only for IGEM Code 
 Example: IQS=1.5 

ISS User Sustained SCF - Shear 
 Use only for IGEM Code 
 Example: ISS=2.0 
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IPC User Cyclic SCF - Pressure 
 Use only for IGEM Code 
 Example: IPC=1.3 

IBC User Cyclic SCF - Bending 
 Use only for IGEM Code 
 Example: IBC=1.5 

ITC User Cyclic SCF - Thrust 
 Use only for IGEM Code 
 Example: ITC=1.2 

IQC User Cyclic SCF - Torsion 
 Use only for IGEM Code 
 Example: IQC=1.5 

ISC User Cyclic SCF - Shear 
 Use only for IGEM Code 
 Example: ISC=2.0 

JCAP  Jacked End Cap  
 Defines the data type Jacked End Cap  
 Example: JCAP  

JMAT  Jacket Material (up to 3 characters)  
 Use for Jpipe and Jbend 
 Example: JMAT=A53  

JSEC  Jacket Section (up to 3 characters)  
 Use for Jpipe and Jbend 
 Example: JSEC=N10  

JLOAD  Jacket Load (up to 3 characters)  
 Use for Jpipe and Jbend 
 Example: JLOAD=L3  

JTHK  Jacket Thickness (inch or mm)  
 Use only for Jbend 

JR  Jacket Radius (inch or mm)  
 Use only for Jbend.  
 Example: JR=6.75 

K Translational stiffness (lb/inch or N/mm) 
 Use for Skewed restraint 
 Example: K=500,DV(1.5,-0.75,0.25) 

KR Rotational stiffness (in-lb/deg. or N-m/deg) 
 Use for Skewed restraint 
 Example: KR=1200,DV(1.2,2.5,0) 

KTIE  Tension and Compression stiffness.KTIE(Tension, Compression) (lb/in 
or N/mm). Use only for Tie rod  

 Example: KTIE(1000,1500) 
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LA Anchor in Local Coordinate System (LCS) or Global Coordinate System 
(GCS). Valid for CAEPIPE Version 10.10 or later. 

 Use only for Anchor. 
 Example: LA=1 (Anchor in LCS), LA=0 (Anchor in GCS) 
 
LD Anchor Displacement in Local Coordinate System (LCS) or Global 

Coordinate System (GCS). Valid for CAEPIPE Version 10.10 or later. 
 Use only for Anchor. 
 Example:  
 LD=1 (Anchor Displacement in LCS),  
 LD=0 (Anchor Displacement in GCS) 
 
LS Limit stop 
 LS(M1,M2) 
 M1=allowable movement in negative direction (in. or mm) 
 M2=allowable movement in positive direction (inch or mm) 
 Example : LS(-1.0,1.5), DV(0,1,0), MU=0.3 

LOAD  Beam load reference (up to 5 characters)  
 Note: Beam load should be defined in BLOADS section before use.  
 Example: LOAD=B1 

LEN  Length (inch or mm)  
 Use only for Branch SIF with type Branch on Thickened Pipe  
 Example: LEN=5  

L1  Length 1 (ft-in or mm)  
 Use to define “L” for API 650 Nozzle and “L1” for WRC 297 Nozzle  
 Example: L1=3’0” or L1=900  

L2  Length 2 (ft-in or mm)  
 Use only for WRC 297 Nozzle to define “L2” 
 Example: L2=4’0” or L2=1200  

LONG  Cut long (inch or mm)  
 Use only for Cut pipe.  
 Example: LONG=100 

LTAG Level Tag for Supports. Use only when Spectrum and Spectrum Level 
defined. LTAG is available in CAEPIPE Version 10.50 or later. 

LXAX  Local X axis.LXAX(xcomp, ycomp, zcomp)  
 Use only for Elastic Element  
 Example: LXAX(1,0,0)  

LYAX  Local Y axis.LYAX(xcomp,ycomp,zcomp)  
 Use only for Elastic Element  
 Example: LYAX(0,1,0)  

MAT  Beam material reference (up to 5 characters)  
 Note: Beam material should be defined in Beam material (BMATERIALS)  
 section before use.  
 Example: MAT=M1  
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MM  Mismatch (inch or mm)  
 Use only for weld  
 Example: MM=5 

MLV Maximum load variation (%) in hanger design 
 Default is 25%. 
 Example: MLV=30 

MOM Moment (ft-lb or NM) 
 Example: MOM(200,-100,0) or MOMX=200, MOMY=-100 

MU Friction co-efficient 
 Example: MU=0.3 

NOD  Nozzle outside diameter (inch or mm)  
 Example: NOD=104  

NTHK  Nozzle thickness (inch or mm)  
 Example: NTHK=6.01  

NOZZLE  Defines the Nozzle data type. (650, 297or 5500).  
 Example: NOZZLE=650 (API 650) or NOZZLE=297 (WRC 297) 
 Example: NOZZLE=5500 (valid for CAEPIPE 10.10 or later) 

OD1 Outer diameter at from end for the reducer (inch or mm) 

OD2 Outer diameter at to end for reducer (inch or mm) 

 
OFFSET Offset of concentrated weight from node or additional weight of valve 

from the center of valve (inch or mm) 
 OFFSET(X offset, Y offset, Z offset). 
 Example: OFFSET(0,18,0) 

PAD Thickness of reinforcement for fabricated tee (inch or mm) 
 Example: PAD=0.25 

PH  Phase (deg or rad)  
 Use only for Harmonic Load  
 Example: PH=10 

P or PRES Pressure (psig or bar) 
 Example: P=500 

ROT Specified rotation (deg or rad) 
 Note: Entry of zero is ignored and not treated as a specified rotation. 
 Example: ROT(1.5,0,-0.25) 
 ROTX=1.5,ROTZ=-0.25 

RLIM  Rotation limit (deg or rad)  
 Use only for Hinge  
 Example: RLIM=10  

ROTL  Rotational limit in Bending and Torsion  
 ROTL(Bending, Torsion) (deg or rad)  
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 Use only for Ball joint  
 Example: ROTL(10,20)  

ROTK  Rotational stiffness. ROTK(kxx,kyy,kzz) (in-lb/deg. or N-m/deg) 
 Use for Anchor and Elastic element  
 Example: ROTK(5,6,3)  

ROT2  Rotational Displacement for Temperature 2. (deg or rad)  
 ROT2(kxx,kyy,kzz)  
 Use only for Anchor  
 Example: ROT2(10,15,10)  

ROT3  Rotational Displacement for Temperature 3. (deg or rad)  
 ROT3(kxx,kyy,kzz)  
 Use only for Anchor  
 Example: ROT3(10,15,10)  

ROTn Rotational Displacement for Temperature 4 through 10. (deg or rad). “n” 
can be 4 through 10. Valid for CAEPIPE 10.10 or later. 

 ROT3(kxx,kyy,kzz)  
 Use only for Anchor  
 Example: ROT5(10,15,10), ROT10(11,5,3)  

R  Fillet radius (inch or mm)  
 Use only for Branch SIF (Radiused Branch and Branch Connection)  
 Example: R=10  

RPAD  Reinforcing Pad (0 or 1)  
 Use only for Nozzle (API 650)  
 Example RPAD=1  

RK  Rotational Stiffness in Bending and Torsion. 
 RK(Bending, Torsion) (ft-lb or Nm)  
 Use only for Ball joint  
 Example: RK(100,150) 

SG Specific Gravity 

 Example: SG=0.8 

SIF Stress intensification factor at node. SIF=value or SIF(in-plane, Out-plane)  
 Example: SIF=1.3 or SIF(1.5,2.0) 

SIFA Axial Stress intensification factor. Valid for CAEPIPE 10.10 or later. Use 
this field to define Axial SIF for applicable codes (ex. B31J, B31.3, etc.). 
Will be ignored, if not applicable for the analysis code defined.  

SIFT Torsional Stress intensification factor. Valid for CAEPIPE 10.10 or later. 
Use this field to define Torsion SIF for applicable codes (ex. B31J, B31.3, 
etc.). Will be ignored, if not applicable for the analysis code defined.  

SHORT  Cut short (inch or mm). Use only for Cut pipe.  
 Example: SHORT=100 
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SHEARY Set support axis in the local-y directionof pipe. Use only for Limit Stop, 
Skewed Restraint and Snubber to define support axis in the local-y 
direction of pipe. Available in CAEPIPE Version 10.50 or later. 

SHEARZ Set support axis in the local-z directionof pipe. Use only for Limit Stop, 
Skewed Restraint and Snubber to define support axis in the local-z 
direction of pipe. Available in CAEPIPE Version 10.50 or later. 

 SEC  Beam section reference (up to 5 characters)  

 Note: Beam section should be defined in Beam section (BSECTIONS) 
before  use.  

 Example: SEC=BS1 

SEIS Seismic displacement (inch or mm)(x,y,z) 
 Example: SEIS (-0.25, 0.00, -0.25) 

SERO Seismic rotation (deg or rad) (rx,ry,rz) 
 Example: SERO (0.25, 0.00, 0.25) 

SETT Settlement displacement (inch or mm)(x,y,z) 
 Example: SETT (-0.25, -0.25, -0.25) 

SPIDER  Defines the data type SPIDER 
 Example: SPIDER 

SR  Turn on the option Short range.  
 Use only for Hanger.  
 Example: SR  

STIFF  Stiffness (lb/in or N/mm)  
 Use for Guide, Limit stop and Snubbers  
 Example: STIFF=1000 

STRO Settlement rotation (deg or rad) (rx,ry,rz) 
 Example: STRO (0.15, 0.15, 0.15) 

T or TEMP Temperature (F or C) 
 Example: T=650 

TA Pressure thrust area for bellows and Slip joints (in2 or mm2). 
 Example: TA=12.3 

TAG Support Tag (up to 14 characters). Valid for CAEPIPE 10.10 or later. 

 Use for Anchor, Guide, Hanger, Limit Stop, Nozzle, Restraint, Rod 
hanger, Skewed restraint and User Hanger. 

 Example: TAG=GUID1S01 

THK  Thickness (inch or mm)  
 Use only for Branch SIF (Radiused Branch & Branch on Thickened Pipe)  
 Example: THK=10 

THK1 Thickness at from end for reducer (inch or mm) 
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THK2 Thickness at to end for reducer (inch or mm) 

THKF  Thickness factor  
 Use only for Valve.  
 Example: THKF=3.0  

TRAK  Translational Stiffness (lb/in or N/mm).TRAK(kx,ky,kz)  
 Use for Anchor and Elastic element.  
 Example: TRAK(1000,1500,2000)  

TJOINT  Defines the Threaded Joint  
 Example: TJOINT 

U or UNIF Uniform load (lbf/ft or Kgf/m) 
 Example: U=200 

US User-defined spring hanger 
 US(No.of hangers, spring rate(lb/inch or N/mm), hot load(lb or N)) 
 Examples: US(2,600,1540) 
 US(1,0,2300) : Constant support 

VS Variable spring hanger 
 Example : VS, VS=2: two variable spring hangers 

VOD  Vessel outside diameter (inch or mm). For Nozzle attached to Spherical 
Vessel, this field can be used to define Vessel Radius. 

 Use only for Nozzle.  
 Example: VOD=250  

VTHK  Vessel thickness (inch or mm)  
 Use only for Nozzle  
 Example: VTHK=10  

VWGT  Valve weight (lbf or kgf)  
 Example: VWGT=100 

WGT Weight of an item (ball joint, flange, Slip joint, etc.) (lbf or kgf)  
 Example: WGT=50  

WS  Widely Spaced  
 Use only for Miter bend 
 Example: WS  

WTYPE  Weld type  
 Example: WTYPE=1  
 (1 = Butt weld, 2 = Fillet weld, 3 = Concave fillet weld, 4 = Tapered  
 Transition) 

PUMPS  

Description (up to 16 characters)  
Suction/Discharge location (0 = Top, 1 = Side, 2 = End)  
Shaft axis (xcomp, ycomp, zcomp)  
Center of pump (x, y, z) 
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English units  

Desc, Horizontal / Vertical inline (0 or 1), Shaft axis, Center of pump (ft-in), Suction node, 
Suction location, Discharge Node, Discharge Location  

SI units 

Desc, Horizontal / Vertical inline (0 or 1), Shaft axis, Center of pump (mm), Suction node, 
Suction location, Discharge Node, Discharge Location  

Horizontal Pumps  

Desc, 0, Shaft axis, Center of pump, Suction node, Suction location, Discharge Node, 
Discharge Location  

Vertical Inline Pumps  

Desc, 1, Suction node, Discharge Node  

Example 

PUMPS  

427BSOUTH,1,350 

427ANORTH,0,0.0000,1.0000,0.0000,-3.8299,-13'8”,44.33,390,2,410,2  

427WEST,1,300 

COMPRESSORS  

Description (up to 16 characters)  
Shaft axis (xcomp, ycomp, zcomp)  

Description, Shaft axis direction, Inlet Node, Exhaust Node, Extraction Node 1, Extraction 
Node 2.  

Example  

COMPRESSORS  

Compressor1,1.0000,0.0000,0.0000,210,300 

TURBINES  

Description (up to 16 characters)  
Shaft axis (xcomp, ycomp, zcomp)  

Description, Shaft axis direction, Inlet Node, Exhaust Node, Extraction Node 1, Extraction 
Node 2.  

Example  

TURBINES  

TURBINE1,1.0000,0.0000,0.0000,250,360 

SEISMIC 

X,Y,Z Static equivalent seismic loads in g’s, [Seismic Combination 1 = Absolute Sum, 2 = 
SRSS].  

The value in square brackets ([...]) is optional. 
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SEISMIC Example: Static seismic loads of 0.25 and 0.3 g’s in X and Z directions. 

SEISMIC 

0.25,0.00,0.30 

[ASCES] 

Static Seismic Loads (g’s) as per ASCE/SEI 7-16 that can be defined through Options > 
Analysis > Static Seismic > Use ASCE. 

This Section is Optionaland is valid for CAEPIPE Version 10.10 and later. If defined, then 
the syntax should be as given below.  

Occupancy Category [0 = I, 1 = II, 2 = III and 3 = IV], Site Class [0 = A, 1 = B, 2 = C, 3 = 
D, and 4 = E], MCE Spectral Acceleration, Component height(ft-in or mm), Structure 
height(ft-in or mm), Component Amplication Factor (Ap) [1.0 to 2.50], Response 
Modification Factor (Rp) [1.0 to 12.0], Importance Factor (Ip) [1.0 to 1.5], Allowable Stress 
Design Factor, Seismic Combination. 

Example 

ASCES 

2, 3, 10.00, 50'0", 40'0", 2.50, 12.00, 1.00, 0.70, 2 

Note:  
If both SEISMIC and ASCES definition are defined, then CAEPIPE will ignore SEISMIC 
definition. 

WIND 

This section is compatible with all earlier version of CAEPIPE up to and including 10.0.  

See ASCEW/1991W, WIND1, WIND2, WIND3 and WIND4 for CAEPIPE Version 10.10 
or later. 

Wind velocity (mph or m/s), Shape factor (defaults to 0.6), X, Y, Z components of wind 
direction. 

WIND Example: A wind load of 100 mph in the X direction. 

WIND 

100,0.600,1.000,0.000,0.000 

[ASCEW] 

Wind Profile as per ASCE/SEI 7-16 that can be defined through Layout Window > Misc > 
Wind – ASCE/SEI 7-16. 

This Section is Optionaland is valid for CAEPIPE Version 10.10 and later. If defined, then 
the syntax should be as given below.  

Occupancy Category [0 = I, 1 = II, 2 = III and 3 = IV], Basic Wind Speed (mph or m/s), 
Wind Directionality Factor, Exposure Category (0 = B, 1 = C and 2 = D], Hill Type (0 = No 
Hill, 1 = 2D Ridge, 2 = 2D Escarpment and 3 = 3D Axisymmetric Hill], Hill height (ft-in or 
mm), Crest Distance (ft-in or mm), Height above Ground Level (ft-in or mm), Distance 
from Crest to Site (ft-in or mm), Type of Surface (0 = Moderately Smooth, 1 = Rough, 2 = 
Very Rough), Gust Factor. 



MBF Import / Export 
 

218 

Example 

ASCEW 

2, 100, 0.9500, 0, 0, 0, 0, 0, 0, 0, 0.8500 

[1991W] 

Wind Profile as per EN 1991-1-4 (2010) that can be defined through Layout Window > Misc 
> Wind – EN 1991-1-4 (2010). 

This Section is Optional and is valid for CAEPIPE Version 10.30 and later. If defined, then 
the syntax should be as given below.  

Basic Wind Speed (mph or m/s), Air Density(lbf/ft3 or kgf/m3), Terrain Category (0 = 0, I 
= I, 2 = II, 3 = III and 4 = IV), [Direction Factor, Season Factor, Terrain Orography, 
Turbulence Factor]  

Example 

1991W 

50,0.001,2,1.0000,1.0000,1.0000,1.0000  

[WIND1/WIND2/WIND3/WIND4] 

Wind Profile that can be defined through Layout Window >Loads > Wind1 / Wind 2/ 
Wind 3 / Wind 4. 

These Sections are Optional and are valid for CAEPIPE Version 10.10 and later. If defined, 
then the syntax should be as given below. 

First line:Use WindCode (0 = None, 1 = ASCE and 2 = EN 1991-1-4. Can be defined as 1 
or 2, when ASCEW/1991W is defined), Shape factor, X, Y, Z components of wind 
direction, Elevation Units (0 = feet and 1 = m), Pressure Units (0 = psi, 1 = kPa and 2 = 
kg/cm2), Velocity Units (0 = mph, 1 = kmh and 2 = m/s), Profile Type (0 = Pressure vs 
Elevation and 1 = Velocity vs Elevation) 

Second line: Number of Wind Profiles 

Following lines:Elevation, Velocity / Pressure 
. 

Example 1 [Manual Wind Profile] 

WIND1 

0,0.6000,1.0000,0.0000,0.0000,0,0,0,1 

2 

0,100 

100,150 

Example 2 [ASCE Wind Profile] 

WIND2 

1,0.6000,-1.0000,0.0000,0.0000 

Example 3 [EN1991-1-4 Wind Profile] 
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WIND3 

2, 0.6000, -1.0000, 0.0000, 0.0000 

ALLOWABLES 

Node, FX/P (lb or N), FY/VL (lb or N), FZ/VC (lb or N), MX/MT (ft-lb or Nm), 
MY/MC (ft-lb or Nm), MZ/ML (ft-lb or Nm). 

Note:  

For Nozzle, enter Radial (P), y shear (VL), z shear (VC), Torque (MT), Circumferential Moment (MC) 
and Longitudinal Moment (ML) 

For Anchor, enter Global forces FX, FY &FZ and Global Moments MX, MY and MZ 

Example:  

ALLOWABLES 

10,84817.63,848176.31,848176.31,454771.2,45477.12,45477.12 

Example MBF Format: 

Sample MBF 

VERSION 

10.50 

OPTIONS 

HGRA,B319 

OPCODE 

0,1,0,0,0,0,1,0,1.20 

OPTEMP 

40,7000,1,0,0 

OPPRES 

0,1,1,1.00 

OPMISC 

50,50,1,1,1,4,2,2 

MATERIAL 

A53,0.283,0.300,1.00 

A53,-325,31.4E+6,5.00E-6,20000 

A53,-200,30.8E+6,5.35E-6,20000 

A53,-100,30.2E+6,5.65E-6,20000 

A53,70,29.5E+6,6.07E-6,20000 

A53,200,28.8E+6,6.38E-6,20000 

A53,300,28.3E+6,6.60E-6,20000 

A53,400,27.7E+6,6.82E-6,19900 

A53,500,27.3E+6,7.02E-6,19000 

A53,600,26.7E+6,7.23E-6,17900 

A53,650,26.1E+6,7.33E-6,17300 

A53,700,25.5E+6,7.44E-6,16700 

A53,750,24.8E+6,7.54E-6,13900 

A53,800,24.2E+6,7.65E-6,11400 

A53,850,23.3E+6,7.75E-6,8700 

A53,900,22.4E+6,7.84E-6,5900 

A53,950,21.4E+6,7.91E-6,4000 

A53,1000,20.4E+6,7.97E-6,2500 

A53,1050,19.2E+6,8.05E-6,1600 

A53,1100,18.0E+6,8.12E-6,1000 

API,0.283,0.300,1.00 

API,-325,31.4E+6,5.00E-6,20000 
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API,-200,30.8E+6,5.35E-6,20000 

API,-100,30.2E+6,5.65E-6,20000 

API,70,29.5E+6,6.07E-6,20000 

API,200,28.8E+6,6.38E-6,20000 

API,300,28.3E+6,6.60E-6,20000 

API,400,27.7E+6,6.82E-6,19900 

API,500,27.3E+6,7.02E-6,19000 

API,600,26.7E+6,7.23E-6,17900 

API,650,26.1E+6,7.33E-6,17300 

API,700,25.5E+6,7.44E-6,16700 

API,750,24.8E+6,7.54E-6,13900 

API,800,24.2E+6,7.65E-6,11400 

API,850,23.3E+6,7.75E-6,8700 

API,900,22.4E+6,7.84E-6,5900 

API,950,21.4E+6,7.91E-6,4000 

API,1000,20.4E+6,7.97E-6,2500 

API,1050,19.2E+6,8.05E-6,1600 

API,1100,18.0E+6,8.12E-6,1000 

PIPE 

36I,36,0.375,0.075,0.0,13,2 

36O,36,0.375,0.075,0.0,13,2.5 

54O,54,0.375,0.075,0.0,13,2.5 

54I,54,0.375,0.075,0.0,13,2 

LOADS 

36O,100,125,1.0,40,0,40,0,77.2,100,125,,,,,,,,,,,,,,,1,0,0,0 

36I,100,125,1.0,40,0,40,0,0,100,125,,,,,,,,,,,,,,,0,0,0,0 

30O,100,125,1.0,40,0,40,0,65.9,100,125,,,,,,,,,,,,,,,1,0,0,0 

30I,100,125,1.0,40,0,40,0,0,100,125,,,,,,,,,,,,,,,0,0,0,0 

24O,100,125,1.0,40,0,40,0,54.6,100,125,,,,,,,,,,,,,,,0,0,0,0 

24I,100,125,1.0,40,0,40,0,0,100,125,,,,,,,,,,,,,,,0,0,0,0 

20O,100,125,1.0,40,0,40,0,48.9,100,125,,,,,,,,,,,,,,,1,0,0,0 

20I,100,125,1.0,40,0,40,0,0,100,125,,,,,,,,,,,,,,,0,0,0,0 

18O,100,125,1.0,40,0,40,0,45.2,100,125,,,,,,,,,,,,,,,1,0,0,0 

18I,100,125,1.0,40,0,40,0,0,100,125,,,,,,,,,,,,,,,0,0,0,0 

16O,100,125,1.0,40,0,40,0,41.4,100,125,,,,,,,,,,,,,,,1,0,0,0 

16I,100,125,1.0,40,0,40,0,0,100,125,,,,,,,,,,,,,,,0,0,0,0 

14O,100,125,1.0,40,0,40,0,37.6,100,125,,,,,,,,,,,,,,,1,0,0,0 

14I,100,125,1.0,40,0,40,0,0,100,125,,,,,,,,,,,,,,,0,0,0,0 

12O,100,125,1.0,40,0,40,0,35.3,100,125,,,,,,,,,,,,,,,1,0,0,0 

12I,100,125,1.0,40,0,40,0,0,100,125,,,,,,,,,,,,,,,0,0,0,0 

10O,100,125,1.0,40,0,40,0,31.5,100,125,,,,,,,,,,,,,,,1,0,0,0 

10I,100,125,1.0,40,0,40,0,0,100,125,,,,,,,,,,,,,,,0,0,0,0 

8O,100,125,1.0,40,0,40,0,27.5,100,125,,,,,,,,,,,,,,,1,0,0,0 

8I,100,125,1.0,40,0,40,0,0,100,125,,,,,,,,,,,,,,,0,0,0,0 

6O,100,125,1.0,40,0,40,0,23.8,100,125,,,,,,,,,,,,,,,1,0,0,0 

6I,100,125,1.0,40,0,40,0,0,100,125,,,,,,,,,,,,,,,0,0,0,0 

42O,100,125,1.0,40,0,40,0,88.5,100,125,,,,,,,,,,,,,,,1,0,0,0 

42I,100,125,1.0,40,0,40,0,0,100,125,,,,,,,,,,,,,,,0,0,0,0 

48O,100,125,1.0,40,0,40,0,99.8,100,125,,,,,,,,,,,,,,,1,0,0,0 

48I,100,125,1.0,40,0,40,0,0,100,125,,,,,,,,,,,,,,,0,0,0,0 

54O,100,125,1.0,40,0,40,0,111.1,100,125,,,,,,,,,,,,,,,1,0,0,0 

54I,100,125,1.0,40,0,40,0,0,100,125,,,,,,,,,,,,,,,0,0,0,0 

60O,100,125,1.0,40,0,40,0,122.4,100,125,,,,,,,,,,,,,,,1,0,0,0 

60I,100,125,1.0,40,0,40,0,0,100,125,,,,,,,,,,,,,,,0,0,0,0 

72O,100,125,1.0,40,0,40,0,144.9,100,125,,,,,,,,,,,,,,,1,0,0,0 

72I,100,125,1.0,40,0,40,0,0,100,125,,,,,,,,,,,,,,,0,0,0,0 

SPCMS 

Malta--N-Y-3,14,0,0,1,4 
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Malta--N-Y-3,0,0.0856 

Malta--N-Y-3,0.037,0.1284 

Malta--N-Y-3,0.074,0.1712 

Malta--N-Y-3,0.11,0.214 

Malta--N-Y-3,0.331,0.214 

Malta--N-Y-3,0.551,0.214 

Malta--N-Y-3,1.914,0.061665 

Malta--N-Y-3,3.276,0.036023 

Malta--N-Y-3,4.638,0.025443 

Malta--N-Y-3,6,0.019667 

Malta--N-Y-3,8,0.011063 

Malta--N-Y-3,10,0.00708 

Malta--N-Y-3,20,0.00177 

Malta--N-Y-3,30,0.000787 

Malta--N-Y_b-1,23,0,0,1,4 

Malta--N-Y_b-1,0,0.0856 

Malta--N-Y_b-1,0.00011,0.0857 

Malta--N-Y_b-1,0.0011,0.0869 

Malta--N-Y_b-1,0.0368,0.1284 

Malta--N-Y_b-1,0.074,0.1712 

Malta--N-Y_b-1,0.11,0.214 

Malta--N-Y_b-1,0.331,0.214 

Malta--N-Y_b-1,0.551,0.214 

Malta--N-Y_b-1,1.23,0.0957 

Malta--N-Y_b-1,1.91,0.0617 

Malta--N-Y_b-1,2.59,0.0455 

Malta--N-Y_b-1,3.28,0.036 

Malta--N-Y_b-1,3.96,0.0298 

Malta--N-Y_b-1,4.64,0.0254 

Malta--N-Y_b-1,5.32,0.0222 

Malta--N-Y_b-1,6,0.0197 

Malta--N-Y_b-1,8,0.0111 

Malta--N-Y_b-1,10,0.0071 

Malta--N-Y_b-1,20,0.0018 

Malta--N-Y_b-1,30,0.0008 

Malta--N-Y_b-1,50,0.0002832 

Malta--N-Y_b-1,100,7.08E-5 

Malta--N-Y_b-1,1000,7.08E-7 

SPLVL 

LVL-0,Malta--N-Y-3,Malta--N-Y-3,Malta--N-Y_b-1,1.000,0.043,1.000 

LVL-1,Malta--N-Y-3,Malta--N-Y-3,Malta--N-Y_b-1,1.000,0.043,1.000 

LAYOUT 

F10,KA,CTAG=,LTAG=LVL-0 

T20,KI,B81,MAPI,P54I,Z11'0",CL=54I 

T30,Y-20'0",CVS=1,HTYP=27,MLV=25,TAG=,LTAG=LVL-0 

T40,KI,B81,Y-10'9" 

T50,Z9'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T60,P54O,Z2'0",CL=54O 

T65,Z10'0" 

T70,Z12'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T75,Z12'0" 

T80,Z12'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T85,Z12'0" 

T90,Z12'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 
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T100,Z11'0" 

T110,KA,Z3'0",CTAG=,LTAG=LVL-0 

T120,Z3'0" 

T130,JD,Z3'0",COD1=54,THK1=0.375,OD2=36,THK2=0.375 

T140,KI,B54,P36I,Z3'8",CL=36I 

T150,KI,B54,X2'11",Y-4'6",Z4'6" 

T160,Z6'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T165,Z7'0" 

T170,Z7'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T180,KI,B54,Z6'0" 

T190,X7'3",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T200,X12'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T210,X12'0" 

T220,X12'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T230,KI,B54,X4'5" 

T240,Z4'5",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T250,Z12'0" 

T260,Z12'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T270,Z12'0" 

T280,Z12'0",CG,TAG=,LTAG=LVL-0,STIFF=Rigid 

T290,Z12'0" 

T300,Z12'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T310,Z12'0" 

T320,Z12'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T330,Z16'0",CG,TAG=,LTAG=LVL-0,STIFF=Rigid 

T340,Z12'0" 

T350,Z12'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T360,Z12'0" 

T370,Z12'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T380,Z12'0" 

T390,Z12'0",CG,TAG=,LTAG=LVL-0,STIFF=Rigid 

T400,Z12'0" 

T410,Z12'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T420,Z12'0" 

T430,Z12'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T440,Z12'0" 

T450,Z12'0",CG,TAG=,LTAG=LVL-0,STIFF=Rigid 

T460,Z12'0" 

T470,Z12'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T480,Z12'0" 

T490,Z12'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T500,Z12'0" 

T510,KA,Z12'0",CTAG=,LTAG=LVL-0 
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T520,Z12'0" 

T530,Z12'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T540,Z12'0" 

T550,Z12'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T560,KI,B54,Z4'5" 

T570,X-4'5",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T580,X-12'0" 

T590,X-11'7",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T600,X-12'0" 

T610,X-12'0",CG,TAG=,LTAG=LVL-0,STIFF=Rigid 

T620,X-12'0" 

T630,KA,X-12'0",CTAG=,LTAG=LVL-0 

T640,X-12'0" 

T650,X-12'0",CG,TAG=,LTAG=LVL-0,STIFF=Rigid 

T660,X-12'0" 

T670,X-10'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T680,X-13'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T690,KI,B54,X-9'0" 

T700,Z7'11",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T710,KA,Z12'0",CTAG=,LTAG=LVL-0 

*Branch Pipe 

F100 

T720,KI,B54,P36O,Y10'9",CL=36O 

T730,Z7'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T740,KI,B54,Z9'0" 

T750,Y16'9",CVS=1,HTYP=27,MLV=25,TAG=,LTAG=LVL-0 

T760,Y26'11",CVS=1,HTYP=27,MLV=25,TAG=,LTAG=LVL-0 

T770,KI,B54,Y5'8" 

T780,Z6'0",CTAG=,LTAG=LVL-

0,LS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid 

T790,KA,Z12'0",CTAG=,LTAG=LVL-0 

WIND1 

0,0.6000,0.0000,0.0000,1.0000,0,0,0 

5 

0,15 

15,15 

30,15 

45,15 

60,15 
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Example MBF 6x Format: 

An example of a model batch file (.mbf file) is shown below: 

Desalter Pumps 

 

OPTIONS  

HGRA,B313 

MATERIAL  

A53,0.283,0.300,1.00 

A53,-325,31.4E+6,5.00E-6,20000  

A53,-200,30.8E+6,5.35E-6,20000  

A53,-100,30.2E+6,5.65E-6,20000  

A53,70,29.5E+6,6.07E-6,20000  

A53,200,28.8E+6,6.38E-6,20000  

A53,300,28.3E+6,6.60E-6,20000  

A53,400,27.7E+6,6.82E-6,20000  

A53,500,27.3E+6,7.02E-6,18900  

A53,600,26.7E+6,7.23E-6,17300  

A53,650,26.1E+6,7.33E-6,17000  

A53,700,25.5E+6,7.44E-6,16500  

A53,750,24.9E+6,7.54E-6,13000  

A53,800,24.2E+6,7.65E-6,10800  

A53,850,23.3E+6,7.75E-6,8700  

A53,900,22.4E+6,7.84E-6,6500  

A53,950,21.4E+6,7.91E-6,4500  

A53,1000,20.4E+6,7.97E-6,2500  

A53,1050,19.2E+6,8.05E-6,1600  

A53,1100,18.0E+6,8.12E-6,1000  

PIPE  

4,4.5,0.237,0,12.5,11,2 

6,6.625,0.28,0,12.5,11,2 

8,8.625,0.322,0,12.5,11,2 

10,10.75,0.365,0,12.5,11,2 

12,12.75,0.406,0,12.5,11,2 

LOADS  

1,400,280,0.85,400,280,350,190 

1N,400,280,0.85,100,280,350,190 

1S,100,280,0.85,400,280,350,190 

1C,100,280,0.85,100,280,100,190 

4,400,600,0.85,400,600,285,450 

4N,400,600,0.85,100,600,285,450 

4S,100,600,0.85,400,600,285,450 

SO1,350,190,0.85,70,0,70,0 

SOA,230,145,0.85,70,0,70,0 

SD1,400,280,0.85,70,0,70,0 

DO1,285,450,0.85,70,0,70,0 

DOA,225,485,0.85,70,0,70,0 

DD1,400,600,0.85,70,0,70,0 

LAYOUT  

F10,CNOZZLE=297,L2=10'0”,NOD=17.5,NTHK=1.3125,VOD=144,VTHK=1.375, 

L1=10'0”,E=29.0E+6,DV(0.0000,0.0000,1.0000)  

L10,CFLANGE=WN,WGT=220  

 

T20,JV,MA53,P10,Y1'6-1/4”,CL=1,VWGT=625,THKF=3.0000,INSF=1.7500,  

FLANGE=WN,WGT=220  

T30,Y0'4-5/8”  

T40,JD,P8,Y0'7”,COD1=10.75,THK1=0.365,OD2=8.625,THK2=0.322  

T50,KI,B12,Y6'0-1/8”  
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T60,KI,B12,X-1.0017,Z1.0017  

T70,KI,B12,X-5'8-15/16  

T80,KI,B12,Y-11'3”  

T90,Z6'6”,CLS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid  

T100,Z20'0”,CLS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid  

T110,JI,B6.75,P4,Z17'6”,CJMAT=A53,JSEC=12,JLOAD=1,JR=19.125  

T120,P8,X10'11”,CLS(0.000,None),DV(0.0000,1.0000,0.0000),  

STIFF=Rigid  

T130,KI,B12,X2'0”  

*  

T240,KT,JE,Z6'4-9/16”,CES(100,400,300),TA=500,BK=11459  

*  

T160,X-2'0”,CLS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid  

T170,KI,B12,X-8'0”  

T180,Y-8'2-13/16,CFLANGE=WN,WGT=152  

T190,JV,Y-1'4-3/4”,CVWGT=590,THKF=3.0000,INSF=1.7500,FLANGE=WN,  

WGT=152  

T200,KI,B12,Y-1'4-3/8”,CL=1N  

T210,JS,Z-1'0”,CFFOR=1000  

T220,JD,P6,Y0'0-15/16”,Z-0'6”,COD1=8.625,THK1=0.322,OD2=6.625,  

THK2=0.28,FRE=30.000  

L200A,CUS(1,900,2250)  

*  

F240  

T250,KT,P8,Z1'2”,CL=1  

*  

T260,KT,Z1'2”  

T270,Z0'11”  

*  

F260  

T280,X-2'0”,CLS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid  

T290,KI,B12,X-8'0”  

T300,Y-8'2-13/16,CFLANGE=WN,WGT=96  

T310,JV,Y-1'4-3/4”,CVWGT=590,THKF=3.0000,INSF=1.7500,  

FLANGE=WN,WGT=152  

T320,KI,B8,Y-1'4-3/8”,CL=1S  

T330,Z1'0”  

T340,JD,Y0'0- 

15/16”,Z0'6”,COD1=8.625,THK1=0.322,OD2=6.625,THK2=0.28  

*Node 230 = P-427B Suction  

T350,KA,P6,Z1'5-3/16”,CDIS(0,0.027,0),DIS2(0,0.027,0),  

DIS3(0,0.027,0)  

L350,CFLANGE=WN,WGT=96  

*Node 550 = P-427A Suction  

F220  

T390,KA,Z-2'7”,CL=1N,DIS(0,0.027,0),DIS3(0,0.027,0)  

L390,CFLANGE=WN,WGT=96  

 

T400,Z-1'6-3/8”  

T410,JL,Z-1'5-3/8”,CTRAK(1,1,1),ROTK(1,1,1),  

LXAX(1.0000,0.0000,0.0000),LYAX(0.0000,1.0000,0.0000)  

*From node 200 2'11.5” in the Z direction  

F370,KA,X-3.8300,Y-13'8”,Z59.6267,CDIS(0,0.027,0),  

DIS2(0,0.027,0),DIS3(0,0.027,0)  

L370,CFLANGE=WN,WGT=58  

T420,P4,Z0'3-3/8”,CL=4S  

T430,JD,P6,Z0'5-1/2”,COD1=4.5,THK1=0.237,OD2=6.625,THK2=0.28  

T440,KI,B9,Z2'0-5/8”  
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T450,Y1'0-7/8”,CFLANGE=WN,WGT=96  

T460,JV,Y1'5-5/8”,CVWGT=204,THKF=3.0000,INSF=1.7500,  

FLANGE=WN,WGT=96  

T470,JV,Y1'4-1/8”,CVWGT=334,THKF=3.0000,  

INSF=1.7500,FLANGE=WN,WGT=96  

T480,KI,B9,Y7'0-3/8”  

T490,X8'0”,CLS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid  

T500,KT,X3'6”  

*  

*From node 340 -2'11.5” in the -Z direction  

F410,KA,CDIS(0,0.027,0),DIS3(0,0.027,0)  

L410,CFLANGE=WN,WGT=58  

T510,P4,Z-0'3-3/8”,CL=4N  

T520,JD,P6,Z-0'5-1/2”,COD1=4.5,THK1=0.237,OD2=6.625,THK2=0.28  

T530,KI,B9,Z-4'0-5/8”  

T540,Y1'0-7/8”,CFLANGE=WN,WGT=96  

T550,JV,Y1'5-5/8”,CVWGT=204,THKF=3.0000,  

INSF=1.7500,FLANGE=WN,WGT=96  

T560,JV,Y1'4-1/8”,CVWGT=334,THKF=3.0000,  

INSF=1.7500,FLANGE=WN,WGT=96  

T570,KI,B9,Y7'0-3/8”  

T580,X8'0”,CLS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid  

T590,KI,B9,X3'6”  

T500  

L530B,CUS(1,520,1392)  

F500  

T600,KI,B9,Z1'7”,CL=4  

T610,X-3'6”,CLS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid  

T620,KI,B9,X-10'11”  

T630,KI,B9,Y-4'6-11/16  

T640,KI,B9,Z7'4”  

T650,Y1'1”,CFLANGE=WN,WGT=96  

T660,Y0'11”  

T670,JD,P8,Y0'6”,COD1=6.625,THK1=0.28,OD2=8.625,THK2=0.322  

T680,KT,Y0'7”  

*  

F250  

T685,P4,X-2'0”,CL=1C,LS(0.000,None),DV(0.0000,1.0000,0.0000),  

STIFF=Rigid  

T690,KI,B6,X-10'11”  

T700,KI,B6,Y-1'5-11/16  

T710,Z1'10”,CFLANGE=WN,WGT=58  

 

*  

F680  

T720,Z-1'6”,CL=4,FLANGE=WN,WGT=58  

T730,JV,Z-1'0-1/4”,CVWGT=170,THKF=3.0000,  

INSF=1.7500,FLANGE=WN,WGT=58  

T735,Z-6'6-3/4”,CL=1C,LS(0.000,None),DV(0.0000,1.0000,0.0000),  

STIFF=Rigid  

T710,CL=1  

*  

F680  

T800,KI,B12,P8,Y3'0”,CL=4  

T810,Z6'1-5/8”,CFLANGE=WN,WGT=152  

T820,Z0'4-3/8”,CLS(0.000,None),DV(0.0000,1.0000,0.0000),  

STIFF=Rigid  

T830,KI,B12,Z1'0”  
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T840,KI,B12,X7'0”  

T850,KI,B12,X1'6”,Y-1'6”  

T860,X6'0”,CFLANGE=WN,WGT=152  

T870,JV,X1'4-3/4”,CVWGT=410,THKF=3.0000,INSF=1.7500,  

FLANGE=WN,WGT=152  

T880,KT,X1'4”  

*  

T890,KI,B12,Y1'7”  

T900,KI,B12,Z2'0”  

T910,Y-1'1-1/4”,CFLANGE=WN,WGT=152  

T920,JV,Y-1'4-3/4”,CVWGT=410,THKF=3.0000,INSF=1.7500,FLANGE=WN,WGT=152  

T930,KI,B12,Y-1'1-1/4”  

T940,KT,Z-2'0”  

*  

T950,X1'0”,CLS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid  

T960,X1'0”  

*  

F940  

T970,X-1'4”  

*  

F880  

T980,KI,B12,X10'6”  

T990,KI,B12,Y4'6”  

T1000,X1'10”,CLS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid  

T1010,X26'8”,CLS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid  

T1020,KI,B12,X6'2”  

T1030,KI,B12,Z2'0”  

T1040,Y4'2”  

T1050,JD,P10,Y0'7”,COD1=6.625,THK1=0.28,OD2=8.625,THK2=0.322  

T1060,KI,B15,Y1'3”  

T1070,Z7'2”,CLS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid  

T1080,Z18'8”,CLS(0.000,None),DV(0.0000,1.0000,0.0000),STIFF=Rigid  

T1090,KI,B15,Z15'2”  

T1100,KI,B15,Y-25'6”  

T1110,KI,B15,X-3.8971,Z-2'3”  

T1120,Y1'7-7/8”,CFLANGE=WN,WGT=220  

 

PUMPS  

427BSOUTH,1,350 

427ANORTH,0,0.0000,1.0000,0.0000,3.8299,13'8”,44.3351,390,2,410,2  

COMPRESSORS  

Compressor_1,1.0000,0.0000,0.0000,210,300 

SEISMIC  

0.25,0.00,0.30 

WIND  

100,0.600,1.000,0.000,0.000 
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Hanger Type  

This section describes the hanger type (HTYP under comments section) number to be used 
for defining variable spring hanger type.  

Hanger Description Type  Value  

ABB-PBS   1  
Basic Engineers   2  
Bergen Paterson   3  
Bergen Paterson (L)  4  
BHEL Hyderabad  5  
BHEL Trichy   6  
Borrello   7  
Carpenter & Paterson  8  
Corner & Lada   9  
Dynax   10  
Elcen   11  
Fee and Mason   12  
Flexider (30-60-120)  13  
Flexider (50-100-200)  14  
Fronek   15  
Grinell   16  
Hydra   17  
Lisega   18  
Mitsubishi (30-60-120)  19  
Mitsubishi (80-160)  20  
Myricks   21  
NHK (30-60-120)  22  
NHK (80-160)   23  
Nordon   24  
NPS Industries   25  
Piping Services   26  
Piping Tech & Products   27  
Power Piping   28  
Sanwa Tekki (30-60-120)   29  
Sanwa Tekki (85-170)  30  
Sarathi   31  
Spring Supports   32  
SSG   33  
Comet   34 
Gradior   35 
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MBF Export 

CAEPIPE can export model data from inside the Layout window to a text file with the 
extension .mbf (model batch file), which may be edited using a text editor. The edited text 
file may then be read back into CAEPIPE by using the Import feature. But note that the 
existing .mod file will be overwritten. So, you must rename the edited text file before 
importing it back into CAEPIPE. 

To export a model, select the menu command File > Export from the Layout window. 

 

The Export Model dialog is shown. Selecting the “Save as type” option as “Model batch file 
(*.mbf)” will export the stress model in CAEPIPE latest version. Once done, click on 
Export button to write to an .mbf file. 
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Select the “Save as type” as “Model batch file 6.xx (*.mbf)” to export the stress model in 6.xx 
format. This will allow the user to have the backward compatibility with CAEPIPE Versions 
6.81 through 10.00. 
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This section brings out the details on how each element and data from CAEPIPE are 
exported to .pcf (Piping Component File) file.  

Vertical Axis 

The stress layout developed in CAEPIPE with Y axis vertical is automatically translated to be 
Z axis as vertical when the layout is exported to PCF file. 

Limitations 

The Element types and Data types listed below are not transferred to PCF at this time. 

Element Types 
1. Ball Joint 
2. Beam 
3. Elastic Element 
4. Hinge Joint 
5. Tie Rod 
6. Comment and 
7. Hydrotest Load 

Data Types 

1. Concentrated Mass 
2. Force 
3. Harmonic Load 
4. Jacket End Cap 
5. Spider 
6. Threaded Joint 
7. Time Varying Load 
8. User SIF and 
9. Weld 

Units 

The stress system will be exported to PCF in SI units, when the Length unit selected in 
CAEPIPE for a stress layout is “m” or “mm”. Otherwise, the stress layout will be exported 
to PCF in English units. The table below provides the details on English and SI units used 
while exporting to PCF. 

Sl. 
No. 

Description of Units English Units SI Units 

1. Length inch mm 

2.  Dimension inch mm 

3. Angle degree degree 

4. Weight lbf kgf 

5. Density lbf/in3 Kgf/m3 

6. Temperature deg. F deg. C 

7. Pressure psi bar 

8. Stiffness lb/inch N/mm 

9. Rotational Stiffness in-lb/deg Nm/deg 
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Basic Header Information 

The Basic Header Information attributes that defines the control file identifier and various 
Units that are used to specify Bores, Co-ordinates, Bolt Diameters, Bolt Lengths and 
Weights while exporting PCF file are provided below for both English and SI Units. 

ISOGEN-FILES ISOGEN.FLS 
UNITS-BORE INCH / MM 
UNITS-CO-ORDS INCH / MM 
UNITS-WEIGHT LBS/KGS 
UNITS-BOLT-DIA INCH/MM 
UNITS-BOLT-LENGTH INCH/MM 

In addition to the above, the layout of stress system is always exported to PCF as a System 
Isometric using the identifier “SYSTEM-ISOMETRIC-REFERENCE” as the stress system 
may generally contain one or more individual pipelines that are physically connected in such 
a way that they form a network. 

Additional optional attributes which relate to the “System” are not written to the PCF file at 
this time. 

Pipeline Header Information 

Each “From” node defined in CAEPIPE is exported to PCF as a PIPELINE-
REFERENCE attribute with its value set to “P” followed by the From Node number used 
in CAEPIPE.  

The Temperature (T1) and Pressure (P1) defined in CAEPIPE for the element followed by 
the From node is written to PCF using the attributes “PIPELINE-TEMP” and 
ATTRIBUTE1 respectively in English or SI units as shown below. 

For example, a From Node 10 in CAEPIPE with Temperature (T1 = 200 C) and Pressure 
(P1 = 10 bar) of the element following the “From” node is exported to PCF as  

PIPELINE-REFERENCE P10 
PIPELINE-TEMP 200 
    ATTRIBUTE1 10 

Component Identifiers 

Each piping component from CAEPIPE is exported to PCF in a self-contained data block 
that consists of a “Component Identifier” together with a list of attributes that help to 
identify component location, size and specific requirements related to a physical component 
in a pipeline. 

This section provides in details on how each piping component (element) from CAEPIPE is 
transferred to PCF along with their list of attributes. Each component from CAEPIPE is 
exported to PCF with Mandatory attributes, Material Information Attributes and 
Supplementary Information Attributes. The supplementary information attributes of each 
component will have eight (8) COMPONENT-ATTRIBUTES as shown in the table below. 
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Sl. 
No. 

Component Attribute 
in PCF 

CAEPIPE Attribute English 
Units 

SI Units 

1. COMPONENT-
ATTRIBUTE1 

Section Outer Diameter ‘inch’ ‘mm’ 

2. COMPONENT-
ATTRIBUTE2 

Section Wall Thickness ‘inch’ ‘mm’ 

3. COMPONENT-
ATTRIBUTE3 

Section Corrosion 
Allowance 

‘inch’ ‘mm’ 

4. COMPONENT-
ATTRIBUTE4 

Section Mill tolerance % % 

5. COMPONENT-
ATTRIBUTE5 

Section Insulation Density ‘lbf/in3’ ‘kgf/m3’ 

6. COMPONENT-
ATTRIBUTE6 

Section Insulation 
Thickness 

‘inch’ ‘mm’ 

7. COMPONENT-
ATTRIBUTE7 

Temperature T1 ‘deg. F’ ‘deg. C’ 

8. COMPONENT-
ATTRIBUTE8 

Pressure P1 ‘psi’ ‘bar’ 

The co-ordinates for all components and supports are transferred in ‘inch’ for English Units 
and ‘mm’ for SI Units. Similarly, size attribute is transferred in ‘inch’ for English Units and 
‘mm’ for SI Units. The material type and grade for each component is transferred to PCF 
through ITEM CODE. 

Element types from CAEPIPE 

Pipe 

Pipe element from CAEPIPE is transferred to PCF as “PIPE” along with their attributes as 
shown below.  

The absolute co-ordinate corresponding to “From” and “To” node is written to “END-
POINT” attribute.  

For standard pipe sizes, the Nominal Size (NS) corresponding to Outer Diameter (OD) 
defined for the element via section property is written to “Size” attribute in “inch” for 
English Units and “mm” for SI Units. For non-standard pipe sizes, OD defined for the 
element via section property is written to “Size” attribute.  

The material properties (Name and Grade) defined for the element via “Material” property is 
written to PCF using the “ITEM-CODE” attribute. 

Section properties of pipe element such as OD, Wall Thickness, Corrosion Allowance, Mill 
tolerance, Insulation Density and Insulation Thickness are written to “COMPONENT-
ATTRIBUTE1” through “COMPONENT-ATTRIBUTE6” as explained in the Table 
above.  

Temperature T1 and Pressure P1 defined for the pipe element via “Load” property is written 
to “COMPONENT-ATTRIBUTE7” and “COMPONENT-ATTRIBUTE8” respectively as 
explained in the Table above.  

The element properties other than those listed above are ignored and not transferred to PCF 
at this time.  
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Component Identifier 

PIPE 

Mandatory Attributes 

    END-POINT   E/W co-ords  N/S co-ords Elevation co-ords Size 
    END-POINT   E/W co-ords  N/S co-ords Elevation co-ords Size 

Material Information Attributes 
    ITEM-CODE   data 
    FABRICATION-ITEM 

Supplementary Information Attributes 

    COMPONENT-ATTRIBUTE1   data 
    COMPONENT-ATTRIBUTE2   data 
    COMPONENT-ATTRIBUTE3   data 
    COMPONENT-ATTRIBUTE4   data 
    COMPONENT-ATTRIBUTE5   data 
    COMPONENT-ATTRIBUTE6   data 
    COMPONENT-ATTRIBUTE7   data 
    COMPONENT-ATTRIBUTE8   data 

Jacketed Pipe 

The Core Pipe of Jacketed Pipe element of CAEPIPE is transferred to PCF as “PIPE” along 
with their attributes as explained above. The Jacketed Pipe details are not transferred to PCF 
at this time as there is no provision available in PCF. 

Bend 

Bend element from CAEPIPE is transferred to PCF as “ELBOW” along with their 
attributes as shown below.  

The co-ordinate corresponding to “Near” and “Far End” nodes (referred in CAEPIPE as 
Node number suffixed with A and B) are written to “END-POINT” attributes. The co-
ordinate corresponding to “TIP” from CAEPIPE is written to “CENTRE-POINT” 
attribute of PCF. 

For standard component sizes, the Nominal Size (NS) corresponding to Outer Diameter 
(OD) defined for the element via section property is written to “Size” attribute in “inch” for 
English Units and “mm” for SI Units. For non-standard component sizes, OD defined for 
the element via section property is written to “Size” attribute.  

The material properties (Name and Grade) defined for the element via “Material” property is 
written to PCF using the “ITEM-CODE” attribute. 

The value of SKEY is written as “ELBW”. 

Section properties of element (defined via section property) such as OD, Wall Thickness, 
Corrosion Allowance, Mill tolerance, Insulation Density and Insulation Thickness are written 
to “COMPONENT-ATTRIBUTE1” through “COMPONENT-ATTRIBUTE6” as 
explained above.  

Temperature T1 and Pressure P1 defined for the bend element via “Load” property is 
written to “COMPONENT-ATTRIBUTE7” and “COMPONENT-ATTRIBUTE8” 
respectively as explained above.  



PCF Export 
 

235 

Bend radius [inch/mm] and Angle [deg] defined for bend element in CAEPIPE are 
transferred to “BEND-RADIUS” and “BEND-ANGLE” respectively. 

The properties other than those explained above are ignored and not transferred to PCF at 
this time.  

Component Identifier 

BEND 

Mandatory Attributes 

    END-POINT   E/W co-ords  N/S co-ords Elevation co-ords Size 
    END-POINT   E/W co-ords  N/S co-ords Elevation co-ords Size 
CENTRE-POINT  E/W co-ords  N/S co-ords Elevation co-ords  

Material Information Attributes 

    ITEM-CODE   data 
    FABRICATION-ITEM 
    SKEY ELBW 

Supplementary Information Attributes 
    COMPONENT-ATTRIBUTE1   data 
    COMPONENT-ATTRIBUTE2   data 
    COMPONENT-ATTRIBUTE3   data 
    COMPONENT-ATTRIBUTE4   data 
    COMPONENT-ATTRIBUTE5   data 
    COMPONENT-ATTRIBUTE6   data 
    COMPONENT-ATTRIBUTE7   data 
    COMPONENT-ATTRIBUTE8   data 
    BEND-RADIUS   data 
    BEND-ANGLE   data 

Miter Bend 

Miter Bend element from CAEPIPE is transferred to PCF as “ELBOW” along with their 
attributes as explained above. In addition, the value of SKEY is written as “BEBW” instead 
of ”ELBW”. 

Jacketed Bend 

The Core Bend of Jacketed Bend element of CAEPIPE is transferred to PCF as “ELBOW” 
along with their attributes as explained above. The Jacketed Bend details are not transferred 
to PCF at this time as no provision is available in PCF. 

Valve 

Valve element from CAEPIPE is transferred to PCF as “VALVE” along with their attributes 
as shown below.  

The co-ordinate corresponding to “From” and “To” node is written to “END-POINT” 
attributes.  

For standard component sizes, the Nominal Size (NS) corresponding to Outer Diameter 
(OD) defined for the valve element via section property is written to “Size” attribute in 
“inch” for English Units and “mm” for SI Units. For non-standard component sizes, OD 
defined for the valve element via section property is written to “Size” attribute.  

The material properties (Name and Grade) defined for the valve element via “Material” 
property is written to PCF using the “ITEM-CODE” attribute. 
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The value of SKEY is written as “VG**” for Gate and Globe Valve, “CK**” for Check 
Valve, “ZB**” for Butterfly Valve, “VC**” for Control Vale, “VB**” for Ball Valve and 
“VP**” for Plug Valve. For valve types other than those explained above, the SKEY is 
written as “VS**”. 

Section properties of valve element (defined via section property) such as OD, Wall 
Thickness, Corrosion Allowance, Mill tolerance, Insulation Density and Insulation Thickness 
are written to “COMPONENT-ATTRIBUTE1” through “COMPONENT-
ATTRIBUTE6” as explained above.  

Temperature T1 and Pressure P1 defined for the valve element via “Load” property is 
written to “COMPONENT-ATTRIBUTE7” and “COMPONENT-ATTRIBUTE8” 
respectively as explained above.  

Empty weight of valve is transferred to “WEIGHT” attribute in ‘lbf’ for English Units and 
‘kgf’ for SI Units. 

The valve properties other than those explained above are ignored and not transferred to 
PCF at this time.  

Component Identifier 

VALVE 

Mandatory Attributes 
    END-POINT   E/W co-ords  N/S co-ords Elevation co-ords Size 
    END-POINT   E/W co-ords  N/S co-ords Elevation co-ords Size 

Material Information Attributes 

    ITEM-CODE    data 
    FABRICATION-ITEM  data 
    SKEY   data 

Supplementary Information Attributes 
    COMPONENT-ATTRIBUTE1   data 
    COMPONENT-ATTRIBUTE2   data 
    COMPONENT-ATTRIBUTE3   data 
    COMPONENT-ATTRIBUTE4   data 
    COMPONENT-ATTRIBUTE5   data 
    COMPONENT-ATTRIBUTE6   data 
    COMPONENT-ATTRIBUTE7   data 
    COMPONENT-ATTRIBUTE8   data 
    WEIGHT    data 

Reducer 

Reducer element from CAEPIPE is transferred to PCF as “REDUCER-CONCENTRIC” 
along with their attributes as shown below.  

The co-ordinate corresponding to “From” and “To” node is written to “END-POINT” 
attributes.  

For standard component sizes, the Nominal Sizes (NS) corresponding to Outer Diameter 1 
(OD1) and Outer Diameter 2 (OD2) of Reducer element are written to “Size” attributes in 
“inch” for English Units and “mm” for SI Units. For non-standard component sizes, OD1 
and OD2 of reducer element are written to “Size” attributes.  
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The material properties (Name and Grade) defined for the reducer element via “Material” 
property is written to PCF using the “ITEM-CODE” attribute. 

The value of SKEY is written as “RCBW”. 

Section properties defined for the Reducer element (via section property) such as OD, Wall 
Thickness, Corrosion Allowance, Mill tolerance, Insulation Density and Insulation Thickness 
are written to “COMPONENT-ATTRIBUTE1” through “COMPONENT-
ATTRIBUTE6” as explained above.  

Temperature T1 and Pressure P1 defined for the valve element via “Load” property is 
written to “COMPONENT-ATTRIBUTE7” and “COMPONENT-ATTRIBUTE8” 
respectively as explained above.  

The reducer properties other than those explained above are ignored and not transferred to 
PCF at this time.  

Component Identifier 

REDUCER-CONCENTRIC 

Mandatory Attributes 

    END-POINT   E/W co-ords  N/S co-ords Elevation co-ords Size 
    END-POINT   E/W co-ords  N/S co-ords Elevation co-ords Size 

Material Information Attributes 

    ITEM-CODE    data 
    FABRICATION-ITEM  data 
    SKEY   RCBW 

Supplementary Information Attributes 
    COMPONENT-ATTRIBUTE1   data 
    COMPONENT-ATTRIBUTE2   data 
    COMPONENT-ATTRIBUTE3   data 
    COMPONENT-ATTRIBUTE4   data 
    COMPONENT-ATTRIBUTE5   data 
    COMPONENT-ATTRIBUTE6   data 
    COMPONENT-ATTRIBUTE7   data 
    COMPONENT-ATTRIBUTE8   data 

Bellows / Slip Joint / Cut-Pipe 

Bellow / Slip Joint / Cut-pipe from CAEPIPE are transferred to PCF as “MISC-
COMPONENT” along with their attributes as shown below.  

The co-ordinate corresponding to “From” and “To” node of the element is written to 
“END-POINT” attributes.  

The mid-point computed using the “From” and “To” node of the element is written to 
“CENTRE-POINT” attribute. 

For standard component sizes, the Nominal Size (NS) corresponding to Outer Diameter 
(OD) of the element is written to “Size” attributes in “inch” for English Units and “mm” for 
SI Units. For non-standard component sizes, OD of the element is written to “Size” 
attribute.  

The material properties (Name and Grade) defined for the element via “Material” property is 
written to PCF using the “ITEM-CODE” attribute. 
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The SKEY attribute is written as EXPJ, SLIP and CUTP for Bellows, Slip Joint and Cut-
Pipe respectively. 

Section properties defined for the element (via section property) such as OD, Wall 
Thickness, Corrosion Allowance, Mill tolerance, Insulation Density and Insulation Thickness 
are written to “COMPONENT-ATTRIBUTE1” through “COMPONENT-
ATTRIBUTE6” as explained above.  

Temperature T1 and Pressure P1 defined for the element via “Load” property is written to 
“COMPONENT-ATTRIBUTE7” and “COMPONENT-ATTRIBUTE8” respectively as 
explained above.  

Empty weight of bellow is transferred to “WEIGHT” attribute in ‘lbf’ for English Units and 
‘kgf’ for SI Units. 

The properties other than those explained above are ignored and not transferred to PCF at 
this time for Bellows / Slip Joint / Cut-Pipe. 

Component Identifier 

MISC-COMPONENT 

Mandatory Attributes 

    END-POINT   E/W co-ords  N/S co-ords Elevation co-ords Size 
    END-POINT   E/W co-ords  N/S co-ords Elevation co-ords Size 
CENTRE-POINT  E/W co-ords  N/S co-ords Elevation co-ords  

Material Information Attributes 
    ITEM-CODE    data 
    FABRICATION-ITEM  data 
    SKEY   EXPJ / SLIP / CUTP 

Supplementary Information Attributes 

    COMPONENT-ATTRIBUTE1   data 
    COMPONENT-ATTRIBUTE2   data 
    COMPONENT-ATTRIBUTE3   data 
    COMPONENT-ATTRIBUTE4   data 
    COMPONENT-ATTRIBUTE5   data 
    COMPONENT-ATTRIBUTE6   data 
    COMPONENT-ATTRIBUTE7   data 
    COMPONENT-ATTRIBUTE8   data 
    WEIGHT    data [only for Bellows] 
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Flange 

Rigid element (with length < OD) and Flange from CAEPIPE is transferred to PCF as 
“FLANGE” along with their attributes as shown below.  

For rigid element, the co-ordinate corresponding to “From” and “To” node is written to 
“END-POINT” attributes. On the other hand, for flange, the co-ordinate corresponding to 
flange node is written to “END-POINT” attributes. As the length of flange is zero in 
CAEPIPE (being a nodal property), both “END-POINT” attributes will have the same 
values. 

For standard component sizes, the Nominal Size (NS) corresponding to Outer Diameter 
(OD) of the rigid element / flange defined via section property is written to “Size” attributes 
in “inch” for English Units and “mm” for SI Units. For non-standard component sizes, OD 
of the rigid element / flange is written to “Size” attribute.  

The material properties (Name and Grade) defined for the rigid element / flange via 
“Material” property is written to PCF using the “ITEM-CODE” attribute. 

The SKEY attribute is written as “FL**”. 

Section properties defined for the rigid element / flange (via section property) such as OD, 
Wall Thickness, Corrosion Allowance, Mill tolerance, Insulation Density and Insulation 
Thickness are written to “COMPONENT-ATTRIBUTE1” through “COMPONENT-
ATTRIBUTE6” as explained above.  

Temperature T1 and Pressure P1 defined for the rigid element / flange via “Load” property 
is written to “COMPONENT-ATTRIBUTE7” and “COMPONENT-ATTRIBUTE8” 
respectively as explained above.  

Empty weight of rigid element / flange is transferred to “WEIGHT” attribute in ‘lbf’ for 
English Units and ‘kgf’ for SI Units. 

The properties other than those explained above are ignored and not transferred to PCF at 
this time 

Component Identifier 

FLANGE 

Mandatory Attributes 

    END-POINT   E/W co-ords  N/S co-ords Elevation co-ords Size 
    END-POINT   E/W co-ords  N/S co-ords Elevation co-ords Size 

Material Information Attributes 
    ITEM-CODE    data 
    FABRICATION-ITEM  data 
    SKEY   FL** 
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Supplementary Information Attributes 

    COMPONENT-ATTRIBUTE1   data 
    COMPONENT-ATTRIBUTE2   data 
    COMPONENT-ATTRIBUTE3   data 
    COMPONENT-ATTRIBUTE4   data 
    COMPONENT-ATTRIBUTE5   data 
    COMPONENT-ATTRIBUTE6   data 
    COMPONENT-ATTRIBUTE7   data 
    COMPONENT-ATTRIBUTE8   data 
    WEIGHT    data 

Rigid 

Rigid element from CAEPIPE is transferred to PCF as “INSTRUMENT” along with their 
attributes as shown below when the length of the rigid element is greater than the outer 
diameter (OD) of the element. On the other hand, when the length is less than OD of the 
element, then the same is transferred as “FLANGE” to PCF as explained above. 

The co-ordinate corresponding to “From” and “To” node of the element is written to 
“END-POINT” attributes.  

The mid-point computed using the “From” and “To” node of the element is written to 
“CENTRE-POINT” attribute. 

For standard component sizes, the Nominal Size (NS) corresponding to Outer Diameter 
(OD) of the element is written to “Size” attributes in “inch” for English Units and “mm” for 
SI Units. For non-standard component sizes, OD of the element is written to “Size” 
attribute.  

The material properties (Name and Grade) defined for the element via “Material” property is 
written to PCF using the “ITEM-CODE” attribute. 

The SKEY attribute is written as “INST”. 

Section properties defined for the element (via section property) such as OD, Wall 
Thickness, Corrosion Allowance, Mill tolerance, Insulation Density and Insulation Thickness 
are written to “COMPONENT-ATTRIBUTE1” through “COMPONENT-
ATTRIBUTE6” as explained above.  

Temperature T1 and Pressure P1 defined for the valve element via “Load” property is 
written to “COMPONENT-ATTRIBUTE7” and “COMPONENT-ATTRIBUTE8” 
respectively as explained above.  

Empty weight of rigid element is transferred to “WEIGHT” attribute in ‘lbf’ for English 
Units and ‘kgf’ for SI Units. 

The properties other than those explained above are ignored and not transferred to PCF at 
this time. 
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Component Identifier 

INSTRUMENT 

Mandatory Attributes 

    END-POINT   E/W co-ords  N/S co-ords Elevation co-ords Size 
    END-POINT   E/W co-ords  N/S co-ords Elevation co-ords Size 
CENTRE-POINT  E/W co-ords  N/S co-ords Elevation co-ords  

Material Information Attributes 
    ITEM-CODE    data 
    FABRICATION-ITEM  data 
    SKEY   INST 

Supplementary Information Attributes 

    COMPONENT-ATTRIBUTE1   data 
    COMPONENT-ATTRIBUTE2   data 
    COMPONENT-ATTRIBUTE3   data 
    COMPONENT-ATTRIBUTE4   data 
    COMPONENT-ATTRIBUTE5   data 
    COMPONENT-ATTRIBUTE6   data 
    COMPONENT-ATTRIBUTE7   data 
    COMPONENT-ATTRIBUTE8   data 
    WEIGHT    data 

Data Types from CAEPIPE 

Anchor 

Anchor from CAEPIPE is transferred to PCF as “Support” along with the attributes as 
shown below. The co-ordinate value corresponding to Anchor node is written to “END-
POINT” attribute. 

The SKEY attribute is written as “ANCH”. 

The stiffnesses and specified displacements defined in CAEPIPE for Anchor are ignored at 
this time. 

Component Identifier 

SUPPORT 

Mandatory Attributes 

CO-ORDS  E/W co-ords  N/S co-ords Elevation co-ords Size 

Material Information Attributes 
    ITEM-CODE    data 
    FABRICATION-ITEM  data 
    SKEY   ANCH 
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Branch SIF 

Branch SIF with their sub-types are transferred from CAEPIPE to PCF as given below.  

Sl. No. Sub-Type of Branch SIF Component Identifier 
in PCF 

1. Welding TEE TEE 

2. Reinforced Fabricated Tee TEE-SET-ON 

3. Unreinforced Fabricated Tee TEE-SET-ON 

4. Others TEE-STUB 

As Branch SIF in CAEPIPE is assigned to a node, the co-ordinate value corresponding to 
“Branch SIF” node is written to “END-POINT”, “CENTRE-POINT” and “BRANCH1-
POINT” attributes.  

For standard component sizes, the Nominal Size (NS) corresponding to Run Pipe Outer 
Diameter (OD1) and Branch Pipe Outer Diameter (OD2) of the element is written to “Size” 
attributes in “inch” for English Units and “mm” for SI Units. For non-standard component 
sizes, OD1 and OD2 of the element are written to “Size” attributes.  

The material properties (Name and Grade) defined for the element via “Material” property 
on which the Branch SIF is located is written to PCF using the “ITEM-CODE” attribute. 

Component Identifier 

TEE 

Mandatory Attributes 

    END-POINT   E/W co-ords  N/S co-ords Elevation co-ords Size 
    END-POINT   E/W co-ords  N/S co-ords Elevation co-ords Size 
    CENTRE-POINT  E/W co-ords  N/S co-ords Elevation co-ords 
BRANCH1-POINT E/W co-ords  N/S co-ords Elevation co-ords Size  

Material Information Attributes 

    ITEM-CODE    data 
    FABRICATION-ITEM  data 
    SKEY   TEBW 

Reinforced / Unreinforced Fabricated Tee 

Component Identifier 

TEE-SET-ON 

Mandatory Attributes 

BRANCH1-POINT E/W co-ords  N/S co-ords Elevation co-ords Size  
    CENTRE-POINT  E/W co-ords  N/S co-ords Elevation co-ords 

Material Information Attributes 

    ITEM-CODE    data 
    FABRICATION-ITEM  data 
    SKEY   TESO 
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Other Tees 

Component Identifier 

TEE-STUB 

Mandatory Attributes 

BRANCH1-POINT E/W co-ords  N/S co-ords Elevation co-ords Size  
    CENTRE-POINT  E/W co-ords  N/S co-ords Elevation co-ords 

Material Information Attributes 

    ITEM-CODE    data 
    FABRICATION-ITEM  data 
    SKEY   TSSO 

Guide 

Guide from CAEPIPE is transferred to PCF as “Support” along with the attributes as shown 
below.  

The co-ordinate value corresponding to Guide node is written to “END-POINT” attribute. 

For standard component sizes, the Nominal Size (NS) corresponding to Outer Diameter 
(OD) of the element in which the guide is defined is written to “Size” attributes in “inch” for 
English Units and “mm” for SI Units. For non-standard component sizes, OD of the 
element are written to “Size” attribute.  

The Friction, Stiffness [lb/in or N/mm] and Gap [in or mm] defined at Guide are 
transferred to “COMPONENT-ATTRIBUTE1”, “COMPONENT-ATTRIBUTE2” and 
“COMPONENT-ATTRIBUTE3” respectively.  

Component Identifier 

SUPPORT 

Mandatory Attributes 

CO-ORDS  E/W co-ords  N/S co-ords Elevation co-ords Size 

Material Information Attributes 

    ITEM-CODE    data 
    FABRICATION-ITEM  data 
    SKEY   GUI 

Supplementary Information Attributes 
    COMPONENT-ATTRIBUTE1   data 
    COMPONENT-ATTRIBUTE2   data 
    COMPONENT-ATTRIBUTE3   data 

Hanger 

Hanger from CAEPIPE is transferred to PCF as “Support” along with the attributes as 
shown below.  

The co-ordinate value corresponding to Hanger node is written to “END-POINT” attribute. 

For standard component sizes, the Nominal Size (NS) corresponding to Outer Diameter 
(OD) of the element in which the hanger is located is written to “Size” attributes in “inch” 
for English Units and “mm” for SI Units. For non-standard component sizes, OD of the 
element are written to “Size” attribute.  

The SKEY attribute is written as “SPRG”. 
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The hanger type and number of hangers entered in CAEPIPE are transferred to 
“COMPONENT-ATTRIBUTE1” and “COMPONENT-ATTRIBUTE2 respectively.  

Component Identifier 

SUPPORT 

Mandatory Attributes 

CO-ORDS  E/W co-ords  N/S co-ords Elevation co-ords Size 

Material Information Attributes 
    ITEM-CODE    data 
    FABRICATION-ITEM  data 
    SKEY   SPRG 

Supplementary Information Attributes 

    COMPONENT-ATTRIBUTE1   data 
    COMPONENT-ATTRIBUTE2   data 

User Hanger 

User Hanger from CAEPIPE is transferred to PCF as “Support” along with the attributes as 
shown below.  

The co-ordinate value corresponding to User Hanger node is written to “END-POINT” 
attribute. 

For standard component sizes, the Nominal Size (NS) corresponding to Outer Diameter 
(OD) of the element in which the user hanger is defined is written to “Size” attributes in 
“inch” for English Units and “mm” for SI Units. For non-standard component sizes, OD of 
the element are written to “Size” attribute.  

The SKEY attribute is written as “HANG”. 

The Spring Stiffness [lb/in or N/mm], Number of hangers, Load [lb or N] and load type 
[HOT or COLD] defined at User Hanger are transferred to “COMPONENT-
ATTRIBUTE1”, “COMPONENT-ATTRIBUTE2”, “COMPONENT-ATTRIBUTE3” 
and “COMPONENT-ATTRIBUTE4” respectively.  

Component Identifier 

SUPPORT 

Mandatory Attributes 
CO-ORDS  E/W co-ords  N/S co-ords Elevation co-ords Size 

Material Information Attributes 

    ITEM-CODE    data 
    FABRICATION-ITEM  data 
    SKEY   HANG 
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Supplementary Information Attributes 

    COMPONENT-ATTRIBUTE1   data 
    COMPONENT-ATTRIBUTE2   data 
    COMPONENT-ATTRIBUTE3  data 
    COMPONENT-ATTRIBUTE4  data 

Rod Hanger 

Rod Hanger from CAEPIPE is transferred to PCF as “Support” along with the attributes as 
shown below.  

The co-ordinate value corresponding to Rod Hanger node is written to “END-POINT” 
attribute. 

For standard component sizes, the Nominal Size (NS) corresponding to Outer Diameter 
(OD) of the element in which the rod hanger is defined is written to “Size” attributes in 
“inch” for English Units and “mm” for SI Units. For non-standard component sizes, OD of 
the element are written to “Size” attribute.  

The SKEY attribute is written as “ROD”. 

The Number of hangers defined at Rod hanger of CAEPIPE is transferred to 
“COMPONENT-ATTRIBUTE1”.  

Component Identifier 

SUPPORT 

Mandatory Attributes 

CO-ORDS  E/W co-ords  N/S co-ords Elevation co-ords Size 

Material Information Attributes 
    ITEM-CODE    data 
    FABRICATION-ITEM  data 
    SKEY   ROD 

Supplementary Information Attributes 

    COMPONENT-ATTRIBUTE1   data 

Constant Support 

Constant Support from CAEPIPE is transferred to PCF as “Support” along with the 
attributes as shown below.  

The co-ordinate value corresponding to Constant Support node is written to “END-
POINT” attribute. 

For standard component sizes, the Nominal Size (NS) corresponding to Outer Diameter 
(OD) of the element in which the constant support is defined is written to “Size” attributes 
in “inch” for English Units and “mm” for SI Units. For non-standard component sizes, OD 
of the element are written to “Size” attribute.  

The SKEY attribute is written as “CS”. 

The Number of hangers defined at this support in CAEPIPE is transferred to 
“COMPONENT-ATTRIBUTE1”.  
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Component Identifier 

SUPPORT 

Mandatory Attributes 

    CO-ORDS   E/W co-ords  N/S co-ords Elevation co-ords Size 

Material Information Attributes 
    ITEM-CODE    data 
    FABRICATION-ITEM  data 
    SKEY   CS 

Supplementary Information Attributes 

    COMPONENT-ATTRIBUTE1   data 

Limit Stop 

Limit Stop from CAEPIPE is transferred to PCF as “Support” along with the attributes as 
shown below.  

The co-ordinate value corresponding to Limit Stop node is written to “END-POINT” 
attribute. 

For standard component sizes, the Nominal Size (NS) corresponding to Outer Diameter 
(OD) of the element in which the limit stop is defined is written to “Size” attributes in 
“inch” for English Units and “mm” for SI Units. For non-standard component sizes, OD of 
the element are written to “Size” attribute.  

The Upper Limit [in or mm], Lower Limit [in or mm], Stiffness [lb/in or N/mm] and 
Friction defined at Limit Stop are transferred to “COMPONENT-ATTRIBUTE1”, 
“COMPONENT-ATTRIBUTE2”, “COMPONENT-ATTRIBUTE3” and 
“COMPONENT-ATTRIBUTE4” respectively. The value of SKEY attribute is written as 
LSX when the direction is defined as (1.0, 0.0, 0.0), LSY when the direction is defined as 
(0.0,1.0, 0.0), LSZ when the direction is defined as (0.0, 0.0, 1.0) and LIM for other 
directions. 

Component Identifier 

SUPPORT 

Mandatory Attributes 

    CO-ORDS   E/W co-ords  N/S co-ords Elevation co-ords Size 

Material Information Attributes 
    ITEM-CODE    data 
    FABRICATION-ITEM  data 
    SKEY   LIM / LSX /LSY / LSZ 

Supplementary Information Attributes 

    COMPONENT-ATTRIBUTE1   data 
    COMPONENT-ATTRIBUTE2   data  
    COMPONENT-ATTRIBUTE3   data  
    COMPONENT-ATTRIBUTE4   data  
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Nozzle 

Nozzle from CAEPIPE is transferred to PCF as “Nozzle” along with the attributes as 
shown below.  

The co-ordinate value corresponding to Nozzle node is written to “END-POINT” attribute. 

For standard component sizes, the Nominal Size (NS) corresponding to Outer Diameter 
(OD) of the element in which the nozzle is defined is written to “Size” attributes in “inch” 
for English Units and “mm” for SI Units. For non-standard component sizes, OD of the 
element are written to “Size” attribute.  

Component Identifier 

NOZZLE 

Mandatory Attributes 
    CO-ORDS   E/W co-ords  N/S co-ords Elevation co-ords Size 

Restraint 

Restraint from CAEPIPE is transferred to PCF as “Support” along with the attributes as 
shown below.  

The co-ordinate value corresponding to Restraint node is written to “END-POINT” 
attribute. 

For standard component sizes, the Nominal Size (NS) corresponding to Outer Diameter 
(OD) of the element in which the restraint is defined is written to “Size” attributes in “inch” 
for English Units and “mm” for SI Units. For non-standard component sizes, OD of the 
element are written to “Size” attribute.  

The SKEY value will be filled with type of “Restraint” defined in CAEPIPE. For example, X 
and Z defined at a “Restraint” in CAEPIPE will be written to SKEY of PCF as “XZ” 

Component Identifier 

SUPPORT 

Mandatory Attributes 

    CO-ORDS   E/W co-ords  N/S co-ords  Elevation co-ords
 Size 

Material Information Attributes 

    ITEM-CODE    data 
    FABRICATION-ITEM  data 
    SKEY   data 

Skewed Restraint 

Skewed Restraint from CAEPIPE is transferred to PCF as “Support” along with the 
attributes as shown below.  

The co-ordinate value corresponding to Skewed Restraint node is written to “END-POINT” 
attribute. 

For standard component sizes, the Nominal Size (NS) corresponding to Outer Diameter 
(OD) of the element in which the skewed restraint is defined is written to “Size” attributes in 
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“inch” for English Units and “mm” for SI Units. For non-standard component sizes, OD of 
the element are written to “Size” attribute.  

Translational Stiffness [lb/in or N/mm] or Rotational Stiffness [in-lb/deg or N-m/deg] 
defined in CAEPIPE will be transferred to COMPONENT-ATTRIBUTE1 of PCF. The 
value of SKEY is filled as TX, TY and TZ for Translational Restraint defined in X, Y and Z 
directions respectively. Similarly, for Rotational Restraint, the value of SKEY is filled as RX, 
RY and RZ for Rotational Restraint defined in X, Y and Z directions respectively. For 
Translational and Rotational Restraint defined in directions other than X, Y and Z, the value 
of SKEY is filled as “SKEW”. 

Component Identifier 

SUPPORT 

Mandatory Attributes 

    CO-ORDS   E/W co-ords  N/S co-ords Elevation co-ords Size 

Material Information Attributes 
    ITEM-CODE    data 
    FABRICATION-ITEM  data 
    SKEY   TX/TY/TZ / RX/RY/RZ/SKEW 

Supplementary Information Attributes 

    COMPONENT-ATTRIBUTE1   data 

Snubber 

Snubber from CAEPIPE is transferred to PCF as “Support” along with the attributes as 
shown below.  

The co-ordinate value corresponding to Snubber node is written to “END-POINT” 
attribute. 

For standard component sizes, the Nominal Size (NS) corresponding to Outer Diameter 
(OD) of the element in which the snubber is defined is written to “Size” attributes in “inch” 
for English Units and “mm” for SI Units. For non-standard component sizes, OD of the 
element are written to “Size” attribute.  

Stiffness [lb/in or N/mm] defined in CAEPIPE will be transferred to COMPONENT-
ATTRIBUTE1 of PCF. The value of SKEY is filled as XSNB, YSNB and ZSNB for 
snubber defined in X, Y and Z directions respectively. For direction of snubber other than 
X, Y and Z, the value is written as “SNUB”. 

Component Identifier 

SUPPORT 

Mandatory Attributes 

    CO-ORDS   E/W co-ords  N/S co-ords Elevation co-ords Size 

Material Information Attributes 
    ITEM-CODE    data 
    FABRICATION-ITEM  data 
    SKEY   XSNB / YSNB / ZSNB /SNUB 

Supplementary Information Attributes 

    COMPONENT-ATTRIBUTE1   data 
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Generic Support 

Generic Support from CAEPIPE is transferred to PCF as “Support” along with the 
attributes as shown below. 

The co-ordinate value corresponding to Generic Support node is written to “END-POINT” 
attribute. 

For standard component sizes, the Nominal Size (NS) corresponding to Outer Diameter 
(OD) of the element in which the generic support is defined is written to “Size” attributes in 
“inch” for English Units and “mm” for SI Units. For non-standard component sizes, OD of 
the element are written to “Size” attribute.  

The stiffnesses defined in CAEPIPE for Generic Support are ignored at this time 

Component Identifier 

SUPPORT 

Mandatory Attributes 
    CO-ORDS   E/W co-ords  N/S co-ords  Elevation co-ords
 Size 

Material Information Attributes 

    ITEM-CODE    data 
    FABRICATION-ITEM  data 

    SKEY   GNSP
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Import Material Library 

CAEPIPE can import material properties created using a text file (batch file) into the 
Material Library. The text file may be created using a text editor and should have the 
extension: .mlb (material library batch file). The text file may also be created for an existing 
material library using the Export command from the Material Library window. 

To import a material properties into the material library, select the menu command File > 
New > Material Library. From the Material Library window > File > Import…  

 

The Import Material Library dialog is shown. 

 

Select the material library batch file (.mlb) and then click on the Import button.  The batch 
file will be read and the material properties thus imported are then shown in the Layout 
window, which can be further modified. 

The input data is given in the following order. The start of each section is indicated by a 
keyword. The data for that section follow. Only the first five characters of the keyword are 
significant. 

Format of Material Library Batch file (.mlb) is given below. 
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OPTIONS 

Piping Code, Units 

Piping Codes that can be entered are given below. Example, enter B311 to define the Piping 
Code as “ASME B31.1”. 

Units can be “SI” or “English”. If this field is left blank, then CAEPIPE will set the default 
units as “English” 

OPTIONSExample 
OPTIONS  

B311,SI 

Piping codes 

B311  ASMEB31.1 
B311-67  USASB31.1(1967)  
B313  ASME B31.3 
B314  ASME B31.4 
B315  ASME B31.5 
B318  ASME B31.8 
B319  ASME B31.9 
B3112  ASME B31.12 
ASME  ASMESectionIII,Class2(1980)  
ASME-86 ASMESectionIII,Class2(1986)  
ASME-92 ASME Section III, Class 2 (1992) 
ASME-2015 ASME Section III, Class 2 (2015) 
ASME-2017 ASME Section III, Class 2 (2017) 
ASME-ND-2017 ASME Section III, Class 3 (2017) 
BS806  Britishcode 
NORWEGIAN-83 Norwegiancode (1983) 
NORWEGIAN-90 Norwegiancode (1990) 
RCC-M  Frenchcode (1985) 
SNCT  CODETI (1995) 
SWEDISH Swedish code (1978) 
STOOMWEZEN Dutchcode (1989) 
Z183  Z183 (1990) 
Z184  Z184 (1992) 
Z662  Z662 
EUROPEAN EN 13480 

 
MATERIAL 

English units 
First line: Description (32 Characters), Density (lbf/in3), Poisson’s ratio, [Long. joint factor], 
[circ. joint factor], [material type], [tensile strength (psi)] 

Following lines:  

Description, Temp (F), E (psi), alfa (in/in/F), [allowable stress (psi)], [yield stress (psi)], 
[rupture stress (psi)], [hoop modulus (psi)], [shear modulus (psi)] 

. 

. 
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SIunits 
First line: Description (32 Characters), Density (kgf/m3), Poisson’s ratio, [Long. joint factor], 
[circ.joint factor], [material type], [tensile strength (N/mm2)]  

Following lines: Description, Temp (C), E (N/mm2), alfa (mm/mm/C), [allowable stress 
(N/mm2)], [yield stress (N/mm2)], [rupture stress (N/mm2)], [hoop modulus (N/mm2)], 
[shear modulus (N/mm2)] 

. 

. 

 
MATERIALExample(SIunits) 
OPTIONS 

EUROPEAN,SI 

MATERIAL 

EN 1.0345 (P235GH) max 60 mm,7850,0.300,1.00,1.00,CSS,360.0 

EN 1.0345 (P235GH) max 60 mm,20,212000,11.90E-6,120.0,0.000,0.000,0.000,0.000 

EN 1.0345 (P235GH) max 60 mm,50,209500,12.20E-6,120.0,0.000,0.000,0.000,0.000 

EN 1.0345 (P235GH) max 60 mm,100,207000,12.50E-6,120.0,0.000,0.000,0.000,0.000 

EN 1.0345 (P235GH) max 60 mm,150,203000,12.75E-6,120.0,0.000,0.000,0.000,0.000 

EN 1.0345 (P235GH) max 60 mm,200,199000,13.00E-6,113.0,0.000,0.000,0.000,0.000 

EN 1.0345 (P235GH) max 60 mm,250,195500,13.30E-6,100.0,0.000,0.000,0.000,0.000 

EN 1.0345 (P235GH) max 60 mm,300,192000,13.60E-6,86.70,0.000,0.000,0.000,0.000 

EN 1.0345 (P235GH) max 60 mm,350,188000,13.85E-6,80.00,0.000,0.000,0.000,0.000 

EN 1.0345 (P235GH) max 60 mm,400,184000,14.10E-6,74.70,0.000,94.00,0.000,0.000 

EN 1.0345 (P235GH) max 60 mm,410,183100,14.14E-6,74.16,0.000,85.30,0.000,0.000 

EN 1.0345 (P235GH) max 60 mm,420,182200,14.18E-6,73.62,0.000,76.00,0.000,0.000 

EN 1.0345 (P235GH) max 60 mm,430,181300,14.22E-6,66.70,0.000,66.70,0.000,0.000 

EN 1.0345 (P235GH) max 60 mm,440,180400,14.26E-6,58.70,0.000,58.70,0.000,0.000 

EN 1.0345 (P235GH) max 60 mm,450,179500,14.30E-6,51.30,0.000,51.30,0.000,0.000 

EN 1.0345 (P235GH) max 60 mm,460,178600,14.34E-6,44.00,0.000,44.00,0.000,0.000 

EN 1.0345 (P235GH) max 60 mm,470,177700,14.38E-6,37.30,0.000,37.30,0.000,0.000 

EN 1.0345 (P235GH) max 60 mm,480,176800,14.42E-6,31.30,0.000,31.30,0.000,0.000 

EN 1.0345 (P235GH) max 60 mm,490,175900,14.46E-6,26.00,0.000,26.00,0.000,0.000 

EN 1.0345 (P235GH) max 60 mm,500,175000,14.50E-6,21.30,0.000,21.30,0.000,0.000 

 

MATERIALExample(Englishunits) 
 
OPTIONS 

B311 

MATERIAL 

A53 GRADE A (SEAMLESS),0.283,0.300,1.00,1.00,CS,29994 

A53 GRADE A (SEAMLESS),-20,29.9E+6,6.25E-6,13700,0,0,0,0 

A53 GRADE A (SEAMLESS),100,29.3E+6,6.46E-6,13700,0,0,0,0 

A53 GRADE A (SEAMLESS),200,28.8E+6,6.70E-6,13700,0,0,0,0 

A53 GRADE A (SEAMLESS),300,28.3E+6,6.90E-6,13700,0,0,0,0 

A53 GRADE A (SEAMLESS),399.9,27.4E+6,7.10E-6,13700,0,0,0,0 

A53 GRADE A (SEAMLESS),500,27.3E+6,7.30E-6,13700,0,0,0,0 

A53 GRADE A (SEAMLESS),600.1,26.5E+6,7.40E-6,13700,0,0,0,0 

A53 GRADE A (SEAMLESS),649.9,26.0E+6,7.50E-6,13700,0,0,0,0 

A53 GRADE A (SEAMLESS),700,25.5E+6,7.60E-6,12499,0,0,0,0 

A53 GRADE A (SEAMLESS),750,24.9E+6,7.70E-6,10699,0,0,0,0 

A53 GRADE A (SEAMLESS),800.1,24.2E+6,7.80E-6,9000,0,0,0,0 



Import/Export Material Library 
 

253 

Export Material Library 

CAEPIPE can export material properties to a batch text file with the extension .mlb 
(material library batch file).  The text file may be edited using a text editor / using MS Excel.  
The edited text file may be read back into CAEPIPE by using the Import feature. 

To export the material properties, select the menu command File > Export from the 
Material Library Layout window. 

 

The Export Material Library dialog is shown. Click on the Export button to write to the 
batch file. 
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Response Spectrum Libraries 

CAEPIPE provide fourteen (14) response spectra for your convenience. These spectra are 
stored in 3 separate Response Spectrum Library files under the directory 
“Spectrum_Library”. These fourteen (14) spectra are added as per the following. 

 EL Centro May 18, 1940 

 Uniform Building Code (UBC) 1991 Edition and 

 Nuclear Regulatory Commission (NRC) Guide 1.60 

EL Centro 

This spectrum data can be accessed by selecting the file “ELCentro_NS_May18_1940.spe” 
available in the folder “SpectrumLibrary” through Layout window >Misc> Spectrums > File 
> Library.  

This predefined data is taken from “J’Bigs, Introduction to Structural Dynamics” and is 
based on the north-south component of the May 18, 1940 El Centro California earthquake. 
As stated in this document, the recorded maximum quantities were 0.33g, 13.7 in/sec, and 
8.3 in. This is intended to apply to elastic systems having between 5 and 10 % critical 
damping. For the El Centro input given below, the three straight lines are defined by. 
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Uniform Building Code (1991 Edition) 

This spectrum data can be accessed by selecting the file “UBC_1991.spe” available in the 
folder “SpectrumLibrary” through Layout window >Misc> Spectrums > File > Library. This 
library has predefined spectrums for three (3) types of soils as shown in the figure below 
(taken from Uniform Building Code 1991 Edition).  

Rock and Stiff Soils (Soil Type 1) [Library Name in CAEPIPE: RASS (S1)] 

Deep and Cohesionless or Stiff Clay Soils (Soil Type 2) [Library Name in CAEPIPE: DCSCS 
(S2)] 

Soft to Medium Clays and Sands [Library Name in CAEPIPE: SMCS (S3)] 

These spectrums must be scaled by the Zero Period Accelerations (ZPA), which is the 
product of Z and I, where Z is the seismic zone coefficient and I is the earthquake 
importance factor as given in UBC Tables 23-I and 23-L. They are reproduced from UBC 
code for easy reference. This product can be applied in CAEPIPE as a scale factor through 
Layout window > Loads > Spectrum > Factor (s). 
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Nuclear Regulatory Commission (NRC) Guide 1.60 

This spectrum data can be accessed by selecting the file “NRC_G1.6_2014.spe” available in 
the folder “SpectrumLibrary” through Layout window >Misc> Spectrums > File > Library. 
This library have ten (10) predefined spectrums are based upon Safe Shutdown Earthquake 
(SSE) for Horizontal and Vertical Design Response Spectra corresponding to 0.5, 2.0, 5.0, 
7.0 and 10% Damping factors as shown in the figure below (taken from NRC Guide 1.60, 
July 2014, Revision 2) 

These predefined spectrums are named in the CAPIPE spectrum library as follows. 

 NRC-HDS-D0.5 (Horizontal Design Spectra with 0.5% Damping Factor) 

 NRC-HDS-D2 (Horizontal Design Spectra with 2% Damping Factor) 

 NRC-HDS-D5 (Horizontal Design Spectra with 5% Damping Factor) 

 NRC-HDS-D7 (Horizontal Design Spectra with 7% Damping Factor) 

 NRC-HDS-D10 (Horizontal Design Spectra with 10% Damping Factor) 

 NRC-VDS-D0.5 (Vertical Design Spectra with 0.5% Damping Factor) 

 NRC-VDS-D2 (Vertical Design Spectra with 2% Damping Factor) 

 NRC-VDS-D5 (Vertical Design Spectra with 5% Damping Factor) 

 NRC-VDS-D7 (Vertical Design Spectra with 7% Damping Factor) 

 NRC-VDS-D10 (Vertical Design Spectra with 10% Damping Factor) 

The horizontal and vertical component Design Response Spectra in Figures 1 and 2 
correspond to a maximum horizontal ground acceleration of 1.0g. For sites with different 
acceleration values specified for the design earthquake, the Design Response Spectra should 
be linearly scaled from Figures 1 and 2 in proportion to the specified maximum horizontal 
ground acceleration. This proportion factor calculated can be applied in CAEPIPE as a scale 
factor through Layout window > Loads > Spectrum > Factor (s). 
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Horizontal Component: 

The numerical values of design displacements, velocities, and accelerations for the horizontal 
component Design Response Spectra are obtained by multiplying the corresponding values 
of the maximum ground displacement and acceleration by the factors given in Table 1 given 
below.  In Figure 1, the base diagramconsists of three parts: the bottom line on the left part 
represents the maximum grounddisplacement, the bottom line on the right part represents 
the maximum acceleration, and themiddle part depends on the maximum velocity. The 
horizontal component Design ResponseSpectra in Figure 1 of this guide correspond to a 
maximum horizontal ground acceleration of 1.0g. The maximum ground displacement is 
taken proportional to the maximum groundacceleration, and is set at 36 inches for a ground 
acceleration of 1.0 g. The displacement regionlines of the Design Response Spectra are 
parallel to the maximum ground displacement line andare shown on the left of Figure 1. The 
velocity region lines slope downward from a frequency of0.25 cycles per second (cps) or 
Hertz (Hz) (control point D) to a frequency of 2.5 cps (controlpoint C) and are shown at the 
top. The remaining two sets of lines between the frequencies of 2.5cps and 33 cps (control 
point A), with a break at a frequency of 9 cps (control point B), constitutethe acceleration 
region of the horizontal Design Response Spectra. For frequencies higher than33 cps, the 
maximum ground acceleration line represents the Design Response Spectra. 
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a. Maximum ground displacement is taken proportional to maximum ground acceleration, and is 36 in. for ground acceleration of 
1.0 gravity. 

b. Acceleration and displacement amplification factor are taken from recommendations given in Newmark, N. M., John A. Blume, 
and Kanwar K. Kapur, “Design Response Spectra for Nuclear Power Plants,” American Society of Civil Engineers (ASCE) 

Structural Engineering Meeting, San Francisco, April 1973, (ADAMS Accession No. ML13207A044).  
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a. Maximum ground displacement is taken proportional to maximum ground acceleration and is 36 in. for ground acceleration of 
1.0 gravity. 

b. Acceleration amplification factors for the vertical design response spectra are equal to those for horizontal design response 

spectra at a given frequency, whereas displacement amplification factors are 2/3 those for horizontal design response spectra. 
These ratios between the amplification factors for the two design response spectra are in agreement with those recommended in  

Newmark, N. M., John A. Blume, and Kanwar K. Kapur, “Design Response Spectra for Nuclear Power Plants,” American 
Society of Civil Engineers (ASCE) Structural Engineering Meeting, San Francisco, April 1973, (ADAMS Accession No. 

ML13207A044). 

The Vertical Component 

The numerical values of design displacements, velocities, and accelerations in these spectra 
are obtained by multiplying the corresponding values of the maximum horizontal ground 
motion (acceleration = 1.0 g and displacement = 36 in.) by the factors given in Table 2. 

The vertical component Design Response Spectra corresponding to the maximum horizontal 
ground acceleration of 1.0 g are shown in Figure 2. The displacement region lines of the 
Design Response Spectra are parallel to the maximum ground displacement line and are 
shown on the left of Figure 2. The velocity region lines slope downward from a frequency of 
0.25 cps (control point D) to a frequency of 3.5 cps (control point C) and are shown at the 
top. The remaining two sets of lines between the frequencies of 3.5 cps and 33 cps (control 
point A), with a break at the frequency of 9 cps (control point B), constitute the acceleration 
region of the vertical Design Response Spectra. It should be noted that the vertical Design 
Response Spectra values are 2/3 those of the horizontal Design Response Spectra for 
frequencies less than 0.25; for frequencies higher than 3.5, they are the same, while the ratio 
varies between 2/3 and 1 for frequencies between 0.25 and 3.5. For frequencies higher than 
33 cps, the Design Response Spectra follow the maximum ground acceleration line. 

Note:  
Since the acceleration values below 2.5 cps and 3.5 cps for Horizontal Design Response 
Spectra and Vertical Design Response Spectra respectively are NOT given in the Figures 1 
and 2 above, the acceleration values corresponding to 2.5 cps (for Horizontal Design 
Response Spectra) and 3.5 cps (for Vertical Design Response Spectra) are entered for 0.1 cps 
in the respective directions. 

Similarly, the accelerations values above 33 cps and up to 60 cps are entered as 1.0 g in the 
respective directions. 
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A 

absolute sum, 91, 104 
acceleration, 92 
analyze, 36 
animate 

deflected shape, 189 
mode shape, 190 

automatic 
save, 10 

automatic node renumbering, 11, 61 
axes, 146 

symbol location in graphics, 146 
axial force, 77 
axial stiffness, 207, 210 

B 

ball joint 
displacements, 166 

batch file, 195 
example, 224 
export, 33, 229 
import, 194 

beam section library 
files, 27 

bellows 
displacements, 166 

bend 
check, 108 
incomplete, 108 
invalid, 108 
pressure correction, 83 
pressure stiffening, 83 

Bourdon effect, 83 
branch connection, 23 

stresses, 152 
branch line, 57 
branch nodes, 20 

C 

center, 141 
center of gravity, 191 
change, 59 
check 

bend, 108 
connections, 111 

code compliance, 152 
color code stresses, 185 
combine, 59 
command line operation, 195 
continuous rendering, 11 
coordinates, 107 
copy graphics, 138 
cut pipe, 21, 91 
cutoff frequency, 15, 18 

D 

damping 
harmonic load, 104 
time history, 103 

data types, 22 
deflected shape, 189 

animated, 189 
delete, 54 
design 

factor, 75 
direction sum, 100 
disable graphics editing, 10 
drawing size, 138 
duplicate last row, 70 
DXF file, 133, 137 
dynamic analysis 

friction, 85 

E 

edit 
copy, 38 
data, 38 
find and replace, 49 
menu, 38 
paste, 39 
type, 38 

elastic modulus, 81 
element forces, 162, 181 
element types, 21 
EMF file, 133, 136 
environment variable 

BOURDONP, 83 
EPS file, 133, 136 
exit, 171 
export 

3D Plant Design, 34 
mbf, 33 

F 

find and replace, 49 
find node, 73 
find text, 73 
First-level Checks, 183 
flange 

model 
files, 27 

report, 153 
font 

graphics, 12, 147 
printer, 135 

printer, 34, 175 
text, 10, 11, 89, 172 

force spectrum 
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convert time function, 118 
load, 119 
read from a text file, 118 

frequencies, 167 
friction 

in dynamic analysis, 85 
friction coefficient, 38 

G 

general, 10 
generate, 64, 66 
g-load, 91 
global 

axes, 56 
forces, 163 
origin, 16 
vertical axis, 86 

graphics, 72 
background, 147 
center, 141 
context menu, 128 
editing, 129 
font, 147 
hotkeys, 130 
previous view, 141 
print, 135 
recover, 148 
render, 143 
rotate, 130 
show, 142 
turn, 141 
view iso, 141 
view x, 140 
view y, 141 
view z, 141 
viewpoint, 130, 140 
zoom, 141 

graphics window, 127, 130 

H 

hanger 
report, 153 
to be designed, 23 

harmonic load, 104 
combination, 104 
damping, 104 
frequency, 105 
phase angle, 104 

harmonic response, 105 
hinge joint 

displacements, 166 
hotkeys 

graphics window, 130 
layout window, 19 
results window, 171 

I 

import, 9 
import model, 194 
insert, 54 

L 

layout window, 15 
liberal allowable stresses, 77 
list, 72 
load 

combinations, 95 
static seismic, 91 

load cases, 90 
force spectrum, 119 
print results, 174 

loads 
thermal, 91 

long radius, 205 
longitudinal 

pressure stress, 82 

M 

menus, 6 
graphics window menus, 135 

file menu, 135 
options menu, 146 
view menu, 140 

layout window menus, 27 
edit menu, 18, 38 
file menu, 18, 27 
help menu, 18 
loads menu, 18, 90 
misc menu, 18, 106 
options menu, 18, 74 
view menu, 18, 72 
window menu, 18, 125 

results window menus, 173 
merge, 28 
mode shapes, 132, 136, 183, 190 
mode sum, 100 
model file 

automatic save, 10 
backup, 10 
save, 27 

multiple split, 55 

N 

node 
find, 73 
increment, 89 

number of thermal loads, 79 
number of time steps, 102 
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O 

occasional load, 82, 92, 120 
occasional load., 92 
options menu, 74 
other element forces, 188 

P 

participation factor, 167 
period, 167 
phase angle 

harmonic load, 104 
piping code, 74 
plot title, 139 
PLT file, 133, 136 
Postscript, 133, 136 
pressure correction for bends, 83 
pressure stiffening in bends, 83 
pressure stress, 82 
previous view, 72, 141 
print, 135 

graphics, 135 
model, 34 
preview, 136, 138 
results, 174 

load cases, 174 
misc, 175 
model, 173 
to file, 177 

to file, 136 
printer, 135, 175 

font, 34, 175 

Q 

QA block, 37 

R 

recover graphics, 148 
redo, 71 
redraw, 143 
reference temperature, 15, 18, 78, 205 
regenerate, 70 
render, 143 
renumber nodes, 60 
report 

flange, 153 
hanger, 153 
rotating equipment, 153 

response spectrum, 85, 91, 116 
results window, 149 
RevisionRecord, 37 
rotate, 57 

S 

save, 19, 36 

automatic, 10 
shape factor, 96 
show nodes, 142 
SIF 

branch, 23 
user, 23 

slope, 56 
soil restraints, 154 
sorted stresses, 128, 150, 152, 172, 180, 185 
spectrum 

direction sum, 100 
mode sum, 100 

spectrum library, 113, 114 
files, 18, 27, 173 

spectrums, 113 
split, 55 

multiple, 55 
spring rate, 85, 215 
SRSS, 91, 93, 100 
static analysis, 75 
static seismic analysis, 92 
static seismic load, 91 
stiffness 

include hanger stiffness, 85 
stiffness matrix, 85 
stress range reduction factor, 77, 79 
stresses 

color coded, 185 
liberal allowable, 77 
occasional, 93 
sorted, 128, 180, 185 
thresholds, 187 

support load summary, 154 
support loads, 157 
sweepolet, 204 

T 

tangent intersection point, 24, 204 
tee 

extruded, 204 
fabricated, 204 
welding, 23, 204 

text 
find, 73 

thermal loads, 91 
threaded joint, 20, 23 
time functions, 120 
time history 

damping, 103 
output interval, 102 
time step, 102 

time history load, 102 
title 

plot, 139 
turn, 141 
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U 

undo, 70 
units 

English, 87 
Metric, 88 
SI, 87 

user allowables, 122 

V 

valve 
library 

files, 27 
Vertical Direction, 86 
view 

previous, 141 

viewpoint, 72, 140, 141 

W 

weldolet, 204 
wind load, 95 

shape factor, 96 
wind profile, 96 

Z 

zoom 
all, 72, 141 
in, 141 
out, 141 
window, 132 

 

 


