Tutorial on Analysis with Multiple Thermal Loads using CAEPIPE
General

The Reference Temperature (can be defined through Layout window > Options > Analysis” is “the
ambient temperature at which the pipe is to be/was initially installed”. In other words, when the whole
piping system is at Reference Temperature, the piping system is “stress free” and the involved pipe
supports are “loads free”, as long as there are NO cold springs introduced during the installation of the
system. There is no need to input Reference Pressure, as at installation the pressure is zero.

T1, T2 etc. (tuned ON through the “Layout window > Loads > Load cases”) refer to the temperatures
prevailing during different operational states of the piping system. Please note that the value of T1 for
the first operational state could be different for different portions of the piping system. In other words,
you could input multiple values for T1 (by having at least that many “Loads”) corresponding to different
portions of the piping. In addition, the same element in the piping system can experience different
temperatures T1, T2, T3 etc. during different operational states.

Hence, the Expansion (T1) case in the Results lists the “Range Solution” obtained for the temperature
range from Reference Temperature to T1 [i.e., (T1 — Tref)], similarly for Expansion (T2), and so on. The
Expansion (T1-T2) case in the Results lists the “Range Solution” obtained for the temperature range
from T1 to T2, which is internally computed as [(T1 - Tref) — (T2 — Tref)], similarly for Expansion (T1-T3)
and so on.

For the operating (W+P1+T1) case, CAEPIPE considers the weight, the pressure P1 corresponding to T1
and the expansion from Tref to T1.

The following are the Steps for performing Analysis with Multiple Thermal loads in CAEPIPE.

The attached stress system shows the layout of four (4) pipelines. These pipelines are connected to five
(5) centrifugal pumps at one end (with one of them being the Spare) and four (4) tanks at the other end.
Out of those 5 centrifugal pumps, Pump 2 is the Spare and will turn into operation when one of the
other 4 pumps fails. In other words, at any point in time, 4 pumps are operating with 1 pump either on
standby or not operational. To represent these, the following thermal load cases are required (see the
attached model).

Cases Description

Case 1 | Pump 2 (the Spare) is “OFF” and the remaining Pumps are “ON”

Case 2 | Pump 1 is “OFF” and the remaining Pumps (including Spare) are “ON”

Case 3 | Pump 3 is “OFF” and the remaining Pumps (including Spare) are “ON”

Case 4 | Pump 4 is “OFF” and the remaining Pumps (including Spare) are “ON”

)
)
)
)

Case 5 | Pump 5 is “OFF” and the remaining Pumps (including Spare) are “ON”
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Step 1:

The above cases can be defined in CAEPIPE by defining the “Number of Thermal loads” as 10 through
Layout window > Options > Analysis > Temperature.

Analysis Options

Code Temperature lPressure] D}mamics] Misc ]

Reference temperature 70 [F]
Mumber of thermal cycles (7000

Murnber of thermal load: 1 2 3 & 10

* Thermal = Operating - Sustained

" Solve thermal case

Elastic Modulus
" Use temperature dependent modulus

* se moduluz at reference termperature

QK | Cancel

Step 2:

Define the Pressures and Temperatures for different operating cases described above through CAEPIPE
Layout window > Misc > Loads. Description corresponding to Loads C1 through CHL is given in the table
below for clarity.

Cases Description Pressures and Temperatures

Case 1 | Spare Pump at Node 1010 is “OFF” and | For C1, T1 = 70 degF; P1 = 0O psi. For others
the remaining Pumps are “ON” (C2 through C5), T1 = 250 degF and P1 = 10.1

psi

Case 2 | Pump 1 at Node 10 is “OFF” and the | For C2, T2 = 70 degF; P2 = 0 psi. For others, T2
remaining Pumps are “ON” =250 degF and P2 = 10.1 psi

Case 3 | Pump 2 at Node 2010 is “OFF” and the | For C3, T3 = 70 degF; P3 = 0 psi. For others, T3
remaining Pumps are “ON” = 250 degF and P3 =10.1 psi

Case 4 | Pump 3 at Node 3010 is “OFF” and the | For C4, T4 = 70 degF; P4 = 0 psi. For others, T4
remaining Pumps are “ON” = 250 degF and P4 = 10.1 psi

Case 5 | Pump 4 at Node 4010 is “OFF” and the | For C5, T5 = 70 degF; P5 = 0 psi. For others, T5
remaining Pumps are “ON” = 250 degF and P5=10.1 psi

Load with name “CHL” is defined to represent the portion of the piping that are always HOT irrespective
of which pump is OFF. Hence, the T1 through T5 is 250 deg F and P1 through P5 is 10.1 psi.

The Load cases and Load combinations defined in the model can be seen using Layout window > Misc
> Loads and Layout Window > Loads > Load cases respectively.

Define the loads C1 through CHL as shown in the snap shot below.
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Step 3:

Assign the Loads C1 through CHL to different portions of stress system as required while creating the
stress layout. After modeling the stress system, one can review the loads assigned to different portions

using the Highlight feature through “Loads List window”.

From the attached model, to review the loads assigned, place the highlight on each load (C1
through CHL) and press “Ctrl+H” or select option “Highlight” under List window >View to highlight
only that portion of the model that is using that specific load. The snap shot below highlight only
that portion of the model that is using the Load C1.
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Step 4:

Select the load cases and load combinations required for analysis through Layout window > Loads >
Load cases.

Load cases (29)

[ Empty weight [w) v Expanzion [T1-T2) [ Expansion [T3- T9) [ Expansion [T9- T10)
v Sustained [w/+F) v Expanzion [T1-T3] | Expanzion [T3-T10] [+ Operating [t+F1+T1)
v Sustained [w/+P1] v Expanzion [T1- T4 V¥ Espangion (T4 - TH) W Operating fwW+P2+T2)
v Sustained [W+F2) v Expansion (T1 - T5] [ Expanzion (T4 - TH] [v Operating [w+F3+T3)]
[v Sustained fw+F3) [ Expanzion [T1 - TE] [ Expansion [T4-T7] Iv Operating [wW+Pd+T4]
v Sustained [w+P4) [ Expansion [T1-T7) [~ Evpansion (T4 - T8 W Operating Pw+P5+T5]
v Sustained [w+F5) [ Expansion [T1 - TH] [~ Expansion [T4-T49] [ Operating [w+PE+TE]
[ Sustained [w+PE] | Ewpansion [T1-T3) [ Ewxpansion (T4 - T10] [ Operating [W+P7+T7)
[ Sustained [wW+F7) [ Expanzion [T1-T10] [ Ewpansion [T5- TE] [ Operating Pw+PE+T 8]
[ Sustained [w'+P2) v Expansion (T2-T3) [ Expanzion [TS- T7) [ Operating [w+P3+T3)
[ Sustained [w'+P3) v Expansion [T2 - T4) [ Expanzion (TS - T8 [ Operating [w+P10+T10]
[ Sustained [w/+P10) v Expansion (T2- T5] [ Expanzion (TS5 -T9] [ Design ' +FD+TD]
v Erpansion [T1] [ Expanzion (T2 - TH] | Expanzion [T5-T10] [+ Static zeizmic [g's)

v Expansion [T2] [ Ewpansion (T2- T7) [~ Ewpansion (TE - T7) Vv wind

v Expansion (T3] | Ewpanzion (T2 - T8 [~ Ewpansion (TE - T8 v wind 2

Iv Expansion [T4) [ Expansion [T2- T4 [ Expansion [TE - T4 [ Modal analysiz

v E=pansion [T5] [ Expanzion [TZ2-T10] [ Ewpanzion [TE - T10)

[ E=pansion [TE] [v Ewxpanzion [T3- T4] [ Expanzion [T7 - T8

[ E=pansion [T7] [+ Expanzion [T3- TH] [ Expansion [T7 - T4

[ E=pansion [T8] [ Expanzion [T3- TH] [ Ewpanzion [T - T10]

[ Expansion [T9) [ Expanzion [T3-T7) [ Expanzion [T2-T9)

[ E=pansion [T10] [ Expansion [T3- T8 [ Expanzion [T8- T10]
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Step 5:
Save the model and perform analysis through Layout window > File > Analyze.

In order to understand the loads and load combinations used for analysis, review the CAEPIPE results file
for Support Loads (loads acting on the supports by the piping for each load case), Element Forces &
Moments (local/global forces and moments on each element for each load case) and Support Load
Summary (listing support loads at particular support for all relevant load cases and load combinations).
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10 a7 |1es  [s@ | |5
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Load combination |FX(lb) [FY (bl |FZ(b) |MX(flb) [ MY (ft-b) | MZ (ft-lb]
Sustained -165 1 4 42 58 5695
Operating1 A7 168 887 25 5 283
Operating2 -230 38 753 53 a1 573
Dperating3 222 -4 343 37 78 57139
Opertatingd -222 -4 843 37 78 5720
Operating -222 -4 843 7 78 5720
Sustained+#wind | -165 1" 4 42 58 -5E35
Operatingl +wind |17 163 287 -25 5 283
Operating2+wind | -230 38 753 53 81 573
Operating3+wind | -222 -4 843 7 78 5719
Operatingd+Wwind | -222 -4 843 7 78 5720
Operating5+Wind  |-222 -4 843 37 78 5720
Sustained+wind 2 |-165 1 4 42 58 5635
Operatingl +wind 2 | 17 -169 887 -25 5 283
Operating2+Wwind 2 | -230 i 7583 53 a1 573
DOperating3+wWind 2 | -222 -4 843 7 78 5719
Operatingd+wind 2 | -222 -4 843 37 78 5720
Operatingd+wind 2 | -222 -4 843 7 78 5720
Sustained+Seismic | -159 1 57 45 61 -BE52
Sustained-Seismic  |-172 10 -43 40 55 5738
Operating +Seismic | -10 168 940 22 8 326
Operatingl-Seismic | -23 170 834 -28 2 pL|
Operating2+Seismic | -224 33 806 56 84 5689
Dperating2-Seismic | -236 38 700 50 73 5774
Operating3+Seismic | -216 -4 896 40 a1 5677
Operating3-Seismic | -228 5 740 34 75 5762
Operatingd+Seismic | -216 -4 836 40 a1 BE78
Dperatingd-Seismic | -228 5 790 34 75 5763
Operating5+Seismic | -216 -4 836 40 81 5678
Operating5-Seismic | -228 5 790 34 75 5763
M aximum -10 33 540 56 84 326
Minimurn -236 170 -43 -28 2 5774
Allowables 0 0 0 0 0 0

The Sorted Stresses in CAEPIPE lists the maximum of Expansion stresses for all thermal range cases at
each node as well as the maximum of Sustained + Occasional stresses for all Occasional cases at each
node. On the other hand, for the Sustained case, it always uses the maximum pressure among the input
pressures (P1 through P10) while computing Sustained Stress at each node.



== Caepipe : B31.1 (2020) Code compliance (Sorted stresses) - [MultipleThermallLoads.res (C\Tutorials\03.. — O

Eile Results View Options Window Help
& DA e BHR
Sustained Expansion Occasional ~

# SL [SH |5L_ SE [SA [SE_ SO (1.25H|S0__
Node |(psi) |[psi] |SH |Node |(psi] |[psi] |SA& |Mode |(psi) [(psi] [1.25H

1 |77004A | 4653 | 13450 | 0.35( 1204 | 7160(33391|0.21)904 |4916|16140|0.30

2 (904 |4631|13450|0.34 | 77004 | 6614 (33034 | 0.21) 77004 | 4700 | 16140 0.29

3 (1204 | 4297 |13450|0.32(1208 |5920(29521|0.20) 1204 | 4559816140 0.28

4 [90B | 3740|13450(0.28| 41104 | 7336 (37146 | 0.20| 1208 | 3354 | 16140 0.24

5 (1004 |3738|13450(0.28| 21104 | 7075 (36997 | 019|908 | 3891 |16140(0.24

6 [120B |3704|13450|025| 21204 | 6671 [36925|0.19) 1004 | 388916140 0.24

7 |105 |3352 (13450 (025|904 | 5321 |28934 | 018|105 | 3605 (16140(0.22

8 |25 3118{13450|0.23| 31104 [6739 (37023 | 018 25 3142 (16140(019

3 |20 3111 (13450 0.23| 31204 | 6488 | 37191 |017] 20 3134 (16140(019

10 (80 2938 (13450 | 0.22 | 41204 | 6038 | 36721 | 0.16] 80 2981 [16140(0.18

11 [110B | 2538 (13450 (019| 1104 | 5456 | 36534 | 0151108 | 2721 [16140(017

12 | 2105 | 245413450 0.18] 40304 | 5308 | 35872 | 0.15] 2105 | 2683 | 16140({017

13 20904 | 231513450 (017 |20 4253 (30514 | 014 20904 | 2631 | 16140 (016

14 (3105 | 2307 |13450| 017|908 |4033(298685|013) 3105 |2532|16140|0.16

15 [100B |2247 [13450(017| 1004 |4029(29987 |0.13]|100B | 2506 16140016 o,

Similarly, Code Compliance report lists the Stresses element-wise following the same procedure as done
for Sorted Stresses.
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& A E e

Press. Sustained Expansion Occasional ~
B INode |allow [SL |SH [SL_|SE [s&a [SE_ S0 [1.25H (SO
[psi) |lpsi) |(psi) |SH |(psi) |(psil [SA |lpsi) |[psi] [1.25H
20 101 | 3111 (13450 0.23| 4253 | 30514 | 0.14| 3134 (16140 |0.19
25 250 1311713450 0.231 3273 | 30508 | 0.11 | 314216140 0.19
25 101 |3118{13450|0.23| 3275 | 30807 | 0.11| 3142 (16140 |0.19
30 1926 (13450 (0.14) 1929 | 31693 [0.06| 194516140012
30 101 | 1924 (134500141982 | 31701 | 0.06| 1943 (16140 |0.12
i) 2171|1939 (134500141986 | 31686 | 0.06| 1959 (16140012
40 101 | 1979 (134500151992 | 31646 | 0.06| 2005 (16140 |0.12
50 211 | 2115(13450|0.16| 2006 | 31510 | 0.06 | 2160 (16140013
50 101 |2115{13450|0.16| 2006 | 31510 | 0.06| 2160 (16140 |0.13
B0 211 | 1990{13450|0.15] 2011 | 31635 | 0.06| 2014 (16140 (0,12
70 101 | 1978 (13450|0.15]| 2052 | 31647 | 0.06| 2002 (16140 |0.12
80 211 | 2863 (13450 |0.21| 2762 | 30762 | 0.09| 2914 (16140 |0.18
80 101 | 2388 (13450018 2162 | 31237 | 0.07 | 2462 (16140 | 0.15
908|211 | 156413450 0121361 [ 32061 | 0.04 | 1637 [ 16140 | 0.10
904 |101 |4631(13450|0.34)| 5321 | 28334 (0.18| 4916 (16140 | 0.30
0B  |140 |3740|13450(0.28| 4033 (29885 (0.13| 3891 | 16140|0.24

0B |10 |1224|13450|0.09)| 988 | 32401 |0.03| 1266 [ 16140 0.08
1008 (211 |1224|13450|0.03| 987 | 32401 |0.03|1265(16140|0.08

of ®| N o o] =] <] ©] =




