Tutorial on Refrigeration Piping using CAEPIPE

Steps to perform Analysis of Refrigeration Piping with ASME B31.5 Code using CAEPIPE:

The snap shot below shows the sample layout of a refrigeration piping system. The system experiences
two (2) different temperatures during its operation (from -50 deg. F to 200 deg. F) with installation
temperature as 70 deg. F. Being refrigeration piping, the analysis code is selected as ASME B31.5 for this
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Step 1:

Select the Analysis code as ASME B31.5 through Layout Window > Options > Analysis as shown below.

s Options

Code |Temperature; Pressure | Dynamics | Mise |

Piping code

[~ Use B31J for SIFs and Flesibility Factors
¥ Include axial force in stress calculations

W Use liberal allowable stresses

QK ; Cancel




Step 2:

As the piping layout involves two (2) operating temperatures, “Number of Thermal Loads” needs to be
set as “2”. This can be done through Layout Window > Analysis > Temperature as shown below. In
addition, the installation temperature (same as “Reference temperature”) can be input as shown below.

Analysis Options

Code Temperature |F‘re55ure; Djmamics} Misc ;

Reference temperature 1 [F]
Mumber of thermal cycles ]?EIEID

Mumber of thermal loads 1 & 2 3 10

& Thermal = Operating - Sustained
' Solve thermal caze

r Elastic Modulus
| e
= |

Note:

As per para. 519.4.5(a) of ASME B31.5 (2016), bending and torsional stresses shall be computed using
the as-installed modulus of elasticity, i.e., E. at installation temperature (same as “Reference
temperature”). Hence, "Use modulus at reference temperature" is set as "default" and is disabled for
user to modify.

Step 3:

Enter the Operating temperatures of the piping layout through “Layout Window > Misc > Loads” as
shown below.

=i= Caepipe: Loads (1) - [RefrigerationPiping.res (C\Tutorials\04_RefrigerationPiping)]
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Name T2 |P2 |Desq.T |DesgPr. |Specific | AddWat |Wind |Wind |Wind |Wind
(F) |[psil|(F) |lpsi)|IF) [psi) aravity | (Ib/f) Load 1|Load 2| Load 3| Load 4

1 L1 -50 |100 | 200 | 100 | 240 125 0.01

B
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Note:

Design Temperature entered will be used to determine the allowable stress for material, which is in turn
used to compute the Allowable Pressure as per the piping code selected (B31.5 in this case).

The Allowable Pressure so computed as per the piping code selected is then compared against the
Design Pressure entered above and reported in the Code Compliance results.

In addition, starting CAEPIPE Version 10.20, a new load case called “Design (W+PD+TD)” is added. When
this load case is selected for Analysis, CAEPIPE will compute and show results for Displacements,



Element Forces & Moments, Support Loads and Support Load Summary. This load cases is NOT included
in Stress Calculations, Rotating Equipment Qualifications and Flange Equivalent Pressure Calculations.

Step 4:

Select the material properties corresponding to “A53 Grade A” through “Layout Window > Misc >
Materials > File > Library...”.

Material Library - [B315-2016.mat (...

Fiping code : B31.5

Material Description ~
AG3 Grade &

AB3 Grade B

A10E Grade &

A10E Grade B

A10E Grade C

AP BL Grade A&

AP BL Grade B

A312 TPA04 [18C-8Mi)

A312 TRA04L [180-8Mi)

Monel B165 Annealed-[Mi-Cu)

Copper B42 Annealed

Copper B42 Drawn, Size(1/8-2"] ]

(] | Cancel | Libramy |

From the dialog box shown, select the Material library as B315-2016 from the folder “Material_Library”
available inside the CAEPIPE installation folder. Once selected, highlight the material as shown above
and press the button “OK”.
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Mame Description | Ty | Density (Mu |Joint | # | Temp |E Alpha | Allowable
pe | (Ib/in3] factaor [F [p=i] [|n£|n.-’F] [p=i]

k53 &453Grade A (C5|0.283 (0.3 [1.00 20 | 29.9E+E | 5.89E-E | 13700
70 | 235E+5 | B.0SE-E | 13700
100 | 23.3E+5 | B.14E-B | 13700
160 | 231E+E | B.24E-E | 13700
200 | 23.8E+E|B.35E-E | 13700
250 |28 6E+E|E.EZE-E | 13700
300 | 28.3E+6|B.88E-E | 13700
350 | 28.0E+E|B.85E-E | 13700
400 | 27.7E+E|B.8ZE-E | 13700




Step 5:

Define the section properties through “Layout Window > Misc > Sections”.
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Mame |Maom | Sch |0 Thk | Cordl [M.Tol|Ihe Dens | Ine Thi | LinDens | Lin Thk | Sail
Dia [|nu:h] finch] |finch] |21 | (bAE) | inch] | [IBA3) | [inch)

1B B" 105 |E.E25 (0134
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Step 6:

Generate the piping layout as shown below.
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Step 7:

After creating the stress model, turn ON load cases through “Layout Window > Loads > Load cases as
shown below.

Expansion (T1) {which is the same as the range (T1 — Tref)}, Expansion (T2) {which is the same as the
range (T2 — Tref)}, and Expansion (T1 —T2) [= (T1 — Tref) - (T2 — Tref)].

Load cases (&)

[ Ernpty Weight [w] Iv Operating (w/+P1+T1]

v Sustained [wW+P) [v Dperating [wW+P2+T2)
¥ Expansion [T1] [ Design [w+PD+TD]
¥ Expansion [T2] [~ Modal analysis

V¥ Expansion [T1-T2)

0k | Cancel [ a1 | nNone |




After analysis, Expansion Stress (SE) value given at any node in Results Window > Sorted stresses and
Results Window > Code compliance is the highest thermal stress range at that node among the three
thermal ranges (T1 —Tref), (T2 — Tref) and (T1 - T2).

Step 8:
Save the model and perform analysis through Layout window > File > Analyze.

In order to understand the loads and load combinations used for analysis, review the CAEPIPE results file
for Sorted Stress, Code Compliance, Displacements, Support Loads (loads acting on the supports by the
piping for each load case), Element Forces & Moments (local/global forces and moments on each
element for each load case) and Support Load Summary (listing support loads at a particular support for
all relevant load cases and load combinations).

As stated above, Sorted Stresses in CAEPIPE lists the maximum of Expansion stresses for all thermal
range cases at each node. On the other hand, for Sustained case, it always uses the maximum pressure
among the input pressures (P1 and P2 in this case) while computing Sustained Stress at each node.
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A EE= BB

Susztained E xpansion
# 5L [sH  [sL SE [sa  [SE_
Mode | [psi] |[ps] [SH |Mode|[ps] |(psi] |54

10 | 1721 (13700 013 304 | 1116 32700 | 0.02
304 |1850(13700| 071110 | 102532529 | 0.03
30B | 1434 (13700|011|70B | 780 |32883|0.02
70B | 1367 (13700|0.10) 308 | 758 | 32756 |0.02
200 |1342(13700| 010|704 | 587 | 33006|0.02
B04 | 1322(13700| 00| 60B | 525 |33000|0.02
40 |1286(13700|0.09)20 | 323 |32308|0.01
130 |1283(13700|0.09) 110 | 206 |33247|0.01
80 |1276(13700|0.09)120 |1839 | 33231 |0.01
30 |1273(13700| 00980 |179 |32374|0.01
50 |1273(13700| 009|604 |166 |32328|0.01
100 |1271(13700| 009|390 |128 |32377|0.00
GOB | 1250(13700|0.09{100 |105 |32379|0.00
704 | 1244 (13700| 0090130 |98 | 32967 |0.00
120 | 1019(13700| 00740 |70 | 32364 |0.00
10 | 1003(13700|007|50 |13 |32377|0.00
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Operating Stress for Impact Test can be seen by selecting the option “Show Operating Stress for Impact
Test” through Mouse Right click.
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Sustained Eupanszion

# L [sH  [sL_ SE [sa  [SE_
Mode | [psi] [[psi) |SH |Mode|(pz] [[psi] |SA&

1 |10 [1721 13700 (013304 | 1116 | 32700 |0.03

|2 |304 (155013700 (011[10 | 1025 |32529 | 0.03

|3 |308 (149413700 (011|708 |780 |32883|0.02

4 |70B |1367 | 13700 (010|308 | 758 |32756|0.02

5 |20 |1342|13700|010| 70 Show Stresses

& |e60a |1322|13700|010) 60 .

— Show Stress Ratios

7 |40 |1286|13700|009| 20

& (130 |1283 13700 |o0a | 11 e s

3 |80 |1276|13700|009)1z2 Show Operating Stress for Impact Test

10|90 |1273|13700|0.09) 80 Hide Allowables

11|80 |1273|13700 009 | 60,

— Results...

(112|100 (1271 |13700 (0.05| 30

13]608 {1250 13700 |0.09| 10 =

14| 704 |1244 |13700|0.08]13 Previous Result

115|120 (101913700 (00740 |70 |32964 |0.00

(16|10 1003 13700 (0.07[50 |19 |32977 |0.00
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Sustained E xpanzion Oper. Stress for Impact Test
& 5L |5H SL SE |5A SE Sopr |Sall | Sopr
Mode |[psi] [[ps] [SH |Mode|(psi] |(psil |SA |Mode |[[psi] |[[pz] [Sal

1 |10 172113700013 304 | 1116( 32700 0.03 ] 306 1828 |4795 (038
(2 |206 [1560|13700| 01110 |1025| 32529 | 0.03] FoB 1724 14795 [0.26
'3 [208 |1434 13700011708 |7E0 |32ms3|ooz|roe 1513|4795 |03z
"4 |7o0e [1367|13700|00] 208 |78 | 3276e|0.02| soe 1464 14795 |03
5 |20 |1342|13700|010] 7oe [587 |33006|002|a0e  |1434 |4795 |00
5 |goa [1322|13700|010] 508|525 | 23000|0.02| 0 1358|4735 [0.28
7 40 |1286|13v00|009] 20 |323 |32908|00 |90 1331 | 4735 [0.28
'8 130 [1283|13700 (009|110 (208 |3z2ar |0 | 130 1329|4735 [0.28
'3 |80 [1276|13v00|009]120 |189 |33 {00100 1319 | 4795 [0.28
(10]a0  [1273|13ro0 (0090|173 | 32974 |0 |40 1306 14795 [0.27
11|50 |1273|13v00|0.09] B0 | 166 |32928 |00 |20 1273 14795 [0.27
[12]100 [1271|13700 (009|950 |128 | 32977 |0.00|s0 1269|4795 [0.26
(12|08 [1250|13700 (009100 |105 |3297a|0.00f10 1260 | 4795 [0.26
14|700 124413700 009|130 |98 |32ge7|oo0|Ene  |1245 [4795 |08
'15]120 1013|1300 (00740 |70 |32364|0.00 120 1106 | 47395 [0.23
16[110 |1003|13v00|007|50 |19 32977 |0.00] 110 1097 14735 [0.23

Similarly, Code Compliance report lists the Stresses element-wise following the same procedure as done
for Sorted Stresses.
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Press. Suztained E wpansion

B (Mode|alow [SL [5H [sL [s5E [sa i
(psil | [pzi] |lpsil |SH | [psi) |[ps] | SA

10 125 | 1721 | 13700 0,13 1025 | 32529 0.03
20 1342 13700 | 010 323 | 32908 | 0.01
200|125 |1342 (137000100 323 (32908 |0.01
308 (BE3 | 1324 113700010 34 [ 32926 0.00
304 (125 |1580(13700)0.11 | 1116 | 32700 0.03

30B |BE3 | 1454 (13700 011| 758 | 32756

0B 125 |1326(13700| 010 221 32324
40 |563 |1286|13700|0.03| 70  [32364

400|125 |1286(13700|0.03|70 | 32964 (0.00
50 |BE3 |1273(13700|0.03|13 |32977(0.00
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BO& | 563 |1260|13700 (003|565 [32390(0.00

BO& | 125 |1322(13700|010) 166 | 32928 (0.01
EOE |BE3 |1250(13700|0.03|525 |33000(0.02

GOB 125 |1240(13700|0.03| 149 (33010(0.00
704 563 |12393|13700(0.03| 167 | 33011 |0

04 | 125 | 1244 (13700 009|587 | 33006 (0.02
0B |BE3 | 1367 (13700|010| 780 | 32283 (0.02

0B (125 |1273|13700(0.09| 227 | 32971 |00
80 |BE3 |1276|13700| 009|179 (32974 (000 o,

From the Displacement results for Expansion (T1) and Expansion (T1-T2), it is observed that the
Displacements are +ve in Global Y direction confirming that the piping is shrinking due to temperature
decrease for both expansion cases.
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Displacemants [global]

Made [* [inch] | [inch] (£ [inch] [# [deg] [ v [deq) | ££ [deq]
10 0ooo (0000 | 0000 00000 (0.0000 | 0.0000

20 goog (0000|0000 Qo000 |(0.0000 |-0.0019
304 |0.008 |0000 (0000 00000 (0.0000 | -0.0020
30B |03 |0.008 (0000 00000 (00000 |05l
40 0002 |0.044 0000 00000 (0.0000 |-0.0170
50 0007|0057 |0.000 0oood (00000 |00A
GOA |-0.013 |0.0B9  (0.000 0oooo (00000 |001A
EOE |-0.009 |0.077 (0000 00000 (00000 |-0m2s
FOA |-0.007 |0078 (0000 Qo000 (00000 | 00124
VOB |0.000 0073 (0000 00000 (00000 |-0.009
a0 oooo o |0.081 0.000 Qo000 |(0.0000 | -0.0011
12190 0.0m 0043 (0.000 00000 |(0.0000 | -0.0004
[13]100 |00 0.043 (0,000 00000 (0.0000 | -0.000
[14]110 |oom 0033 (0000 00000 |0.0000 | 0.0001

15120 (0000 |0.004 | 0.000 0.0000  (0.0000 | 0.0002

16130 (0000 |0.000  |0.000 Q0000 |(0.0000 | 0.0000
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=l= Caepipe: Displacements: Expansion (T1-T2) - [Refriger...

Displacements [global)
Made (¥ [inch] | [inch] |Z [inch] |# [deg] | v [deq] | ZZ [deq)
1 |10 |0000 (0000 (0000  (0.0000 |0.0000 |0.0000
(2 |20 |om? |oooo |oooo |ooooo |ooooo |04z
(3 302 |oms [oom 0.000 00000 |0.0000 |-0.0044
4 308 |0028 |oo017 |0000 |ooo000 [oooo0 |00
5 |40 |0o04 |oose [ooo0 [ooooo |ooooo |-0o03F2
6 |50 |06 |0126 |oo0o0 [ooooo |ooood |-0.03S
7 |g0s |-0027 |0152 |oo0o0 [ooooo |ooooo |-0033
5 (6B |0ms |07 0.000 00000 |00000 |-0.0274
(5 |7os |0me |07z |oooo |ooooo |ooooo |-ooere
(qolroe |oooo [ooer 0.000 00000 |00000 |-0.0043
ERET 0135 0000 |0.0000 |0.0000 (-0.0024
12]90  |oom 0107 |0.000 |00000 |0.0000 |(-0.0003
13]100 |0.0m 0035 |0.000 |00000 |00000 |(-0.0004
14]110 | 0.0m 0086 0000 (00000 (00000 |0.0001
(15120 |oooo |ooos [oooo |ooooo [ooooo |o.ooos
(16130 |oooo |oooo [oooo |ooooo [ooooo |o.ooo0o

Similarly, from the Displacement results for Expansion (T2), it is observed that the Displacements are -ve
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in Global Y direction confirming that the piping is expanding downward due to temperature increase.
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=i~ Caepipe: Displacements: Expansion (T2) - [Refrigerati...

Displacements [global)

Mode | % (inch] |7 [inch] |2 [inch] ¥ [deg] | [deq) | ZZ [deq)
1 (10 0000 {0000 (0000 (0.0000 |0.0000 |0.0000
2 |20 |-0o003 |0o00 |oooo |oooon |ooooo o023
3 304 |0mo |-0000 {0000 |0.0000 00000 |0.0024
4 208 |-oms |0o08 |oooo |oooon |ooooo |oairs
5 |40 |oo02 |-0054 0000 |00000 00000 |0.0202
& |50 |ooos |-ooes {0000 {00000 00000 | 000203
7 [s0e |oms  |0oe3 o000 |oooon |ooooo |o.20z
@ |eoB |0o10 |-0033 0000 |00000 00000 |0.0149
9 |70e 0009 |-0094 {0000 |0.0000 00000 |0.0148
f0|70e |oooo |-0o0ee {0000 (00000 00000 |0.0023
11|e0 |.o0o0 |-0074 {0000 {00000 00000 |0.0013
1z|a0 |00 |00ss o000 |oooon |ooooo |o.oo0m
13100 0001|0052 {0000 {00000 00000 |0.0003
(14|110 |.0001 |-0047 (0000 {00000 |0.0000 |-0.0000
(15[120 |oooo |0o05 {0000 |o.0000 |o0000 |-0.0003
16]130 |oooo |oooo o000 {00000 |o.0000 |o0.0000

Element Forces & Moments (local forces and moments on each element for Expansion (T2) load case)

are shown below.
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=i (Caepipe : Pipe forces in local coordinates: Expansion (T2) - [RefrigerationPiping.res... — O
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] Ee=D> Ee te
B [Mode |dwial  |vShear|z Shear|  Torzion(ft-b) Inplanelft-Ib] Dutplane]ft-Ib) Flex. Factors SE A~
[[[=]] [[[=]] [[=]] Moment | SIF Moment | SIF Moment | SIF FFi |FFo |FFt |[psi]
1 (1o |7 -20 I I -B1 1.00 I 1.00 B5E
| 20 |7 -20 I I B3 1.00 I 1.00 175
2 (2o |7 -20 I I -63 I 175
308 |7 -20 1] 1] -B1 1] 170
3 (30 |7 20 a a E1 359 a 2499 137411374 EOE
| 30B |20 7 a a 41 359 a 2499 137411374 411
4 [30B |20 7 I I -41 I 120
40 |20 7 I I -1 I 38
5 (40 (20 -7 1] 1] -1 1] 3B
50 |20 -7 a a -1 a 1
6 (50 (20 7 a a Rl a 1A
| B4 |20 7 a a g a a0
7 [B0& (20 7 I I a 359 I 299 137411374 a0
BOB |-7 -20 1] 1] 28 359 1] 2499 137411374 285
g |coB |-7 -20 a a 28 a 5l
| o |7 -20 a a 32 a a0
9 [7oa |7 -20 I I 32 359 I 2499 13741374 3B
VOB |-20 7 I I 42 359 I 2499 13741374 423
10(70B |-20 7 1] 1] -42 1] 123
g0 |-20 -7 a a 32 a 97
11|80 |-20 7 a a -32 a a7
_SEI -20 7 a a -22 a B3

Element Forces & Moments (global forces and moments on each element for Expansion (T2) load case)
are shown below.

*i* Caepipe: Pipe forces in global
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S HED GR B Ee=s &
# |Mode|F< |FY [F2 [Mx MY [MZ o~
(k) |0&) | 0b) | (ft-Ib) | (Re-B] | (ft-I)
110 |7 |20 (0 0 1] -1
a0 |7 -20 |0 0 0 E3
2|20 |7 |20 |0 0 1] -£3
o |7 -20 |0 0 0 &1
3 |30e |7 |20 |0 0 1] A1
e |7 -20 |0 0 1] 41
4 1308 |7 |20 |0 0 1] -41
0 |7 -20 |0 0 1] 11
5|40 |7 |20 |0 0 1 11
B0 |7 -20 |0 0 0 1
E |80 |7 |20 |0 0 1 -
BO& |7 -20 |0 0 0 -
7o|e0& |7 |20 (0 0 1] g8
EOE |7 -20 |0 0 0 -28
8 |BOB |7 |20 (O 0 1] 28
0|7 -20 |0 0 1] -32
9 |70 |7 |20 |0 0 1] 3z
B |7 -20 |0 0 0 -42
10708 |7 |20 (0 0 1 42
a7 -20 |0 0 0 -32
180 |7 |20 (0 0 1 32
[ |7 -20 |0 0 0 22




Support Loads on all supports by the piping for Operating Load case 1 are shown below.

=I* Caepipe: Loads on Anchors: Operating (W+P1+T1) - [RefrigerationPipi..  — O
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Ee= S e

B [Mode|Tag|[F(Ib] |FY(lb) |FZ0b] [ M [f-b]) MY (F-0] | M2 (f-B]
1 (10 -8 -l 1] o o 47
2 (130 = 106 1] o o 13

Support Load Summary (listing loads on a particular support by the piping) for all relevant load cases and
load combinations) is shown below.

=li= Caepipe : Support load summary for anchor at node 10 - [RefrigerationPiping.re.. — O
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Load combination |FX (b]  [FY(b) |FZ(b] [MX (ft-b) | MY [ft-lb) | MZ (ft-b)
Sustained -2 -7 0 1] 0 15
Operatingl -8 70 1] 1] 0 47
Operating2 5 -107 0 1] 0 196

M axirmum 5 -70 0 0 0 196
Minimum a8 -107 0 1] 0 47
Allowables 0 1] 0 1] 0 1]




